Still problems with 5160 and Mac Pro

Discussion in 'Installation and Configuration of Parallels Desktop' started by skeedatl, Sep 12, 2007.

  1. skeedatl

    skeedatl Member

    2-3 Display Adapters with 5160 and Mac Pro No Workie

    I just installed the latest build of 5160 (9/12/07) and now I get memory allocation errors, even after rebooting and even when trying very low memory settings.

    I run 3 display adapters in my Mac Pro, a Radeon X1900 and 2 7300GTs. With all 3 I get the allocation error. A 2nd attempt at starting the VM whether I change memory settings or not results in Parallels crashing. If I run the Radeon and and 1 7300GT I can start the VM and get the Admin password dialog but then Parallels crashes. If I remove both 7300GTs leaving just the Radeon, everything runs fine. Below is part of the error log I get when Parallels chokes.

    I didn't have this problem running multiple adapters with the previous retail (as in non-beta) build. But 5160 did fix the memory allocation errors I was getting (so long as I only run 1 video card).

    Version: 3.0 (3.0 Build 5160.0)

    PID: 391
    Thread: 0

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_INVALID_ADDRESS (0x0001) at 0x0280c004

    Thread 0 Crashed:
    0 ...ple.CoreServices.OSServices 0x90fc4fb8 DynamicArray::getFirstNumber() const + 6
    1 ...ple.CoreServices.OSServices 0x90f6a9e9 CCFindArraySegment + 23
    2 ...ple.CoreServices.OSServices 0x90f6a9a8 CCArrayGetEntryPtr + 26
    3 ...ple.CoreServices.OSServices 0x90f75ac2 CLocalRefToSharedStorageEntry::GetLoadedData(long) const + 170
    4 ...ple.CoreServices.OSServices 0x90f759b6 CIconStorageEntry::GetData(long) + 26
    5 ...ple.CoreServices.OSServices 0x90f758f1 CIconStorageEntry::GetDataInfo(long, unsigned long, _ISStorageDataInfo*) + 35
    6 ...ple.CoreServices.OSServices 0x90f758c6 _ISGetStorageDataInfo + 58
    7 0x917e9ecc ISStorageRefDataInfoGetter(void*, long, _ISIconInfo*) + 50
    8 0x917e9cfb ISGetBestCGImageForIndexedStorageData(void*, CGSize, _ISIconStorageCallbacks const*, unsigned char, _ISBitmapImageInfo*, CGImage**) + 1141
    9 0x917e8c79 ISGetCGImageRefForISImageRef(void*, CGSize, short, RGBColor const*, unsigned long, _ISImageRefCallbacks const*, CGRect*) + 781
    10 0x917e84de PlotISImageRefInContext(void*, CGContext*, CGRect, short, short, RGBColor const*, unsigned long, _ISImageRefCallbacks const*) + 338
    11 0x917e82b1 PlotIconRefInContext + 213
    12 com.parallels.desktop 0x0047288e 0x1000 + 4659342
    13 com.parallels.desktop 0x0058705f 0x1000 + 5791839
    14 com.parallels.desktop 0x001cfcf9 0x1000 + 1895673
    15 com.parallels.desktop 0x001d4b94 0x1000 + 1915796
    16 com.parallels.desktop 0x001d5fd6 0x1000 + 1920982
    17 com.parallels.desktop 0x001436ef 0x1000 + 1320687
    18 com.parallels.desktop 0x001474a1 0x1000 + 1336481
    19 com.parallels.desktop 0x0014e10c 0x1000 + 1364236
    20 com.parallels.desktop 0x0039f62c 0x1000 + 3794476
    21 com.parallels.desktop 0x003c7c07 0x1000 + 3959815
    22 com.parallels.desktop 0x005d491b 0x1000 + 6109467
    23 com.parallels.desktop 0x003d3a8f 0x1000 + 4008591
    24 com.parallels.desktop 0x003d3c7d 0x1000 + 4009085
    25 com.parallels.desktop 0x003f8801 0x1000 + 4159489
    26 com.parallels.desktop 0x003d4ad6 0x1000 + 4012758
    27 com.parallels.desktop 0x003d0c24 0x1000 + 3996708
    28 com.parallels.desktop 0x003bee45 0x1000 + 3923525
    29 com.parallels.desktop 0x003c41d1 0x1000 + 3944913
    30 com.parallels.desktop 0x00460b3e 0x1000 + 4586302
    31 0x92dec537 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1093
    32 0x92debbdc SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 304
    33 0x92df2fbc SendEventToEventTarget + 56
    34 0x92df344f ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 1169
    35 0x92dec8ee DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 2044
    36 0x92debbdc SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 304
    37 0x92df2fbc SendEventToEventTarget + 56
    38 com.parallels.desktop 0x0045954a 0x1000 + 4556106
    39 com.parallels.desktop 0x00660d71 0x1000 + 6684017
    40 com.parallels.desktop 0x005fbbab 0x1000 + 6269867
    41 com.parallels.desktop 0x005fbcc4 0x1000 + 6270148
    42 com.parallels.desktop 0x003d72fd 0x1000 + 4023037
    43 com.parallels.desktop 0x000436c9 0x1000 + 272073
    44 com.parallels.desktop 0x00006372 0x1000 + 21362
    45 com.parallels.desktop 0x00006299 0x1000 + 21145
    Last edited: Sep 12, 2007
  2. skeedatl

    skeedatl Member

    Couldn't wait any more for support and had to uninstall 5160 and go back to 4560 which works with the multiple display adapters. I with these final releases were actually tested thoroughly before being called finals.
  3. wonder_mice

    wonder_mice Hunter


    Is this happens on English build of Parallels Desktop? Or you have some other language?
  4. skeedatl

    skeedatl Member

    It's the English build 5160 final from 11 Sept 2007.
  5. Jeff Lavoie

    Jeff Lavoie Bit poster

    Fix 5160 - .parallels_settings corrupted

    The cause of this issue is a either a corruption or failure to replace the parallels settings file in your root directory.

    To fix this you need to delete a Unix hidden file in the root of your home directory.
    Launch Terminal and enter the following command replacing <username> with your MAC OS X login name

    rm /Users/<username>/.parallels_settings

    All of my previous images returned after I deleted this file. Parallels no longer crashes on boot, and no longer asks me to install a new VM.
    Last edited: Sep 21, 2007
  6. skeedatl

    skeedatl Member

    I tried that and it didn't fix it.
  7. Jeff Lavoie

    Jeff Lavoie Bit poster

    Other fixes

    I also did an extensive uninstall. Perhaps the other persistent files are also the issue.

    Try these:
    1. Delete all Parallels links in the Mac dock and your desktop. The old links are reported to not work and you will need new links.

    2.a. Uninstall 5160 (mount Parallels-Desktop-5160-Mac-en.dmg and use the provided uninstall binary)

    2.b.The uninstaller will not remove everything so have your original key ready and any upgrade keys (you need both if you got an upgrade key) because you're going to delete the registration files and the kernel drivers. (on my install, only kernel driver vmmain.kext kernel was persistent)

    sudo rm -rf /Library/Parallels
    sudo rm -rf /Library/Receipts/Parallels.pkg
    sudo rm -rf /Applications/
    sudo rm -rf /Library/StartupItems/Parallels
    sudo rm -rf ~/Library/Preferences/com.parallels.Parallels.plist
    sudo rm -rf ~/Library/Parallels
    sudo rm -rf ~/.parallels_settings
    sudo rm -rf /System/Library/Extensions/hypervisor.kext
    sudo rm -rf /System/Library/Extensions/vmmain.kext
    sudo rm -rf /System/Library/Extensions/Pvsnet.kext

    3. Reinstall parallels 5160
  8. skeedatl

    skeedatl Member

    The only reliable fix I've found was removal of the additional video cards...then 5160 works perfectly. Reinstalling them brings back the problem. Going back to 4560 was the final solution for me as 4560 works great aside from the good old 'memory allocation' issue when I try to run more than 1GB of VM memory.
  9. Archy

    Archy Bit poster


    Do you have displays mirroring enabled in Mac?
    Do you have "Use multiple displays" enabled in VM configuration?
  10. skeedatl

    skeedatl Member

    No and no. I use 3 display adapters for individual monitors (no mirroring). and don't use multiple displays in the VM.

    Build 5160 won't run if I have more than 1 display adapter physically installed in my Mac Pro. If I remove the display adapters (leaving only 1) the VM runs fine. I didn't have this problem with the previous retail build 4560.

Share This Page