Stop: 0x0000007b Error On Boot Camp Partition MacBook Air

Discussion in 'Windows Guest OS Discussion' started by CarlR, Oct 10, 2009.

  1. CarlR


    I know that this has been discussed a number of times before, however after looking and trying all the solutions I can I still cannot get my Boot Camp partition to work using parallels.

    I have a new Macbook Air 2.13GHz 128GB SSD Drive. I have the Superdrive attached.

    I can run use the Windows XP by pressing the option key at boot up and it works just fine.

    Whenever I try and start my Parallels virtual machine I get the dreaded BSOD Stop: 0x0000007b error.

    Can anyone help?


  2. Raymond Weeth

    Raymond Weeth

    Same issue on MacPro

    I upgraded my bootcamp drive to Win 7, and now I get the same error when trying to boot using Parallels. I can still dual boot though.
  3. Raymond Weeth

    Raymond Weeth

    Same problem on MacPro with Win 7. Have not figured it out either.
  4. shawnf


    Google for MergeIDE.reg... I had the same problem after upgrading Boot Camp from Vista Business to Win 7 Pro on Snow Leopard (getting Boot Camp 3 drivers to install required a registry key to be deleted or it kept insisting a reboot was required). After running MergeIDE.reg under Boot Camp I managed to boot under Parallels and re-install the Parallels drivers.
    All working fine now :)
  5. CarlR


    Problem Resolved

    The problem was eventually resolved by 2nd line technical support.

    Apparantly it is to do with the size of the drive being incorrectly calculated by Parallels, here is the solution. I could not work out the calculation and it was done for me in the end by the support team.

    1. Start Parallels Desktop 4.0 for Mac
    2. Open the list of the registered virtual machines and right-click any of the VMs that do not work.
    3. Choose the Show in Finder option
    4. Right-click on the appropriate .pvm file and choose Show package content 5. Right-click on the .hdd file inside .pvm bundle and choose Show package content 6. Check that the appropriate .hdd bundle and all the files inside it have Read and Write permissions and <user name> owner

    Note: To check Ownership and Permissions please right click on the required file and choose Get info option. On the Ownership & Permissions tab you can find permissions combobox and owner combobox inside details tab.

    After that you should open DiskDescriptor.xml file from the .hdd bundle. Please open DiskDescriptor.xml file with TextEdit application from /Applications/
    Note: the virtual machine should be stopped before you start working with the DiskDescriptor.xml file

    For example you will see:

    <Parallels_disk_image Version="1.0" >


    You should check the values inside DiskDescriptor.xml file and change the specific value in the tag <End> from "<End>XXXXXX</End>" to "<End>YYYYYY</End>"

    NOTE: you may find several <StorageData> tags. You need to do it with the last one.

    To count YYYYYY you should do the following:

    Start Calculator application from /Application/
    Calculate XXXXXX / 63 value
    Add 1
    Remove fractional part
    Then multiply to 63

    Calculated value is the YYYYYY value.

    Please replace the values inside the file. Also make sure that in <Sectors><Sectors> tag the value is 63! not 32. Then save it and try to start your virtual machine again. It should start fine.

    NOTE: Please backup your edited DiskDescriptor.xml file to some safe place. You will need it in case you recreate or reconfigure your virtual machine. E.g. if you edit configuration of your virtual machine and then get the same error message, just replace the DiskDescriptor in .hdd file with the edited and saved one.
  6. Raymond Weeth

    Raymond Weeth

    Shawnf thanks....
    Don't know why this worked, since the mergeide.reg is a win XP thing. I just copied the mergeide.reg, and savee it with text editor. I put it on a usb flash drive since I did not have a floppy drive. right clicked on the file and selected merge. I exited my bootcamp windows 7 back to the Mac OS, and started parallels. Initially it did not want to recognize the drive, but I just went back into configuration and reselected the bootcamp drive. I started the vm, and now parallels is working. Hope this helps everyone else.
  7. Peter Payne

    Peter Payne Bit Poster

    Got it working

    I got it working for me. I needed to delete and re-create the PC in Parallels, re-defining the Boot Camp volume. Am now a happy camper.
  8. shorts16


    Stop: 0x0000007b

    This did not work for me.

    Only difference was that I had the *.reg file on the desktop of my Bootcamp boot and did not "merge" it.

Share This Page