Stuck on "Installing Parallels Tools"

Discussion in 'Parallels Provider for Vagrant' started by DimV, Jul 9, 2022.

  1. DimV

    DimV Bit poster


    I'm on a Mac Monterey 12.4 with Vagrant (Homestead for Laravel projects), Parallels Desktop 17.1.4. Upon booting up the VM I got this message that the Parallels Tools is outdated - screenshot so I opened the Parallels Desktop UI and clicked on the orange "!" which said "Update Parallels Tools", which is taking forever (2 days). I checked the parallels-tools-install.log and I saw this:

    Sat Jul 9 12:40:13 CDT 2022
    Start installation or upgrade of Guest Tools
    Found Guest Tools directory: /usr/lib/parallels-tools

    I've reinstalled vagrant, parallels desktop, the VM box, basically everything and tried again. Unfortunately - same result. So I'd be happy if someone knows how to fix this.
  2. DimV

    DimV Bit poster

  3. DimV

    DimV Bit poster

    Found the solution by following this (in case someone else finds themselves in this situation):

    How to install Parallels Tools in a Linux virtual machine
    1. Start the Linux and open the Terminal window.
    2. Get the administrator's / root privileges:
    sudo su or su

    1. Make sure the DVD drive in the Linux VM is ejected:
    eject /dev/cdrom

    1. Go to the Parallels Desktop menu bar > Devices > CD/DVD > Connect image...
    Navigate to /Applications/Parallels Desktop/Contents/Resources/Tools.

    Click on prl-tools-lin.iso and click Open.

    1. Mount the Parallels Tools image to the Linux VM:
    mkdir /media/cdrom

    mount /dev/cdrom /media/cdrom

    1. Make sure the disk image has been successfully mounted:
    ls /media/cdrom

    It should list the files located on the disk:

    install* installer/ install-gui* kmods/ tools/ version

    1. Go to the Parallels Tools image and run the installation package:
    cd /media/cdrom


  4. chargio

    chargio Bit poster

    Make sure that you are selecting prl-tools-lin-arm.iso if you are on an M1. For some strange reason by default it tries to mount the non arm version and it fails
    DimV likes this.
  5. DimV

    DimV Bit poster

    Yes, I forgot to mention that.

Share This Page