Suse 10 w/winxp guest /dev/rtc problem

Discussion in 'Parallels Workstation for Windows and Linux' started by afore, Apr 11, 2006.

  1. afore

    afore

    Messages:
    86
    Suse 10 w/winxp guest /dev/rtc problem (solved)

    Read related to this problem, but noting definitive on the solution. One thread had where build 1672 solved problem, but am not able to find that build. If I could, maybe it would fix my problem. Here are the various outputs.

    Error output when starting VM

    Parallels Workstation encountered a problem with the /dev/rtc device. This may be caused by one of the following reasons: (1) you do not have proper system permissions, (2) the device is not found in your host PC, (3) the device is used by another process. The absence of /dev/rtc device may downgrade VM performance and make internal timers slow.

    linux:~ # dmesg |grep -i real
    Real Time Clock Driver v1.12

    linux:~ # zcat /proc/config.gz |grep -i rtc
    # CONFIG_APM_RTC_IS_GMT is not set
    CONFIG_RTC=y
    # CONFIG_HPET_RTC_IRQ is not set
    CONFIG_SENSORS_RTC8564=m
    CONFIG_SND_RTCTIMER=m

    linux:~ # hwclock --debug --show
    hwclock from util-linux-2.12q
    Using /dev/rtc interface to clock.
    Last drift adjustment done at 1144781683 seconds after 1969
    Last calibration done at 1144781683 seconds after 1969
    Hardware clock is on UTC time
    Assuming hardware clock is kept in UTC time.
    Waiting for clock tick...
    ...got clock tick
    Time read from Hardware Clock: 2006/04/11 19:39:50
    Hw clock time : 2006/04/11 19:39:50 = 1144784390 seconds since 1969
    Tue Apr 11 12:39:50 2006 -0.045644 seconds

    linux:~ # cat /proc/interrupts
    CPU0
    0: 755762 XT-PIC timer
    1: 16 XT-PIC i8042
    2: 0 XT-PIC cascade
    5: 401 XT-PIC Intel 82801DB-ICH4
    7: 3 XT-PIC parport0
    8: 3 XT-PIC rtc
    9: 3 XT-PIC acpi
    11: 410996 XT-PIC uhci_hcd:usb1, uhci_hcd:usb2, uhci_hcd:usb3, ehci_hcd:usb4, yenta, ohci1394, eth0, nvidia
    12: 114 XT-PIC i8042
    14: 40071 XT-PIC ide0
    15: 25354 XT-PIC ide1
    NMI: 0
    LOC: 0
    ERR: 0
    MIS: 0

    Any suggestions on this or where I can get build 1672 for linux?
     
    Last edited: Apr 13, 2006
  2. constant

    constant

    Messages:
    1,010
    .
    There is only a Windwoes build 1672.

    Linux is on build 1670
    .
     
  3. kschrod

    kschrod

    Messages:
    4
    Maybe this is a "problem" in Suse and not in Parallels.

    What'S the output of

    ll /dev/rtc

    Maybe the access control is wrong -- as said in the error message?
    Pls. check the /etc/permissions.* files too.
     
  4. afore

    afore

    Messages:
    86
    ll /dev/rtc results in

    crw-rw---- 1 root audio 10, 135

    What should it be and how do you change it? I looked for that directory in the /etc/permissions file, but did not find it. Found all kinds of other /dev file, but not the rtc.

    Art
     
  5. Shawn Parr

    Shawn Parr

    Messages:
    2
    The file you are looking for under SuSe 10 is:

    /etc/udev/rules.d/50-udev.rules

    In there do a search for rtc, and add:

    MODE="666"

    That will set the permissions to appear as:

    crw-rw-rw 1 root audio etc etc

    And you will no longer get the error.
     
  6. afore

    afore

    Messages:
    86
    That fixed the /dev/rtc problem and the choppy audio. Now to solve the other problems.
     

Share This Page