Synergy and Parallels - Modifier keys (shift, ctrl, caps) no longer work

Discussion in 'Parallels Workstation for Windows and Linux' started by jreue, Sep 11, 2006.

  1. jreue

    jreue

    Messages:
    1
    Machine 1:
    Gentoo Linux
    Synergy v 1.3.1 Server
    Keyboard and Mouse are hooked to this machine

    Machine 2:
    Gentoo Linux
    Synergy v 1.3.1 Client
    Parallels v 2.1.1670
    • Host: Gentoo
    • Guest: Windows XP

    The modifier keys work fine on machine 1 and on the host OS of machine 2
    Inside the guest OS of machine 2, CTRL, CAPS LOCK, SHIFT, etc do not work.
    I've seen posts about this in the forums, but they all deal with the Mac Desktop update build.

    I actually think that all my modifier keys worked before I installed the Parallels Tools. But, I've tried uninstalling them, but i still have the same issue.
     
  2. Ynot

    Ynot Parallels Developers

    Messages:
    387
    Seems it's a Synergy problems and Parallels do not support Synergy in current version.
     
  3. RichardD19

    RichardD19

    Messages:
    2
    For anyone who stumbles upon this in the future, here is the response I received from Parallels support, which solved the issue for me in Parallels 14 (I ran the commands while the VM was shut down, but I don't know whether it makes a difference):

    To resolve the issue please, open Terminal (Applications > Utilities > Terminal) and execute the following commands:

    defaults write 'com.parallels.Parallels Desktop' 'HID Host Hook.Allowed Sources' "synergy"
    defaults write 'com.parallels.Parallels Desktop' 'HID Host Hook.Allowed Sources' "synergyc"
     
  4. ParallelsU418

    ParallelsU418

    Messages:
    1
    Thanks for posting this! It does indeed fix the Synergy issues, but not in Coherence mode. I wonder if there are any commands to fix that specifically.
     

Share This Page