Text not displaying within Windows 11 VM after updating to Parallels Desktop 19

Discussion in 'Windows Virtual Machine' started by MicahG, Jan 4, 2024.

  1. MicahG

    MicahG Bit poster

    Messages:
    2
    Any ideas on how to fix this issue? I'd like to avoid reinstalling my vm's back running Parallels 18?
    I've tried adjusting Parallels 19's display / hardware settings, running Windows cmd prompt system scans, re-installing Windows and running all system updates... Any ideas on possible troubleshooting methods to resolve? Image 1-5-24 at 12.33 AM.jpg ?
     
  2. PeterK36

    PeterK36 Bit poster

    Messages:
    3
    Hi!
    Same for me after upgrading to Parallels 19. No text in the menus. Windows 11 is unusable like this.
     
  3. ChrisC75

    ChrisC75 Bit poster

    Messages:
    3
    Same problem, did anyone figure this out?
     
  4. Avinash Bundhoo

    Avinash Bundhoo Staff Member

    Messages:
    458
    Hello!
    In order to proceed with further investigation, kindly provide us with the below information:
    1. Reproduce the issue.
    2. Collect a technical report (right-click Parallels icon in Dock > Help > Send technical data > check "Attach screenshots..." > press Send Report) and send the report's 9-digit ID in a reply.
    Thank you!
     
  5. tonza

    tonza Member

    Messages:
    22
    Does the problem also appear when your virtual machine is running under Retina Display resolution? That changes the system font used, so it may be able to coax Windows into displaying its text!

    Select View > Retina Resolution > Best for Retina display and see whether the text appears then. If it doesn't... you may have to re-install Windows (in another virtual machine?) to see if that rectifies the problem.
     
  6. ChrisC75

    ChrisC75 Bit poster

    Messages:
    3
     
  7. ChrisC75

    ChrisC75 Bit poster

    Messages:
    3
    I spent hours reinstalling windows and parallels I finally fixed it by adding the flag "video.metal=0" to the boot order advanced settings flags. After that windows is working great and all menus are perfect!
     
    MattH20 and tonza like this.

Share This Page