The case of the missing tilde ~

Discussion in 'Windows Guest OS Discussion' started by Johnno Nolan, May 29, 2010.

  1. Johnno Nolan

    Johnno Nolan

    Messages:
    2
    Hi,

    I've tried in vain to find the answer through the other sources so I'm putting this out there.

    Guesting Windows 7 64 bit on my Mac Book Pro.

    I've suddenly discovered I cannot access the tilde ~ key on my keyboard it defaults to the pipe | symbol.
    Has any one found a way round this? Can I configure the keyboard to use this somewhere?


    Thanks


    Johnno
     
  2. mrutter

    mrutter Bit Poster

    Messages:
    50
    Hi Johnno, I have the same issue.

    I still haven't found a solution for this. I tried to map keyboard keys to Windows (see Parallels Desktop, Preferences, keyboard). The tilde, on Mac, is such a special character (right Alt + N) and everytime I map it, then, once I saved the configuration, the key is lost.

    As a developer it's very difficult to work without the tilde (at the moment I'm using a text file from where I copy and paste the tilde when I need it). I don't understand why nobody, at Parallels Desktop, has resolved this important issue.

    Regards,
    Marcello
     
  3. Johnno Nolan

    Johnno Nolan

    Messages:
    2
  4. mrutter

    mrutter Bit Poster

    Messages:
    50
    Hi Johnno. Thank you very much to let me/us know. Unfortunately, that key combination does not work on my Mac (Macbook Pro 17" 2009, Windows 7 Ultimate Ita, the keyboard is Italian).

    Regards,
    Marcello
     
  5. JoakimA

    JoakimA

    Messages:
    5
    Hi.

    I'm running a Parallels installation of Win7 (swedish) on my MBP.

    I was messing around trying to find the "pipe-character" (|) and found some interesting combinations:

    Backslash: [CTRL]+[ALT]+[+]
    Pipe: [Right ALT]+[<]
    Ctrl-Alt-Del: [Fn]+[Ctrl]+[Alt]+[Backspace]
    Tilde: [Ctrl]+[Alt]+[^]

    Hope this helps!

    Regards,

    /Joakim
     
  6. mrutter

    mrutter Bit Poster

    Messages:
    50
    Hi Joakim, thank you for you post.

    Unfortunately, even the key combination "[Ctrl]+[Alt]+[^]" (for tilde) does not work on my Mac (Macbook Pro 17" 2009, Windows 7 Ultimate Ita, the keyboard is Italian).

    This is a very strange behavior. I don't understand why the tilde char is missing on the italian keyboard even as a key combination that works for other countries!

    May be someone is thinking that italian's developers don't need the tilde :) ?

    I hope someone will resolve this issue, we're are all waiting.

    Thank you.
    MR
     
  7. JoakimA

    JoakimA

    Messages:
    5
    Space..?

    Strange... And if You press [Space] after the combination..? Did that do the trick..?

    /Joakim
     
  8. mrutter

    mrutter Bit Poster

    Messages:
    50
    Nothing! I also tried to setup a custom key combination in Parallels's keyboard configuration (Parallels Desktop, Preferences, Keyboard). In that case I'm not able to associate the tilde char in Mac. If I'm not going wrong, the tilde is ALT+N, but when I try to enter this combination inside the "To:" field, it takes the "Alt" key but not the tilde (and the tilde is displayed as an underlined character). If I unselect the "Alt" key and save the combination, when I reopen it the combination is empty. In any case it does not work on Windows side.

    At the moment I'm using a text file on my desktop to copy the tilde char ... It's very very frustating!

    Thank you for your interest, JoakimA.

    Reagrds,
    MR
     
  9. JoakimA

    JoakimA

    Messages:
    5
    Hello again.

    Looked at the differencies between the italian and the Swedish keyboard layout.

    http://support.apple.com/kb/HT2841?viewlocale=en_US

    It seems like the ^ on the Swedish keyboard is resided below the one on the Italian, so maybe the "[Ctrl]+[Alt]+[*]" would be the proper combo on your keyboard?

    Regards,

    /Joakim
     
  10. mrutter

    mrutter Bit Poster

    Messages:
    50
    It should but it's not.

    With that key combination I get a "]" char (or a "}" if I press the SHIFT key too).
    To be true, hoping in a different key combination, I tried all the combinations I can without any result.

    Thank you.
    MR
     
  11. JoakimA

    JoakimA

    Messages:
    5
    Sorry to hear.

    The quest for the proper combo gets a bit more complicated with different keyboard layouts... :-(

    /Joakim
     
  12. mrutter

    mrutter Bit Poster

    Messages:
    50
    Hi JoakimA.

    Finally, today I decided to resolve this issue once for ever. So googling about keyboard mapping I found many solutions. The one which worked very fine for me and that I choosed is: Microsoft Keyboard Layout Creator 1.4.

    In a few of seconds I configured my tilde sequence [RIGHT-ALT]+ù (which is the "\" chars in the US keyboard).
    And finally, I have my tilde to work!

    So please, let me print some tildes ... I have to vent :)
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Hope this helps someone else.

    Regards.
    MR

    P.S. Ok, if someone have a better solution, please let me know: you're welcome!
     
    Last edited: Apr 11, 2011
  13. JoakimA

    JoakimA

    Messages:
    5
    Haha... NICE!

    It's good to vent and to get it out... :)

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ to You too!!! :)

    /Joakim
     
  14. Mexican Keyboard

    In case this turns out to be useful for anyone...

    My keyboard has the Ñ key.

    I got the tilde by pressing Crtl + Alt + Ñ and then a space, since the tilde is supposed to go "on top" of letters :p
     
  15. RaffaC

    RaffaC Bit Poster

    Messages:
    1
    For me it worked:

    RIGHT OPTION + N, a

    ããã cool :)
     

Share This Page