The upgrade to 4.0 is a DISASTER

Discussion in 'Installation and Configuration of Parallels Desktop' started by prefabsprouter, Nov 13, 2008.

  1. jackcav

    jackcav Bit poster


    Since practically everyone in this thread is stating that the install process fails prior to completion, your advice demonstrates that Parallels is not taking our complaints seriously. Apparently, no one at Parallels is taking the time to carefully read the posts. All you are doing is providing utterly useless advice. How about a new strategy? How about fixing the mess you made?


  2. kevinw

    kevinw Hunter

    I don't have an answer for you except that my installation went exactly the same way. I have no idea why it didn't want to recognize Windows, the hardware, etc. from the 3.0 installation and certainly didn't get much guidance in the process as to what to expect or how to reply to the prompts. I ended up answering all of them and registering Windows and have it installed but many of the functions are hosed.

  3. fwolpers

    fwolpers Bit poster

    I have had various email conversations with all East European sounding named people from Parallels over the last days and since I "downgraded" back to PD 3, as I couldn't get anything to work with PD4, I insisted on a refund of the price I have paid for the upgrade.
    They confirmed to have this initiated, so keep fingers crossed, that my loss in this case will then be limited to the complete waste of about 2 days of my precious private spare time.
    The downside is, that Parallels choose to launch a product at a sort of BETA stage, doesn't respond to the real failures and probably got overwhelmed by the flood of error messages from users.
    It is a weired marketing philosophy and is probably extremely desturctive to the name & reputation of the company. I hope they are aware of it.........

    MacBook Pro 2,6 GHz
    4 GB RAM, 250 GB Harddrive
    Mac OS X Leopard 10.5.5
    PD3 with WinXP Pro
  4. strayduck

    strayduck Bit poster

    Just a quick note to agree with rstrauss and MrLynn;

    To rstrauss' point: if you can manage to coerce 4.0 into installing and working it looks like a nice upgrade. One of my favorite features: you can have Parallels remember USB settings so when you plug in your ancient Palm Treo, for example, that Windows doesn't pop up with a notification EVERY TIME. Also: The performance *is* tangibly better when you have the settings right.

    Inre MrLynn: I agree wholeheartedly. SERIOUSLY, you should not need a CS degree to install GUI software. My upgrade experience looked something like:

    Starting system:
    Mac Pro quad 2.66, 7 GB Memory
    Mac OS X 10.5.5
    Parallels 3
    Guest OS 1: Windows XP Home SP2 using Boot Camp partition
    Guest OS 2: Ubuntu 7
    Parallels Tools Installed
    AVG Free Edition 8.0

    (1) Back up old OSes and upgrade Parallels to 4.0 3522
    (2) Notice that Ubuntu 7 virtual machine is completely pooched. Deleted machine and created a new one for 8.0 from scratch. Worked fine but inconvenient
    (3) Notice performance in WindowsXP is really, really bad. Fiddle with preferences to optimize (turn on hypervisor, give it 2 CPUs, RAM, VRAM). Smoothed out but would not give my BootCamp HD partition back to Mac OS when shutting down windows and turning off Parallels. (This problem persists to this day but holding down "option" on reboot does make the Windows drive show up so it's probably not a dealbreaker).
    (4) The next day Windows would no longer boot -- some black screen with "missing hardware" surrounding the HD. Hangs when searching for Mac address. No amount or manner of reboots would fix. Deleted virtual machine and made a new one from the still functional BootCamp partition. Parallels tools, however, would not install properly -- mouse movements jerky, high CPU usage, control-alt required to re-capture mouse. Turning off virus software and reinstalling multiple times did not fix the problem
    (5) Uninstalled AVG completely using Windows Control Panel. Also uninstalled completely the Parallels tools and rebooted. INstalled Parallels tools from scratch and they worked after reboot
    (6) Make 4 attempts to install AVG 8 Free Edition. All Fail.

    SIMPLE, right?

    So I guess I'm about the third person to make it out the other side relieved that it wasn't worse (though if I were charging hourly for my time Parallels would actually owe me hundreds vs. the other way around...)

    Still have the issues of antivirus and the disappearing Boot Camp partition to work out, but I can at least run Windows until then...
  5. strayduck

    strayduck Bit poster

    Update: Booting to Windows in BootCamp allowed proper installation of AVG but it still appeared to be using the Parallels graphics adapter. Downloaded and installed the newest ATI Catalyst control panel (from 8.10 to 8.11) and got my proper resolution back.

    Booting back to OS X showed my BootCamp partition on the desktop and firing up Windows in Parallels actually worked. Quitting windows put the BootCamp partition back on the desktop once again.

    Tiptoeing carefully forward...
  6. Frazzle

    Frazzle Bit poster

    Really disappointed I paid for the upgrade to 4.0, I was booting from my Boot Camp partition,the upgrade failed twice, tried to rebuild windows non-destructively, now have a virtual machine that works partially, every time I start up it goes the the conversion process and once windows has booted windows finds new hardware- pci tool device and can't find it.

    This is properly hosed. And the only advice from Parallels appears to be do a fresh windows install and start again, this is not an upgrade it's a re-install! Absolutley rubbish advice, and where's the apology or even a reponse, appaling!

    I paid £32 to lose my windows partition and re-install, well no way, the best thing we can all do is walk, it's the only way, parallels have been given ample opportunity to provide better instructions or support but have FAILED, let's all walk. I hate admitting I've wasted money on this but VMware here we come. To make a mistake once is understandable to make it twice is stupidity, don't let Parallels get away with this rubbish product, hit them where it hurts, in the pocket. What a scandal this upgrade process is, I think it's criminal and we are the victims.
  7. MrLynn

    MrLynn Member

    Parallels Support Replies. . .

    . . . to the ticket I started a couple of days ago. This is the actual text from one Madhusudhan B:

    I seem to remember trying menu commands, which didn't work. But fortunately, I have been able to get PD4 working, by starting over using a copy of the backup HDD, as I described above.

    I would be interested to know if anyone can get their stalled upgrade to work by just clicking the menu command to Install Parallels Tools. I suspect that Madhusudhan B's understanding of the problem most of us have been having is as poor as his English.

    WinXP under PD4 does seem to run faster, and Parallels does seem to be consuming less of my MacBook Pro's resources (2.33GHz, 2GB), allowing the Mac apps to run better. For some reason the keyboard shortcuts to change the view don't work, but the menu commands do.

    /Mr Lynn
  8. Junior Member

    I managed to upgrade my Parallels 3.0 virtual machine to 4.0 format.
    But the performance is horrendous. Stay with 3.0 until Parallels manage to iron out all the bugs. I had the exact same experience with upgrading to Parallels 3.0 previously. Obviously this company doesnt learn from its past mistakes.

    And my advice do not install Parallels Internet Security (Kaspersky) It will hang your virtual machine and play havoc with your network connection.

    I am seriously considering VMWare. At least I dont read so many complains abt it in their forums.

    Parallels is doing a very very poor job of securing customer satisfaction and product quality. A very sad state of affair for a pretty good product.
  9. theand

    theand Bit poster

    I can't believe this issue hasn't been sorted yet.
    For every person registering on this forum to complain there are a hundred that didn't bother. It's a huge wide-spread problem and nobody appears to have a clue 6 days in.
    I've had dealings with 3 separate Parallels employees and whilst courteous and willing to help none of them can do a thing or even know what the previous employee was doing with me. It's like I have to explain myself every time!

    I've been a customer since version 2 and I genuinely wish I hadn't upgraded and have lost all faith in this company.
  10. Junior Member

    I managed to upgrade my Parallels 3.0 virtual machine to 4.0 format.
    But the performance is horrendous. Stay with 3.0 until Parallels manage to iron out all the bugs. I had the exact same experience with upgrading to Parallels 3.0 previously. Obviously this company doesnt learn from its past mistakes.

    And my advice do not install Parallels Internet Security (Kaspersky) It will hang your virtual machine and play havoc with your network connection.

    I am seriously considering VMWare. At least I dont read so many complains abt it in their forums.

    Parallels is doing a very very poor job of securing customer satisfaction and product quality. A very sad state of affair for a pretty good product.
  11. MaximS

    MaximS Forum Maven

    MrLynn, please, write here the ticket id.
    Last edited: Nov 19, 2008
  12. MrLynn

    MrLynn Member

    MaximS: It's #617745.

    When the upgrade problem first occurred, I also filed a trouble report, but I don't have that number.

    /Mr Lynn

    PS Can you change my user ID here to get rid of the e-mail address? Just 'MrLynn' will do fine. Thanks.
    Last edited by a moderator: Nov 19, 2008
  13. theand

    theand Bit poster

    7 days in and things seem to be quieter than ever. Still no official acknowledgement of a massive problem. It's really at a recall state at the moment.

    Can someone at Parallels tell me how to get back to version 3.0 please, I have a back up version 3.0 VM and a time machine back up of PD 3.0.
    What are the stages of getting 4.0 out of my face for good and actually being able to work again in version 3.0?

    You could at least do this.
  14. spiffey

    spiffey Junior Member

    I have had problems with the upgrade (though the upgrade process itself went smoothly). In my case it was the copy and paste functionality which didn't work; it even went as far as disabling copying within XP itself.

    However, getting back to version 3 was easy (for me). First, you have to uninstall version 4 (by using the uninstaller included on the version 4 disk image). Then, rename your Parallels folder to "Parallels 4" or some other name you feel appropriate. Then take your Parallels backup folder and rename that "Parallels" (assuming that you did a "Backup and convert" on installation? If not, you'll have to copy over your last known 'good' backup of version 3 from Time Machine). Then reinstall version 3 from the latest version 3 disc image (I used Parallels-Desktop-5626-Mac-en.dmg).

    After doing this (it took about 5 minutes to complete), version 3 worked as though nothing had changed.
  15. prefabsprouter

    prefabsprouter Bit poster

    I agree 100%. To John (from the Parallels Team): why aren't you guys acknowledging the fact that there is a huge problem with your product, and at least advise all of us who have issues with 4.0 on how to downgrade to 3.0??

    I'd like to know why it's taking support an inordinate amount of time to respond to requests. I sent a support request on November 13th (ticket #615211). I heard NOTHING, until SIX days later, on November 20th, when I received an e-mail from support (first one I receive) stating they replied 4 days earlier and didn't hear back from me, so they assume they can close the ticket. What??? Are you support systems defective as well?? This is the last straw. I went to a URL they provided with the details of the tickets, and I did see there a response from them previously written (but obviously never sent to me), asking me to send to them three files from my computer, two of which it turns out do not exist on my computer. I sent them the one file which I did have yesterday. Who knows how long it is going to take now to receive a reply...

    I know many of you have spent $30 to call support, and most are in no better place than you were before the call. I'm sure those $30 calls add up and make a nice little revenue stream for Parallels. The cynic in me wonders whether Parallels released a half-baked product thinking, "well, the upside of this incomplete release is we'll get *a lot* of calls and therefore extra $$$!!" This is why I refuse to call and give them more money in connection with their unusable product.

    We should all demand our $40 upgrade fee reversed - after all we were sold a product that does not work. If Parallels refuses, the credit card companies are very good and quick about reversing the charges of defective products, resulting in a 'chargeback' to the vendor, which not only deducts $40 from them (in this case), but also results in administrative charges to them. It only takes a quick call to the the credit card company. Vendors HATE this and there is not much they can do about it. All you have to explain to the credit card company is that you were sold a defective product. The $30 charge of the calls to support can also be reversed by the credit card company if one explains that you did not receive what you paid for and expected.

    John, I don't want to see a group of us do this, but by not acknowledging the problem and by being unresponsive to our requests, it looks like you are leaving many of us with no other option. Remember; YOU ARE SELLING A DEFECTIVE PRODUCT. You just have to look through the many posts in the forums to find proof of that.

    I tried downgrading to Parallels 3.0 this morning but now that is not working either!! I see the Windows black screen counting down to start Windows, but when it reaches '0', nothing happens. So, no 4.0 and now no 3.0 either.

    The whole experience is beyond frustrating. I have started to look into Fusion.


  16. MrLynn

    MrLynn Member

    I am not sure the product itself is defective; just the installation-upgrade software. Once I went back and repeated the VM upgrade on a good backup copy of the VM (and this time logged onto Windows as an Administrator), it worked all right, and I've had no further problems with PD4. So far (knock wood!) it's running well, and considerably better than PD3.

    Obviously there are a lot of potential booby-traps to upgrading individual VMs. But it is Parallels's (Nova Development's) responsibility to anticipate those and to build devices into their upgrade software that will stop the process, explain the problem in a few words, and tell the user exactly how to proceed (and that should not include links to lame 'troubleshooting' web pages, either!).

    What Nova should do is to announce that they will be sending out replacement installation CDs (or downloads) to everyone who purchased PD4. The new install disks should be idiot-proof. Most of us are not programmers, nor even IT geeks; we are just average folk with a very limited understanding of how any of this works. You have to anticipate what can go wrong, and make sure you have allowed for every possible glitch.

    I know that's a tall order, but that's the responsibility that comes with marketing consumer software. And you have to be up-front with customers, explaining what you are doing to remedy the situation, and what they can expect.

    /Mr Lynn
  17. peterlemer

    peterlemer Hunter

    tattsenglee: I am running Kaspersky AV ( paid for) on v3 Parallels and it is transparent and efficient.

    This makes me wonder whether the Parallels V4 included version has been modified - we should be told.

    Either that - or KAV doesn't work with the current version of Parallels V4. again - we should be told.

  18. AdamWest

    AdamWest Bit poster

    I just registered here so i can add my name to the growing list of customers that wasted time trying to install 4.0. Could we please get some information from the company on a plan to fix this? I am not even asking for a timetable, just an acknowledgment that there is a problem and that they are working on a revision to release to us as soon as possible. This is your customer base here asking for a response from the company, it is the least you could do.
  19. adanguspf

    adanguspf Member

    Lucky me (for using Vista???)

    As so many of you, I hopped on the PDv4 bandwagon as soon as I received the email notification. I run a Vista Business VM on a 17" MacBook Pro Core Duo with 2GB of RAM. I did not back up the VM before running the upgrade, which in hindsight seems insane.

    Outside of a single bogus error message at the end of the automatic upgrade, everything worked and continues to work without issue. I have not had to reactivate Vista nor any of the MS Office apps that run under Vista. I can say that the new system appears to be easier to use than PDv3, and that as advertised it runs faster, at least in the fairly simple configuration that I have. I have been using v4 on a daily basis for over a week now (I think).

    Having said that, I see no benefit so far in using the Hypervisor schema and assigning more than one of the two available CPUs to the guest OS; that is, performance seems to slow down with 2 CPUs assigned to Vista even when there is nothing doing on the Mac side. I will note than upon the first assignment of 2 CPUs to the guest OS, Vista detected the new hardware and wanted a reboot. This went without incident. Later, deallocating 1 CPU caused no problems.

    I have been doing some fairly heavy graphics processing with the Vista machine, and as I say, all seems well so far. Both the Vista PPTP VPN and a Cisco IPSec VPN still work. USB, DVD/CD assignments on the fly work properly. Video playback is better, but not great.

    Also, the Vista performance evaluation tool still fails as in PDv3, although it seems to get near the end of the evaluation tests before failing. This means that Aero is still off limits, though I'm not sure I care much about that.

    As near as I can tell, all of the problem reports appear to be associated with users running XP as a guest OS; at least, I haven't noted someone who upgraded a Vista guest VM in the sinking boat. I also read one user's report in which they'd replaced a messed-up VM from the upgrade process with a back-up copy, and that the conversion seemed to go fine.

    This suggests an alternative upgrade workflow: don't just back-up your existing VM to an external drive, remove it completely during the upgrade from v3 to v4 if you're running XP. Create a new blank machine if you're asked by the upgrade wizard. After you have v4 running as an app, copy your VM folder contents back and do the conversion. This is just a WAG on my part for those of you stuck, and smart enough to have kept a backup copy of your VM.

    I have PDv3 still running on another platform with about 6 different XP-based VMs. Having read this thread, I am gun-shy about touching them.

    I have to say that this is the first time in a long time that I'm happy I upgraded to Vista.
  20. Augman

    Augman Bit poster

    4.0 installed without a problem in a new user

    I have been having the same problems as described in this thread upgrading my parallels 3.0 to 4.0 on my macbook pro core 2 2.33 ghz. I was running 3.0 with XP pro but it would hang up during install about 30% through the install green progress bar. I tried everything suggested here on the forum and could not get it to work.

    I decided to try to install 4.0 and XP on a fresh user account on the same computer. IT INSTALLED WITHOUT A SINGLE PROBLEM AND RUNS GREAT!!! It is much faster running xp games in the new VM. I am not sure why this worked but there must be something in hidden files etc. in some users that is causing the issue. Two completely different install experiences on the same computer.

Share This Page