There is no application set to open the document

Discussion in 'Windows Guest OS Discussion' started by JuiceD, Sep 28, 2015.

  1. NickO3

    NickO3 Bit Poster

    Messages:
    2
    Thanks for this Ketan... this worked perfectly!
    EDIT: This worked perfectly only for when I need to open "My PC" through the dock. MS Office suite products don't open and when I try to select the default application to open them, none of the Office products are listed in Finder.
     
    Last edited: Oct 5, 2015
  2. MarkCCB

    MarkCCB Bit Poster

    Messages:
    1
    Ketan, my apologies, I am having the same issue but was not able to follow your fix. Could you please elaborate? Many thanks!
     
  3. FernandoF1

    FernandoF1

    Messages:
    1
    Solution!! Install Parallels latest update - Version 11.0.2 (31348), reinstall Parallels Tools, and then run "Rebuild Launch Services Database" in OS X 10.11.
    All application-file associations return to normal, and Windows apps open normally from Windows Applications folder in OS X.
     
  4. GerardK1

    GerardK1 Bit Poster

    Messages:
    1
    Hello Michael,
    I have windows 7 running under Parallels Desktop 10.3.0 and since upgrading to El Capitain I have been unable to launch windows applications from the osX dock I get the
    "There is no application set to open the document" issue.

    I have tried reinstalling Parallels tools and then rebuilding the launch services db with the following command

    /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister
    -kill -r -domain local -domain system -domain user
    Please note I entered it exactly as above (e.g. I didn't change user to my user name or anything).

    It didn't solve my problem. Am I doing anything wrong or missing a step ?

    Best Regards
    Ger
     
  5. WAYNEW2

    WAYNEW2 Bit Poster

    Messages:
    1
    All,

    I just went through this issue after upgrading to El Capitan using Parallels Desktop 10 for Mac hosting Windows 7.
    I was receiving the error There is no application set to open the document "Microsoft Outlook 2010 " when selecting the application from the Windows 7 Applications folder in the Dock. This was happening for all of my Office products (Excel, Word, etc.) and Internet Explorer.
    1) Right Click on Windows 7 Applications Folder in Dock; select Open "Windows 7 Applications"
    2) For me, my Microsoft Outlook 2010 application is under a folder, "Microsoft Office"; Right click on it and select Get Info
    3) Under the "Open with:" section, you will see Parallels Link (Default). Select the dropdown arrow on the right
    4) You will see Parallels Link without Default. Select it.
    5) Press the button below that says "Change All..."
    6) It will say "Are you sure you want to change all your Parallels Link documents to open with the application "Parallels Link"? This change will apply to all Parallels Link documents with type "PSA6"."; Select Continue.

    The system will update all the links and all should work!
     
    Parallels User likes this.
  6. WAYNEW2's method fixed the issue for me, but there is one small edit I would make.
    In step 4, it says you will see "Parallels Link" without Default. I did not see a Parallels Link without Default. The only option I saw was "Parallels Link (Default)".
    However, I just left this as the selection, and then clicked the "Change All..." button, then clicked to confirm the "Are you sure...", and all my links started working again.
    I'm not nit-picking, but figured it was important to post what I actually saw, because I almost didn't continue past step 4) of WAYNEW2's instructions.
     
  7. AegisI

    AegisI Bit Poster

    Messages:
    34
    Hello Friends

    Upgraded and Re-Installation about all Parallels tool.
     

Share This Page