Time Machine Restore to VM on USB 3 Device

Discussion in 'Mac OS X Guest OS Discussion' started by KevinB7, May 8, 2017.

  1. KevinB7

    KevinB7 Bit Poster

    Messages:
    13
    I have a MacOS (Sierra) VM on a USB 3 drive plugged into my MBP. I have a TimeMachine backup on a different USB 3 drive.
    1. Start the Restore from Recovery Partition
    2. Attached the TimeMachine device to the VM
    3. Search for backups to restore (OK found the right one)
    4. All goes well until we have to select the destination
    5. Restore - FAIL FAIL FAIL
    The restore process doesn't 'SEE' the drive of the VM (which is expanding 300Gb, but I also tried with non-expanding 300Gb). It only sees a drive called Macintosh HD which is 67Gb. My MBP physical drive is 256Gb with 73Gb free. I look at Macintosh HD and it is 73Gb with 6Gb for something and 67Gb left.

    So the RESTORE is seeing the free space (near as I can figure) on my physical drive and using that, and only that, as the restore point. Of course it complains of not enough space to restore. But what is singularly annoying is that the VM cannot see it's own primary HDD to restore to.

    Exactly the same happened when I tried to use the Migration assistant from a TimeMachine backup, 67Gb free, not enough space. If I use TimeMachine in the foreground I see the backups and Cancel/Restore, but Restore is always greyed out. This should be a simple process, but I am literally wasting days just to do a simple restore. Maybe I'm just missing something simple and obvious, but so far no epiphany.

    Any suggestions even where to start looking?

    Thanks,
    Kevin
     
  2. rkulikov

    rkulikov Parallels Developers

    Messages:
    166
    Can you please send us a problem report with this issue? For this at the moment of restoring fails make virtual machine active and in Mac application menu bar go to Help -> Send Technical data. Post report id here.
     
  3. KevinB7

    KevinB7 Bit Poster

    Messages:
    13
    Hi,
    Can you please send us a problem report with this issue? For this at the moment of restoring fails make virtual machine active and in Mac application menu bar go to Help -> Send Technical data. Post report id here.
    That would not help. The ISSUE (I have since found out) is that the Default MacOS partition size (regardless of the available disk) is 64Gb. The PROBLEM is that I cannot increase the files system (partition) size to match the disk size. I think this is a problem with Parallels using a Guest VM on a USB 3 drive. I Have booted to Disk Utility, Tied to resize the partition and included the problem report with that.
    Report ID is 179408344
    See the images attached:
    1. The default MacOS disk size is 64Gb
    2. I can resize to 300Gb
    3. I can make it expanding or not
    4. WHATEVER I do the RESIZE FILE SYSTEM option is ALWAYS Greyed out
    5. I have booted to Disk Utility
      • I resize the partition
      • The system say success
      • The partition is NEVER resized
    The VM is on a USB 3 Mechanical Drive (when I'm in the US in a couple of months I'll by the 1 Tb OWC SSD). I have used a 1Tb Touro USB 3 Drive and a 2Tb Toshiba USB 3 Drive all with the same result. Because I cannot resize the initial partition any time I try to do a backup (I've used timeMachine, Acronis and SuperDuper!) they all complain NOT ENOUGH DISK space.

    The initial disk size with RESIZE greyed out:
    Initial Disk Size.png

    This time I have resized the disk, all options are unavailable, I haven't applied the changes:
    REsized to 300Gb.png

    Now I have applied the changes, BUT from here I CANNOT resize the file system:
    Applied.png
     
  4. KevinB7

    KevinB7 Bit Poster

    Messages:
    13
    As an aside, the 'Resize File System' seems to work OK on a Windows 10 VM. This appears to be a problem with Parallels and MacOS Sierra 10.12.xx.

    OK CLOSE THIS ISSUE:
    This is all tied up with the fact that Parallels CANNOT resize a GUID/HFS+ partition. There are ways by converting to coreStorage, rezize, convert back to HFS+.

    The Big Question Though:
    If Parallels are too lazy/otherwise distracted to put in this fix to change the the partition size, then:

    Why do they NOT give the user the option to SELECT the partition size when it is being created, how hard would that by????
     
    Last edited: May 29, 2017
  5. RobertP6

    RobertP6 Bit Poster

    Messages:
    7
    I have the same issue and I'm not planning on upgrading Parallels until this is fixed (as the OP said...allow the user to select the partition size when being created).
     

Share This Page