To use your Windows files directly in Mac you should reinstall Parallels Desktop.

Discussion in 'Windows Virtual Machine' started by imborn2x, Nov 4, 2007.

  1. imborn2x

    imborn2x Bit poster

    I have been using Parallels for the past 4 months.
    I has worked well.

    I just upgraded to Leopard.
    Then I upgraded to the Parallels Beta to run with Leopard.

    I use MS Outlook Webmail for work.
    I have to open documents from attachments in emails.

    BEFORE, I would open an attachment, and it would go to mac and open with a mac program (like word for mac).

    NOW... I get this message:
    To use your Windows files directly in Mac you should reinstall Parallels Desktop.

    And nothing will open.

    PLEASE HELP... I use my email for work and need to open the attachments all the time.

    I have tried to reinstall Parallels 5 times yet nothing changes.

    Thanks for your help in advance!
  2. alexg

    alexg Parallels Developers


    Parallels Desktop uses MacFUSE for Windows sharing. The version of MacFUSE what comes with Parallels Desktop is not compatible with Leopard. You can fix it by installing the latest version of MacFUSE for Leopard. You can get it at

    Also, please check the Finder option "Preferences -> General -> Connected servers". It should be checked (it is unchecked by default).

  3. HZC

    HZC Member

    I checked "Preferences -> General -> Connected servers" in the Finder Preferences, then I installed MacFUSE-Core-10.5-1.0.0.dmg and rebooted. Then Parallels wouldn't start up, stating that I had to re-install it, so I did that and then Parallels started up fine and so did Windows. However, I still get the error message "To use your Windows files directly in Mac you should reinstall Parallels Desktop."

    (-) Double-clicking on any file on the Windows side that uses a Mac application to open doesn't seem to work (produces the same error).

    (+) Double-clicking on files on the Mac side that use Windows applications to open seems to work OK.

    (+) Windows C drive mounts properly in Finder.
    Last edited: Nov 6, 2007
  4. dglow

    dglow Bit poster

    Identical problem

    I've been experiencing similar symptoms using 10.5 and Parallels 5540. I followed the advice above, upgrading to MacFuse Core for Leopard 1.1. Parallels did start up without problem (no reinstall required), but an inability to open files from the windows partition into OS x app persists.

    AlexG, it sounds like this is a known issue - please advise how to proceed. I am happy to provide any diagnostic information. Question: is this problem in any way related to booting Parallels from a Boot Camp partition?

    As a final note, I am slightly alarmed to learn that such functionality is highly dependent upon updates to external code (MacFUSE). How does Parallels plan to manage this dependency in the future?

    thank you,
  5. redsta

    redsta Bit poster

    I've experienced the exact problem as described above with OS 10.5 and Build 5540. I can add that I am not using a Boot Camp partition.

    I should add that I do see in this thread, New Parallels Desktop 3.0 Beta Program Begins, that these two lines are listed under the section "== Known issues in Parallels Desktop 3.0 for Mac Beta (Build 5540) =="

    Note that Sharing Mac Applications was turned on, and I tried turning it off and back on without solving the problem. This leads me to believe that the issue cannot be resolved until the next build is released. Does anyone know of a workaround with Build 5540?

    When is the next build expected?

  6. fmonkey

    fmonkey Junior Member


    Using Windows Vista inside Parallels Desktop Build 5540 Beta (with the 5540 Parallels Tools installed) on Mac OS X 10.5 (Leopard), I am able to open Windows files in Mac (and vice versa) EXCEPT when double-clicking on that file in an Office 2007 email attachment. If I save the attachment and use Windows Explorer to open problem. But if I double-click the attachment inside Outlook, select Open when presented with the Opening Mail Attachment dialog, I get the error stating "To use your Windows files directly in Mac you should reinstall Parallels Desktop." Can anyone help?
  7. gmorris

    gmorris Junior Member

    Leopard, 5540 with vista

    I see some on this forum are using the same Leopard, parallels and vista installation as i tried (fmonkey as one example).

    I kept getting activation issues and grew so frustrated that i eventually abandoned the idea of trying to get vista to work in parallels. Then in bootcamp i got unrecoverable activation issues and had to reinstall vista in bootcamp. MSFT support were absolutely clueless and literally told me that Vista is just not supported on the mac with bootcamp. They gave me a tech support number for apple. Total brush off.

    I really miss using parallels which was pretty stable for me on a macbook pro 15" 3gb build 3214 with XP and 10.4. I thn upgraed to leopard and it went downhill from there causing me to loose my xp install even with bootcamp and hence the vista upgrade which allowed me to recover it.

    Has anyone else had activation issues or found work arounds to make the parallels installation more stable. I was using a parallels bootcamp install for my VM (I'm not sure if Fmonkey or anyone else was). FYI i also tried VMware fusion and that plain just doesn't work right.
  8. whuff

    whuff Member

    Same problem here

    Can someone from Parallels help us here????? I am now receiving this message when ever I attempt to use a windows file in a mac application. Since this was supposed to be the beauty of using parallels, I think you should give us a hand here in figuring out what to do!

  9. Jason Cutler

    Jason Cutler Junior Member

    I am experiencing a similar issue

    This thread is closely related to the "Opening attachments to Outlook email" thread.
    and "Leopard - Outlook - Error Message" threads.

    I have the same issue, and I'm crossposting so Parallels realizes what is happening.
    This is using

    OS X 10.4.11
    Parallels 5584
    WindowsXP SP2
    Outlook 2003

    The events that caused Outlook attachments to be unable to opened by Mac applications are as follows:

    The user's account was a local account, but I needed to convert it to a Network account unfortunately the shortname was the same. So I followed these steps I found on the Internet:
    I renamed the user's home folder for existing local account
    I deleted the local user's account (to remove it from the Netinfo database)
    made the new network account
    I renamed the user's home folder back to the original shortname
    I did a "chown" command on the folder like this:

    Everything seems to be fine except for opening attachments directly from within Outlook, unless you use a Windows app to do so. If a Mac app is assigned to open the attachment, we see the same error as Old Marine does:

    "Parallels Desktop cannot open file C:\Documents and Settings\Administrator\Local Settings\Temporary Internet Files\OLKF5\DocumentName.doc from the guest OS. You can open only files located on Windows drives (volumes) which have drive letters assigned or in Parallels Shared Folders".

    I believe this to be a permissions error. I have checked the permissions on the C drive alias, and "Others" was set to "Read Only". I tried setting it to "Read & Write" and rebooting Windows and restarting Parallels, but that didn't work. The Group permission is still "Read only", but I don't know what group these aliases should be.
    Someone on the forums suggested deleting these aliases and letting Parallels recreate them, but I'm a little nervous about that.

    I also tried:
    reinstalling Parallels Tools
    disconnecting all Shared Folders, restarting Windows and reenabling them

    If the files are on the Windows desktop they open in Mac apps fine, just not from within Outlook which is what the user expects to do.
    Last edited: May 9, 2008

Share This Page