Toolbox Video Downloader - Files aren't saving in MacOS 10.15.5

Discussion in 'Parallels Toolbox for Mac' started by BillieH, Aug 6, 2020.

  1. BillieH

    BillieH Bit Poster

    Messages:
    3
    After the latest update (colored icons), there are now a number of sites I cannot seem to download 'valid' videos.
    They seem to download, they appear to have the .mp4 extension, but they will not play in Quicktime or preview.
    I was able to open them in VLC player, but as we know, the codecs in that app are different.
    I am not sure what changed that is preventing certain downloads to play, and others will not. SS  2020-08-06 at 4.25.12 PM.png SS  2020-08-06 at 4.25.49 PM.png SS  2020-08-06 at 4.26.26 PM.png
    I am not able to replicate this with YouTube videos, however I can replicate this with several other sites that were supported prior.
    It seems that the ones that do not work natively appear to be missing key elements.
    I have tried to drop them into the Video converter, and it appears to 'convert' them, but they still do not open.

    MacOS Catalina: 10.15.5 (19F101)
    Toolbox version: Version 4.0.0 (3231)
     
  2. sergk

    sergk Parallels Developers

    Messages:
    382
    Hello,

    what is the value of your "quality" and "For non-MP4 videos" option in "Download Video" tool?
    Also could you please provide us with Technical Report (https://kb.parallels.com/en/124107) and links to some videos (not from youtube) that have a problem.
     
  3. BillieH

    BillieH Bit Poster

    Messages:
    3
    346651008
    Prior to the update, the Preferred Quality Setting was "Normal (up to 720p)" which did not offer conversion options.
    I have since tried "High" and "Maximum" to which I set to "Convert to MP4".
    There was never a need to convert, as these files are in mp4 format already. But., no matter the setting, the 'containers' of the mp4 appear to get broken.
    I should also note, that if i use developer tools to find the mp4 file path, and download via the browser, the files do not corrupt in this way.
    Also, if i give the Download Video App a direct link to the file from developer tools, the mp4 does not break either.

    The URL Example:

    A technical data report with ID 346651008 has been sent to Parallels to help us improve the product. Thank you for your feedback!
     
  4. BillieH

    BillieH Bit Poster

    Messages:
    3
    I'm not sure why the spacing was so off in my reply, and it looks like the link was stripped. Essentially, you can pull from metacafe dot com as an example of downloads that don't work.
     
  5. sergk

    sergk Parallels Developers

    Messages:
    382
    Thanks for additional info, we'll investigate it.
     
  6. StevenC12

    StevenC12 Bit Poster

    Messages:
    2
    Has this been addressed/resolved yet? I'm having the same issues following the latest major update to Toolbox (I current have v4.0.1 (3447) and MacOS v10.15.6 (19G2021)). Videos downloaded by Toolbox are no longer recognized by Quicktime, FCPX, Compressor, etc. Thanks.
     
  7. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    6,252
    Hello, could you provide us with the Toolbox technical report right after the issue reproduced and share the report's ID here?
    Also could you share with us a video link which is failing to download?
    Looking forward to your reply.
     
    Last edited: Sep 9, 2020
  8. StevenC12

    StevenC12 Bit Poster

    Messages:
    2
    Maria, thank you for your response. Technical Report ID: 349212649. And, here is a link to a random video which results in a file not recognized by Quicktime, FCPX, Compressor, etc.

    To be clear, the file is not "failing to download." A video file is downloaded and can be opened by VLC, Handbrake, etc. However, the file is not recognized by Quicktime, FCPX, Compressor, etc.

    Also, can you please add back the ability to see the details of Technical Reports prior to sending, and the ability for users to limit what data gets transmitted. These functions appear to have been removed in the latest major Toolbox update.

    Thanks again. :)
     
  9. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    6,252
    Hello, thanks a lot for the provided tech report, but we cannot see a link.
    Could you resend it please?
     

Share This Page