Tools Installation Problem: Error 1402

Discussion in 'Installation and Configuration' started by EdGoSe, Oct 26, 2010.

  1. EdGoSe

    EdGoSe

    Messages:
    1
    My latest Parallels Desktop 6 for Mac update (to build 6.0.11826 Rev 611899, Oct 19) did not appear to install Tools when I started Windows 7 (64 bit).

    I can't select Coherence mode although Desktop 6 indicates Tools are installed (bottom left corner).

    However, when I try to reinstall Tools I get Error 1402: (Could not open key: HKEY_Local_Machine32\Software\Microsoft\Windows\CurrentVersion\InternetSettings\ZoneMap\Domains\psf). I also get a similar error when I try to uninstall Tools via the Control Panel facility. The psf registry entry referred to in the error message does not exist. Also there is no Parallels folder in C:\Program Files.

    On my Windows 7 (64 bit installation) there are no registry entries beginning HKEY_Local_Machine32 but there are entries beginning HKEY_Local_Machine.

    When I try to uninstall Tools, I also lose all the the psf network file references and cannot see my files on the Mac. To get out of this I had to restore 22GB PVM from my Time Machine from a configuration before installing Desktop ver 6 - takes ages especially as I have now had to do this several times!

    I have tried reinstalling Desktop 6 (over previous version) but am reluctant to rebuild my Windows 7 virtual machine as this will take a very long time.

    Any ideas to help?
     
  2. aak

    aak

    Messages:
    73
    Hi!

    Do you have some kind of anti-virus or anti-spyware software installed?
    Could you try to disable it and reinstall Parallels Tools for Windows?
     
  3. Steve Lessard Jr

    Steve Lessard Jr

    Messages:
    4
    Same Problem

    I'm having the same issue. I've got Kaspersky Internet Security 2011 that is installed with parallels. I have the same error as the OP and cannot resolve the issue.
     
  4. Steve Lessard Jr

    Steve Lessard Jr

    Messages:
    4
    Solved the problem. There was a permissions problem for the psf keys. I applied all the changes from the parent folder "Domains". My problem was that somehow the keys were made from a user that did not exist, therefore has no owner and no permissions. Once the problem was fixed Parallels Tools updated perfectly.
     
  5. DanielCL

    DanielCL

    Messages:
    2
    How did you apply changes from the parent folder "Domains"

    I am having the same problem as both of you. I wanted to try to use the fix that solved your problem. Could you tell me how you applied the the changes from the parent folder "Domains"?
     
  6. AndreOssamuN

    AndreOssamuN

    Messages:
    8
    Same here !

    Tell us you did it ! Please !
     
  7. AndreOssamuN

    AndreOssamuN

    Messages:
    8
    Disabling the anti-virus doesn't help.

    I have Kaspersky Internet Security 2011.

    It stops and rolls back...
     

    Attached Files:

    Last edited: Nov 2, 2010
  8. Steve Lessard Jr

    Steve Lessard Jr

    Messages:
    4
    Click on Start then click on Run and type in Regedit. First thing is first backup your registry. Just incase this doesn't work correctly for you, you have a way to revert back.

    Navigate to HKEY_LOCAL_MACHINE/SOFTWARE/WOW6432NODE/MICROSOFT/WINDOWS/CURRENTVERSION/INTERNET SETTINGS/ZONEMAP/DOMAINS

    One there try to click on psf and .psf you should get an access denied message. This is because it does not know the owner and if the key has no owner it doesn't properly exist and therefore stops access.

    Make sure domains is highlighted and click edit on the menu bar then click on permissions. From there make sure that Creator Owner, System, and Administrators all have full control and that nothing is denied. (Do not worry about Users because Regedit can only be run as an administrator).

    If you see a user group called "Administrator" delete it and add the group "Administrators" (the "s" is important)

    Then click on advanced.

    Make sure that in the permissions tab all users have Allow in the type field. in the box below check "Replace all child object permissions with inheritable permissions from this object"

    Click apply.

    In the owner tab the current owner needs to be SYSTEM or ADMINISTRATOR (SYSTEM is preferred)

    Again click Replace owner on subcontainers and objects.

    Click apply then click ok. Close the permissions box.

    You should now be able to click on the .PSF and PSF keys and no access denied errors should occur. I deleted my two keys and then upgraded my parallels tools.YMMV (NEVER MODIFY THE REGISTRY UNLESS PROPERLY BACKED UP)

    Hope this works for all of you and if you have any problems feel free to respond. Also please respond if it worked :)


    Make sure in the permissions ta
     
  9. AndreOssamuN

    AndreOssamuN

    Messages:
    8
    It doesn't show any group....

    It says I don't have permission to see the permission configurations .psf but I can change the permissions.
     
  10. Steve Lessard Jr

    Steve Lessard Jr

    Messages:
    4
    If your still getting the access denied it's because of the permissions, that is the only thing that would say other than a corrupt registry. Have you edited any permissions before? they can be tricky and sometimes are a pain to deal with, but you need to make sure that you are applying the policies to the children because you are editing the parent of ".psf" and "psf". Meaning that yes because you can successfully change the permissions of "Domain" doesn't mean that "PSF" and ".psf" are changing. The trick is to get it to "trick" into the correct permissions
     
  11. DanielCL

    DanielCL

    Messages:
    2
    You should work for parallels!!

    Your solution worked perfect!! I changed the permissions in the registry, reinstalled parallels tools and it went fine. Just finished booting in coherence mode! Parallels technical support should hire you! Thanks a million.
     
  12. AndreOssamuN

    AndreOssamuN

    Messages:
    8
    Steve,

    Thanks for your help.

    If I want to see the groups first I have to go to:

    Start>All programs>Accessories>Execute(Run)>regedit>

    Navigate to HKEY_LOCAL_MACHINE/SOFTWARE/MICROSOFT/WINDOWS/CURRENTVERSION/INTERNET SETTINGS/ZONEMAP/DOMAINS

    Right click> Permissions

    From here I can see all the groups:
    CREATOR OWNER,
    SYSTEM,
    Administrators(Andre-PC\Administrators),
    Users(Andre-PC\Users)

    I click the Advanced button and I see:

    [​IMG]

    and I checked "Replace all child object permissions with inheritable permissions from this object"

    In the owner tab the current owner is already SYSTEM.

    I replaced owner on subcontainers and objects.

    And now I navigate to HKEY_LOCAL_MACHINE/SOFTWARE/WOW6432NODE/MICROSOFT/WINDOWS/CURRENTVERSION/INTERNET SETTINGS/ZONEMAP/DOMAINS

    and I can click on .psf and no access denied errors ocurred but I can't see any group.

    [​IMG]
     
  13. AndreOssamuN

    AndreOssamuN

    Messages:
    8
    WORKED !!!

    But I had to do add a group/user manually.

    As the pictures shows, " no group or user has permission to access this object..."

    I had to manually add a user so I clicked on Add button and typed Andre and the system automatically recognized me as (Andre-PC\User) and then I typed Administrators and the system automatically recognized as Administrators(Andre-PC\Administrators).

    Also as recommended by Steve, I checked "Replace all child object permissions with inheritable permissions from this object".

    Now I can use Coherent mode !

    Thanks !
     

    Attached Files:

  14. aak

    aak

    Messages:
    73
    Guys, thanks a lot!
    We'll place this solution to our support knowledge base.

    Yet one question still bothers me. What could've broke ownership to this key?
    We're still unable to reproduce this issue in lab :(

    How did you install guest Windows? Was it Express Mode or may be migration?
    Or may be it's one of Windows Updates?

    Any clues are appreciated!
     
  15. AndreOssamuN

    AndreOssamuN

    Messages:
    8
    It's been a while since Coherent Mode stop working and I don't remember if it started before upgrading to Parallels Desktop 6 or not.

    I can say that I had problems to uninstall Parallels Tools v5.xx and now I have v6.xx.

    One user said he had to uninstall the latest Windows Security update. I think the problem might have to do with security updates. But the question is: When you uninstall a security update the ownership is restored to the way it was before the update?

    I am using Windows 7 Enterprise just for the record.
     
  16. aak

    aak

    Messages:
    73
    Yes, I do remember that note on a Microsoft Security Update. We've tried to reproduce this issue with all current security updates from Microsoft. Yet no luck :(
    Andre, is there any chance you could provide us a list of all security updates installed on your Windows? You can send me those as private message.

    Guys, is there anybody who do not use Windows 7 Enterprise and have the same issues?
     
  17. nnapier

    nnapier

    Messages:
    4
    Having a similar problem, which may nor may not be related, but running Win XP Pro.

    Just upgraded to Build 6.0.11828. When tools tries to install, it fails removing the old version of tools.

    Message is: The feature you are trying to use is on a network resource that is unavailable.

    Click OK to try again, or enter an alternate path to a folder containing the installation package 'parallels-tools-386.mis in box below.

    (Path in box is LOCALS~1\Temp\PrlToolsPackages\data\i366...)

    Next message Error 1714. The older version of Parallels Tools cannot be removed. Contact you technical support group.

    I also tried removing tools via the Windows control panel, but got same error.

    The path doesn.t exits on either of my VMs.

    Any advice?

    Thanks
     
  18. aak

    aak

    Messages:
    73
    I'm quite positive that this is a different issue.
    Could try to:
    1. Restart your VM
    2. Uninstall Parallels Tools
    3. Restart VM
    4. Install Parallels Tools
    If this will not help, please send problem report and send report ID to me
     
  19. nnapier

    nnapier

    Messages:
    4
    On reflection agree it's a different problem.

    Thanks for you advice. However, the issue is that I can't uninstall the old version of parallels; when the update process tries it fails with the error I've described above.

    My quickest solution is to rebuild a new VM from scratch and re-install my applications. This way I should have a 'clean' VM, rather than keep upgrading from previous versions.

    But if you have any thoughts I'll give them a try on the old VM.

    Thanks,
     
  20. vitalb

    vitalb Parallels Developers

    Messages:
    28
    The most possible reason for your bug is cleaning Windows Installer cache and contents of temporary folders. Are you using some Windows cleaner program? To fix you need perform some advanced actions below. You can remove previous version of Parallels Tools using installation package from original source. Use file prl-tools-win.iso from previous version PD installed on your Mac. You require exactly previous PD package and two PD reinstall.

    For this you need:
    0) Find installation package of Parallels Desktop for Mac (.dmg) that was perviously installed version. Be sure you have installation package for current version, too!
    1)* Backup you current VM.
    2) Uninstall current PD.
    3) Install previous PD
    4) Start your problem VM. Do not touch other VMs if you have.
    5a) You can use menu Virtual Machine\Reinstall Parallels Tools and goto p.10). But this method is not guarantied. Better use method 5b)-9).

    5b) Mount to VMs CDROM file /Library/Parallels/Tools/prl-tools-win.iso
    6) Press Cancel if smth starts in Windows automatically.
    7) Open CD drive in guest Windows (mostly D:)
    8) Start file 'setup.exe', click Next on Welcome screen.
    9) On the next dialog you should see option buttons (Repair, Remove). Select Repair and click Next. Click Install and complete installation manually. Click OK on all windows if they are appear. Click Restart on finish screen to restart Windows.

    10) After Tools installation completes and Windows is rebooted, shut down it, stop VM, quit Parallels Desktop.
    11) Install current PD again (6.0.11828)
    12) Start your VM. Tools should update automatically.

    *) Always backup your VM before any strong manipulation.
     

Share This Page