Trigger AAAA DNS requests on IPv4-only wifi shared network and return proper result

Discussion in 'Windows Virtual Machine' started by MartinB34, Jan 25, 2023.

Tags:
  1. MartinB34

    MartinB34 Bit poster

    Messages:
    2
    Hi,
    I have encountered an issue that Microsoft Edge and other apps do not trigger AAAA DNS requests at all when the host is connected to the internet via IPv4-only WiFi network. When I switch to a WiFi network with IPv6 support then AAAA DNS queries are properly triggered.
    I want the DHCPv6 server to always assign IPv6 address and gateway to my network adapter.
    An interesting point is that Firefox triggers AAAA DNS queries but the response is somehow modified... I can see the IPv6 address in the DNS response on the host but the same DNS response does not contain this IPv6 on the guest.
    I have configured some IPv6 routes into my tunnel (WireGuard) on the host so I need IPv6 traffic on the IPv4-only networks.

    Could somebody help me, please?
     
  2. Adeboye Adeotan

    Adeboye Adeotan Staff Member

    Messages:
    358

    1. Hello MartinB34,

      Please follow the steps outlined below to enable automatic DHCPv6 IP address assignment on your network adapter and virtual machine.
      1. Make sure that the virtual machine is shut down. If it is in a suspended state, please run it and then shut it down (Actions > Shut Down).
      2. Open the virtual machine's Configuration: click the Parallels icon || > Control Center > right-click on the virtual machine > Configure.
      3. Switch to the Hardware tab and then select Network from the list.
      4. Take note of the selected option in the source dropdown.
      5. Click the "Advanced" button > Open Network Preferences
      6. Select the source noted in step 4.
      7. Click on IPv6
      8. Check the Enable IPv6 DHCP button
      9. Click on Apply.
      10. Start your virtual machine.
      11. On your Windows virtual machine, Press Windows + R to open up a Run dialog box. -> Type "control panel" in the Run box and press the Enter button to open it.
      12. Click on "View network status and tasks"
      13. On the left side of the Network and sharing center window, and click "Change adapter settings".
      14. Right-click your network adapter and click on Properties.
      15. In the new window, select the checkbox next to Internet Protocol Version 6 (TCP/IPv6) and click the Properties button.
      16. Click the "Obtain an IPv6 address automatically" radio button, and click ok.
      17. Restart your virtual machine and test connectivity.
      18. If the issue persists, please collect an additional technical report (click Parallels icon || > Help > Send technical data > check "Attach screenshots..." > press Send Report) and send the report's 9-digit ID in reply to this post.
     
  3. MartinB34

    MartinB34 Bit poster

    Messages:
    2
    Hi!
    Thank you for your answer.
    I have tried to follow the steps and checked everything but my configuration seems to be ok.
    I have sent an additional technical report with ID 417297240.

    Additional details:
    When I manually assign IPv6 DNS server and IPv6 default gateway to my network adapter (the same values which are set automatically when I am connected to WiFi with IPv6 support) then MS Edge starts to trigger DNS AAAA requests but the responses are somehow modified and IPv6 address is removed even when I see it on my host before... Similar situation which I can see in Firefox without any manual modifications.
     

Share This Page