TS must be more than 2 IPs away from GW?

Discussion in 'Parallels Remote Application Server' started by ghinky, Dec 19, 2006.

  1. ghinky

    ghinky Guest

    I set up a farm of 2 Gateways and 4 Terminal Servers with sequential IPs of x.x.58.200 through x.x.58.205. I used identical hardware and a server image so the software was identical also.

    Everything seemed to work fine, including MS RDP, but I couldn't get Verify Agent to work for 202 or 203 but 204 and 205 worked just fine.

    After much trial and error I moved 202 and 203 to 206 and 207 and everything worked. All I can figure is that the 2x software didn't want the Gateways right next to the Terminal Servers in an IP range.

    Any ideas?
  2. nixu

    nixu Guest

    Never seen any thing of that sort, I am 100% sure it is not a ip range issue.

    Make sure that agent service is running, when the agent fails to reply.

  3. ghinky

    ghinky Guest

    yes, the service is running

    I'd be happy with any other explanation because IP range makes no sense to me either.

    If I change the IP of a TS from 202 to 210 and restart the service then Verify Agent works. If I change back from 210 to 202 and restart the service then Verify Agent fails. It's the same behavior with 203 and 211.

    With GWs at 200 and 201 I can't use 202 and 203.

    Like I said before, these are all identical hardware and software. The only differences are computer name and IP - which is why I took a shot in the dark and tried changing the IPs.
  4. ghinky

    ghinky Guest

    well, looks like the IP's not the solution

    The problem has returned. 2 of the servers work fine and 2 won't verify. They are identical hardware and identical software packages. I have no idea.
  5. nixu

    nixu Guest

    Make sure that every terminal server agent is bund with only one Application Server.

  6. ghinky

    ghinky Guest

    I'm setting up a redundant system as described in


    so I can't do that in production. I tried binding each TermSrv to only one Gateway and that didn't change a thing. I also tried not binding a TermSrv to either Gateway and that didn't help either.
  7. ghinky

    ghinky Guest

    I was wrong. There was another server that had these TermSrv's associated with them that I hadn't accounted for.

    It's weird that only 2 of them messed up.

Share This Page