Ubuntu 12.10 stuck on small display

Discussion in 'Linux Guest OS Discussion' started by dankell, Oct 18, 2012.

  1. badtemperredrodent

    badtemperredrodent

    Messages:
    3
  2. YanaYana

    YanaYana

    Messages:
    1,666
    Hello everyone,
    Thank you for the issue description. Would you please send the Problem report from Help --> report a Problem and pose the report ID number here. It will help us to speed up the investigation
     
  3. badtemperredrodent

    badtemperredrodent

    Messages:
    3
    Report ID 19506150.

    Thanks.
     
  4. pkrnjevic

    pkrnjevic

    Messages:
    2
    So the answer to all PD7 owners is to upgrade to PD8? For something this minor, really?
    VMWare is looking pretty good about now - I've used them on Windows for 10+ years and they've never strong-armed my like this.
     
  5. paraNix

    paraNix

    Messages:
    21
    I will reluctantly consider purchasing what will very likely be my last upgrade of Parallels(to V8), just for this simple x recompile they COULD easily release for V& owners. I'll begin moving my testing VM's to VMWare, because I've never heard of VMWare doing what Parallels is doing here, forcing us to buy an upgrade for a simple recompile for the new version of X(thus also not even allowing us to do it ourselves). This is customer price gouging in my opinion. Oh yeah, and there has NEVER been a 3d accelerated coherence mode in Parallels, unlike VMWare (who has had it for some time now), contrary to the Parallels advertising. But hey, if you only test VM's in Windows 7/8, then Parallels is spiffy ;-)
     
  6. jockerfox

    jockerfox

    Messages:
    1
    To Serv !

    Hi Serv,
    please answer to me and to community: PD7 can run xorg 1.13 in the future ?

    Note: I have bought PD7 three / four month ago !!!!! And I made upgrade from VirtualBox to PD because I USE Ubuntu.. O my God!

    Regards.
     
  7. serv

    serv Parallels Developers

    Messages:
    789
    I can't really comment on that, sorry.
     
  8. Carl Petersen

    Carl Petersen

    Messages:
    6
    I was on the brink of coughing up the $50 for the U12.10 fix but I just can't do it. Time to find another solution.
     
  9. YanaYana

    YanaYana

    Messages:
    1,666
    Thanks for the report
     
  10. DiegoB

    DiegoB

    Messages:
    2
    try this...

    0. if is not installed install Kernel-souces gcc kernel-headers

    1. uname -a
    >> remember the version of kernel module. For example, 3.4.6-2.10-desktop

    2. sudo cp /usr/lib/parallels-tools/kmods/prl_fs_freeze/Snapshot/Guest/Linux/prl_freeze/prl_fs_freeze.ko /lib/modules/<kernel_module version>/extra/

    sudo cp /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prl_tg.ko /lib/modules/<kernel_module version>/extra/

    sudo cp /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/prl_eth.ko /lib/modules/<kernel_module version>/extra/

    sudo cp /usr/lib/parallels-tools/kmods/prl_fs/SharedFolders/Guest/Linux/prl_fs/prl_fs.ko /lib/modules/<kernel_module version>/extra/

    3. sudo depmod -a

    4. sudo modprobe prl_fs_freeze
    sudo modprobr prl_tg
    sudo modprobe prl_eth
    sudo modprobe prl_fs

    5. Then reboot your VM

    6. if necessary Reinstall Parallels Tools
     
  11. Pilotniq

    Pilotniq

    Messages:
    1
    Works for me now.

    Thanks DiegoB, that worked for me.

    The tricky part was installing the Parallels tools without the mouse.

    I used the Ctrl + Alt + T shortcut to get a terminal, then ran the Paralells installer.

    /Pilotniq
     
  12. YanaYana

    YanaYana

    Messages:
    1,666
    Thanks for the feedback!
     
  13. RudyAttias

    RudyAttias

    Messages:
    1
    [solved] just install the parallels tools from Parallels Destop 8 trial version

    - download the trial version of Parallels desktop 8 and mount the dmg
    - open a terminal and cd into the mounted dmg (cd /Volumes/Parallels\ Desktop\ 8)
    - copy the parallels tools iso to your home directory (cp ./Parallels\ Desktop.app/Contents/Resources/Tools/prl-tools-lin.iso ~/prl-tools-lin-v8.iso)
    - mount the iso on your ubuntu 12.10 and upgrade your parallels tools.
    NOTE: because of version mismatch you will get a warning about outdated parallels tools version. besides that, so far I couldn't see any incompatibilities between the Parallels Desktop 7 and the guest tools from version 8, if you find any post a comment... enjoy.
     
  14. YanaYana

    YanaYana

    Messages:
    1,666
    thanks for this guidance - i am sure it will be useful for other users
     
  15. AndrewCxxxxx

    AndrewCxxxxx

    Messages:
    1
    No support

    YanaYana, it would be good if you offered support rather than just cluttering up the forums with your unhelpful posts.
     
  16. StephenGH

    StephenGH

    Messages:
    1
    Worked beautifully for me with Mint

    Thanks Rudy! This was so easy and worked like a charm. I am running Mint 14 with kernel 3.5.0-17-generic and xorg 1.13.0. Automatic screen resize and mouse switching work as does the clipboard between Mint and my OSX host.
     
  17. Aaron_W

    Aaron_W

    Messages:
    1
    Thanks so much!

    I had to reinstall Parallels due to a corrupt HD and had the screen resolution stuck at 800x600. I followed the steps outlined by Rudy and it worked like a charm!

    For other newbies out there, to mount your iso, perform the following:

    "You can connect and mount the Parallels Tools ISO image file manually. Right-click the CD/DVD drive icon in the virtual machine's window status bar and choose Connect Image. In the Finder window, go to the hard disk folder (normally named "Macintosh HD"), select the /Library/Parallels/Tools/ folder, select the prl-tools-lin.iso file, and click Open to connect it to the virtual machine."

    Also, I had the mouse pointer issue after performing the steps but I simply reinstalled parallel tools again and everything worked like a charm.

    Thanks again
     
  18. joefly

    joefly

    Messages:
    1
    Sorry for the stupid question, I am new to ubuntu, that is why i am using VM to experiment, I got to through all of the steps that RudyAttias said except the last step to mount in Ubuntu and upgrade Parallel tools.

    Mount in Ubuntu, do you mean to start up parallel with Ubuntu 12.10 and click on the iso image? and how to I install the package. Is there terminal command line that I need? What is it?

    Sorry for the newbie question, I know this is pretty basic but I am new to Linux
     
  19. theboneofgood

    theboneofgood

    Messages:
    1
    CentOS 6 (6.4) and apparently xorg 1.13+

    After traipsing down the rabbit hole starting with no screens found, then detected devices vs. screens, then prlvideo not loading, I finally found this.

    Thank you so much Rudy!
     
  20. FionaP

    FionaP

    Messages:
    1
    Thanks so much Rudy! That was really helpful - as was much else on this thread.

    Just thought I'd let you know what I did that might help other linux noobs like me:

    Follow Rudy's first 3 instructions (copying an iso file from the downloaded dmg via macosx terminal)
    locate the prl-tools-lin-v8.iso in the home (user) directory
    rename to prl-tools-lin.iso
    go to finder and open Machindtosh HD/Libaray/Parallels/tools
    replace the prl-tools-lin.iso in there with the new one in your home directory

    open the linux virtual machine
    go up to the paralells options for that virtual machine (top bar from macosx) and go to Virtual Machine and then "Update Parallels Tools"
    now Parallels Tools should be mounted as a virtual CD in the linux OS (using the new prl-tools-lin.iso that we replaced in the library before)
    open the terminal
    write: "su"
    and type password
    if you haven't set up "su" password to be able to use the root directory just google how to
    write: "cd "
    to get to root directory
    write "cd/ media/Parallels\ Tools"
    with the Parallels Tools folder open
    write: "./install"
    this should open the Parallels Tools updater install script which is the new version downloaded and discovered thanks to Rudy's instructions
    follow the prompts with the updater and allow it to reset linux
    on reboot all problems should be solved


    I did all this from memory guys and am new to linux so please correct any mistakes I have made
     

Share This Page