Ubuntu 15.10 no Side and Menubar

Discussion in 'Linux Guest OS Discussion' started by Andre Geisler, Feb 5, 2016.

  1. Andre Geisler

    Andre Geisler Bit Poster


    I have problems with current Parallels Desktop (Version 11.1.2 (32408)) and Ubuntu 15.10.
    I upgraded compiz and now I cannot see any side or menubar in Unity.
    What I have tried so far to fix this problem:
    - rm -rf ~/.config; reboot
    - Install Parallels Tools again

    None helped!

    The problem occurs again and again! It's really frustrating when you really require a reliable virtual machine for Linux.
  2. TimoS2

    TimoS2 Bit Poster

    I have the same problem after updating my Ubuntu.
  3. ManojK@Parallels

    ManojK@Parallels Parallels Support

    As of now, Ubuntu is supported only upto 15.04 in Parallels Desktop 11 and our engineers are working to add the fore coming versions of Ubuntu. But try to choose manual installation rather then express and see how it works without parallels tools. Try to install tools later.
  4. Andre Geisler

    Andre Geisler Bit Poster

    Sorry, but the problem is not related to installation. Installing Ubuntu 15.10 wasn't the problem.
    It's about updating components like compiz, which are causing display problems.
    These problems also occur on Ubuntu 14.04 and are not really new.
    Display errors in Ubuntu 14.04 (after updating), which I could not fix,
    forced me to install a fresh Ubuntu. Than I chose a newer version.
    See this thread https://forum.parallels.com/threads/graphic-issues-in-unity-and-latest-build.330463/#post-780966
    Last edited: Feb 7, 2016
  5. ArthurK1

    ArthurK1 Bit Poster

    Hmmmmm remarkable! almost similar to Windows 10 menu probs. (also in Parallels Desktop (Version 11.1.2 (32408))

    (Sorry for being of topic)
  6. Andre Geisler

    Andre Geisler Bit Poster

    No problem.
    Just installed Ubuntu native on my besides Mac Os X.
    I cannot wait every few month for fixes in Parallels.
  7. Franck_Zoccolo

    Franck_Zoccolo Bit Poster

    Same problem here.

    "Partially" solved by uninstalling by hand the parallels tools (I recommend taking a snapshot before starting):
    • Switch to a Text only TTY (Ctrl+Alt+Fn+F1 on my MBPro)
    • log in
    • execute "sudo /usr/lib/parallels-tools/install" and choose to remove parallels tools
    • reboot
    At least I did not have to reinstall my VM and the VM is useable.

    Note: Then I tried to reinstall the tools, but same story, it does not work.
  8. Andre Geisler

    Andre Geisler Bit Poster

    I just tried it also, sadly with the same result.
    What I could observe during boot:
    - I saw all menus etc. for some seconds after reinstall and reboot.
    - Now I can see the "Parallels Shared Folders" link on Desktop flickering.

    Without Parallels tools everything works (slowly).
    So it is certainly a incompatibility between Parallels Gfx driver and compiz (again).
    I searching for an older version of compiz.

    Will it be fixed? When?
    Hopefully sooner than later.

  9. ChoiD

    ChoiD Bit Poster

    Exactly same issue here.
  10. MichaelE7


    As a temporary workaround it's possible to just remove the parallels unity plugin.
    WARNING: this breaks at least coherence, perhaps some other functions too. The workaround can be reverted by simply reinstalling the parallels tools.

    Instead of running the parallels tools uninstaller on a console run the following command: (assumes that the parallels tools are installed)
    cd /usr/lib/compiz && sudo rm libprlcompiz_0_*

    Compiz (used by unity) is crashing somewhere inside the parallels plugin. Switch to a console and run "unity --replace --debug" for a backtrace. What's even worse is that the repeated crashes trigger some sort of memory leak that causes the VM to consume more and more memory. Already crashed my MBP once, had to kill the VM two times after that as it was causing the system to freeze (consumed more than 4GB instead of the configured 2 GB).
    Andrew345 and PeterHe like this.
  11. Andre Geisler

    Andre Geisler Bit Poster

    Just tested the same VM with VMWare Fusion 8. Everything works fine, also 3D stuff is working.
    But it's a little bit slower than Parallels Desktop. I can continue using my Linux VM.
    Hopefully they will fix Parallels soon.
  12. sduensin

    sduensin Bit Poster

    Just want to add my voice to the list. This is a huge problem for me. <sigh>
  13. MarkF152

    MarkF152 Bit Poster

    Ditto here. Can't run Ubuntu unless I uninstall Parallels tools as described above.
    I had been running 15.10 for quite some time before this problem suddenly cropped up.
    Any news of a fix from the Parallels rep?
  14. JuergL

    JuergL Bit Poster

  15. PeterHe

    PeterHe Bit Poster

    Same problem, these driver issues are are getting old really fast... every update is spin on the roulette wheel
    Removing Compiz seems to fixed it for me! Reinstalling tools will reinstall these files though...
    Thanks for the tip!
  16. ManojK@Parallels

    ManojK@Parallels Parallels Support

    Hello All, please be informed that Parallels Desktop 11 Update 1 Hotfix 3 (11.1.3-32521) was released and we have updated the tools. Kindly update to the latest build from here and update Parallels Tools (Actions > Update Parallels Tools) and let us know how it works.
  17. PeterHe

    PeterHe Bit Poster

    Installed the hotfix, reinstalled parallels tools - no improvement for me! (If possibly even worse as entire screen flickers...)
    - Compiz fix still seem to work so...
  18. imacken

    imacken Kilo Poster

    This is a joke. I have the same issue as PeterHe. 15.10 was working fine until I updated to 11.1.3-32521!
    Now, just the desktop background and nothing else!
  19. Franck_Zoccolo

    Franck_Zoccolo Bit Poster

    Was working with 11.1.3-32521 until today when I updated my Ubuntu VM : Seems that another compiz/unity update broke everything again...
  20. O_B

    O_B Bit Poster

    Same here. Parallels Desktop 11 for Mac, Version 11.1.3 (32521), Ubuntu 15.10 64-bit.

    Got unity and sidebar working by installing compiz-config-settings-manager
    sudo apt-get install compiz-config-settings-manager
    Then, run ccsm - and enable the Ubuntu Unity plugin.
    Got a ton of conflicts - clicked through/accepted them all.
    Not a fix - but a workaround (for me).
    Last edited: Mar 8, 2016

Share This Page