Ubuntu 15.10 no Side and Menubar

Discussion in 'Linux Guest OS Discussion' started by Andre Geisler, Feb 5, 2016.

  1. BenR2

    BenR2 Bit Poster

    Messages:
    5
    This fixed my problem but if you reinstall the parallels tools it will break again.
     
  2. Andre Geisler

    Andre Geisler Bit Poster

    Messages:
    16
    Updating to Parallels 11.1.3 (32521) did not help.
     
  3. Andrew345

    Andrew345 Bit Poster

    Messages:
    3
    I updated to Version 11.1.3 (32521) from 10, uninstalled & reinstalled the Parallels tools and the problem remains.

    I've just removed the Parallels /usr/lib/compiz/libprlcompiz_0_* as MichaelE7 suggested and its working (in Windowed mode) again! Thanks MichaelE7!

    There's an Ubuntu Launchpad issue here for this: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1546838 (though from this thread it sounds like its a Parallels issue rather than compiz issue)
     
  4. EgorK1

    EgorK1 Bit Poster

    Messages:
    1
    I just had to do the removing compiz plugin procedure and things are working. Perhaps a little slower but at least functional. Hoping for a proper fix soon...
     
  5. Brian Turner

    Brian Turner Bit Poster

    Messages:
    6
    Incredibly Poor Support From Parallels!!!
    The OP started this thread over 6 weeks ago. During that time there have been several suggestions of 'work arounds' from various Parallels customers, but nothing constructive at all from Parallels support staff.
    I bought Parallels to enable me to use virtual machines on my Mac and I have Linux Ubuntu as one of those virtual machines. When I follow the Ubuntu links in Software Updater, I end up with no Side Bar or Menu Bar, as the OP stated. This, of course, renders that particular VM unusable.
    I'm currently downloading alternative software that is guaranteed to work with Linux and is updated whenever necessary in order to keep it working. I'll then be looking to Parallels for a partial refund of my subscription as this software no longer does as it's advertised and the developers don't give a toss about their paying customers.
     
  6. JuergL

    JuergL Bit Poster

    Messages:
    2
    Still no updated drivers? Are the Parallels folks even aware that there is a problem, currently? I must agree, I too expect a faster turnaround for a product that costs this much and requires charging for paid upgrades at such frequency as Parallels does.
     
  7. Bill Standen

    Bill Standen Bit Poster

    Messages:
    22
    Agreed that the delay on this is getting absurd.
    Parallels, can we at least get an ETA or even just a progress report?
     
  8. marat_t

    marat_t Parallels Support

    Messages:
    288
    try this:
    1) Login into GUI shell (blank Unity screen must appears)
    2) Switch into text terminal (Ctrl+Alt+F2) and perform commands
    export DISPLAY=:0
    compiz --replace core decor composite opengl move resize unityshell &
    5) Switch back into GUI shell (must see Unity interface)
    6) Run GUI terminal, and perform following commands (can copy/paste)
    sudo rm /usr/lib/compiz/libprlcompiz_0_9_12_2.so
    gsettings set org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins "['core', 'ccp', 'composite', 'opengl', 'place', 'snap', 'imgpng', 'resize', 'commands', 'compiztoolbox', 'move', 'mousepoll', 'grid', 'wall', 'vpswitch', 'unitymtgrabhandles', 'regex', 'copytex', 'session', 'animation', 'workarounds', 'expo', 'fade', 'scale', 'ezoom', 'unityshell']"
    7) Reboot

    P.S. don't forget to take a snapshot before proceeding. Also, it will be easier to perform these steps from host terminal using ssh
     
    Last edited: Apr 3, 2016
    Pbryanw and DirkTi like this.
  9. JacobJ1

    JacobJ1 Bit Poster

    Messages:
    5
    If you want to create a new VM with Ubuntu 15.10 issue the following commands before you update the software:

    echo "compiz hold" | sudo dpkg --set-selections
    echo "compiz-core hold" | sudo dpkg --set-selections
    echo "compiz-gnome hold" | sudo dpkg --set-selections
    echo "compiz-plugins-default hold" | sudo dpkg --set-selections

    Not 100% sure if all are needed but this prevents compiz from being updated. The holds can be released as soon as there is a better fix for this issue.
     
  10. Andre Geisler

    Andre Geisler Bit Poster

    Messages:
    16
    Hello,

    just tested with Parallels Release Version 11.2.0 (32581): Ubuntu 15.10 works fine now!
    I am also tested Ubuntu 16.04 clean install successfully.
    Next I will test an upgrade from 15.10 to 16.04.
    Many thanks to the Parallels Developer team!
     
  11. Andre Geisler

    Andre Geisler Bit Poster

    Messages:
    16
    Upgrading from15.10 to 16.04 also worked perfectly.
    Great Ubuntu and Parallels is usable again!
     

Share This Page