Ubuntu 7.10 and Parallels 5160 does NOT WORK!

Discussion in 'Linux Virtual Machine' started by akidd, Oct 19, 2007.

  1. akidd

    akidd Member

    Mac Pro Dual 2.4
    4GB Ram
    Parallels build 5160

    Got the released Ubuntu 7.10. Verified the ISO ubuntu-7.10-desktop-i386.iso

    I set up a VM:

    OS Type Linux
    OS Version Ubuntu Linux

    Everything else defaults. Upon trying to install I get:

    'The display server has been shut down about 6 times in the last 90 seconds. It is likely that something bad is going on. Waiting for 2 minutes before trying again on display :0.'

    I've tried every idea I could find via google and the Parallels forum. VGA=791 Kernel parameter. Start in Safe Mode. Changing VGA mode. I am unable to exit to commandline "ALT-F1" or kill X "CTRL-ALT-BACKSPACE" when it is cycling.

    I love Parallels, but as a victim of the original 3.0 release I bought VMWare Fusion to avoid the many issues I was having at the time. For kicks I tried the release Ubuntu 7.10 on Fusion and it works first time, all defaults... <ARGH>
  2. runelind

    runelind Bit poster

    Yep, same thing happened to me. I'm running a Macbook with build 5160.
  3. toddritt

    toddritt Bit poster

    I have the exact same problem/symptoms/scenario, fwiw.

    Thanks for any help,
  4. markgilbert

    markgilbert Bit poster

    How I Got 7.10 Working

    I did an upgrade install through Ubuntu to 7.10 an was presented with the messages about the X server restarting.

    My solution was this

    Boot normally and wait for the error to appear, then you are dumped at the console for 2 minutes.

    Select "Install Parallels Tools" from the Action menu and ok the dialogue

    at the command line type;
    sudo mount /media/cdrom
    cd /media/cdrom
    sudo sh prl-tools-uninstall.sh

    Say Yes to the next question about are you sure, note the uppercase Y as my system would not accept a lowercase y

    then type;
    sudo shutdown -r now

    After I had done this and rebooted my system booted ok. Sorry that this wont help those who have just tried to install a fresh copy of 7.10, but it may help those upgrading. An alternative solution to the fresh install is download an older version such as 7.04, then do the upgrade via Ubuntu and when the X server issue happens, remove Parallels Tools, or try not installing them at all, that may work too.

    For the record I am running build 5160 on a 24" iMac.

  5. MrMacHead

    MrMacHead Member

    I had the same error trying to install from the ubuntu-7.10-desktop-i386.iso. Then I used the hint from this thread http://forum.parallels.com/showthread.php?t=17069

    Using the alternate install ISO seemed to work OK. So far, though, I am stuck with just the 1900 X 1200 resolution on my 24" iMac. Attempting to use the Screen Resolution preference to switch to a lower resolution results in display problems.
  6. midtoad

    midtoad Bit poster

    yes it does

    I just installed 7.10 on a MBP with Parallels 3.0 build 5160. I used the Alternate CD (check off 'alternate cd' on the distribution download page on ubuntulinux.com).

    The only issue I'm having at the moment is that Ubuntu persists in running at 1600x1200, whereas my Sony external monitor is running at 1024x768. This is a pain because to reach parts of the Ubuntu desktop, I have to press Ctrl-Alt to be able to reach the scroll bars on the window that Ubuntu is running in. I'm unable to run full-screen. Each time I try to change the Ubuntu screen resolution to something smaller, the setting results in an illegible screen.
  7. jmarcus

    jmarcus Bit poster

    7.10 alternative/text installer works

    I had the same problem described above with the xserver not starting. I then had luck installing ubuntu 7.10 on my MB using the alternative/text version. WRT the screen resolution, during the install there was a question about which screen resolutions to support - I selected the LCD size and then a couple smaller resolutions (800x600, 640x480).

    It takes alot longer to install but it worked!
  8. jimcoyle

    jimcoyle Hunter

    I too, finally got it installed by using the alternate image and hand-picking the screen resolution to use. Working fine now.
  9. jgadbaw

    jgadbaw Bit poster

    It does work

    I did a standard upgrade to my Ubuntu 7.04 setup and it went off without a hitch. No problem with the video and all my previous setup options were maintained. Standard iMac setup. I was careful to make sure all the current updates were done before the upgrade. I realize YMMV, but I have not had any trouble with Ubuntu. I urge everyone to be patient and calm and stick with it.
  10. midtoad

    midtoad Bit poster

    fixed the screen

    I fixed my screen problem, which was that Ubuntu persisted in coming up with a 1600x1200 desktop, even though my Apple MBP only supports up to a 1280x800 desktop. Each time I tried in Ubuntu to reduce the screen resolution, I got an unusable screen (wrong scan rate or something). This caused my Parallels session to have scroll bars, and to reach the opposite corners of my Ubuntu desktop I'd have to press Ctrl-Alt to escape the desktop, then scroll the window, then click inside again to have Ubuntu re-capture the mouse.

    What I did was wait for Ubuntu to start up, then opened a terminal session and typed:

    then I looked for Section "Screen" and Subsection "Display" and then deleted the highest-resolution modes, e.g. 1600x1200, 1280x1024. I then restarted the Ubuntu graphical desktop with Ctrl-Alt-R-backspace, and it restarted with the new largest resolution, which I'd set as 1280x800.

    BTW, in the Parallels settings for video for this virtual machine, I de-selected Use Custom Resolutions.

  11. Xenos

    Xenos Parallels Team

    Dear all,

    We are sorry for not paying attention to the thread for such a long time. Please take into consideration that the forum is the place to share your questions and opinions with other users. We are trying hard to provide you with solutions on the problems you encounter but it's sometimes difficult to monitor all forum discussions at once. Anyway we are grateful for the information you give us to improve our products. For obtaining quick support service from Parallels, please send a request ticket.

    To fix the X problem causing display problems (including "The display server has been shut down about 6 times..." error) you should go to /etc/X11/xorg.conf file.
    In the file find ServerFlags Section that looks like this:

    Section "ServerFlags"

    If there is no ServerFlags Section, you should create it and type there:
    Option "Xinerama" "True"

    If the Option already exists but it's "False", change it on "True".

    You should finally get something like this:

    Section "ServerFlags"
    Option "Xinerama" "True"

    Save and restart Linux.

    We'd appreciate you giving the feedback.

    Best regards,

Share This Page