Ubuntu 8.04 freezes with Parallels 4

Discussion in 'Linux Virtual Machine' started by lukeoldboy, Nov 13, 2008.

  1. John@Parallels

    John@Parallels Forum Maven

    All operations inside VM are protocoling , so asking logs is normal operations, which allow us to understand what s going on on Mac
  2. mojo6771

    mojo6771 Junior Member

    We are getting nowhere

    - lets look at the history of the forums :

    - Parallels 3 worked well with unbuntu (8.04 and 8.10)
    - Parallels 4 is cool since it gives full screen support

    - Problems have been reported with 8.04
    - With 8.10 first the response was it it not supported, then it was supported (though the web pages
    of Parallels do not reflect that). (Since 8.10 is the latest Ubuntu build customers are going to use it)

    - a number of users have submitted the problem tickets
    - Parallels team asked users to try some steps (like disable sharing), that was no help
    - there was a new build released. The release notes made no mention of this ubuntu issue. Still
    all of us upgraded hoping for the best. But it was no help.

    So far it seems the Parallels engineers have not been able to recreate the issue within their environment.
    A number of users (including me) have offered to help in any way we can. I understand Parallels is a complicated beast, but an reasonable person can see that we are getting nowhere...

    This issue has been going on for 3 months now...(customers have been very patient).

    As I see it (I could be wrong, since I am a newbie on Parallels), this product is just not usable by its customers.
    We are using Parallels in the recommended way and not doing anything out of the norm.
  3. jgadbaw

    jgadbaw Bit poster

    Try This

    I think this is a fix that you all could try if you are running 8.10. Go to System/Administration/Synaptic Package Manager. Search for backport. You will see linux-backports-module-intrepid. Select and apply. That should fix it for you. There has been a problem with 8.10 installations on PC's as well with the freeze thing. Good luck
  4. jgadbaw

    jgadbaw Bit poster

    Try this. Go to System/Aministration/Synaptic Package Manager. Search for "backport". Then if you are running 8.10, select linux-backports-module-intrepid and then apply changes. This should fix the freezing problem. There has been a similar problem with 8.10 on PC installations and this fixes system freezing. Good Luck - worked for me.
  5. David Alvaro

    David Alvaro Bit poster

    Another report if can help you: ID 88238
  6. stewarsh

    stewarsh Member

    Possible Workaround

    I was recently revisiting this, and unchecked the 'Synchronize Time with host the computer' option and have been running all day w/o a freeze.
  7. bliblong

    bliblong Bit poster

    I can confirm this seems to be a possible workaround. I unchecked the "Synchronize time with the host computer" setting since the end of January (yes, I've submitted a trouble ticket and report :), and it hasn't frozen since.

    However, for good measure I also increased the amount of memory to the vm (Ubuntu 8.04 LTS) partition to 1024 MB, disabled the Shared Folders (I'm now using a USB flash drive to share files), and enabled the Adaptive Hypervisor, on the theory that the problem might be exacerbated by a CPU or memory resource issue causing eventual deadlock.

    I now shut down the partition every time I suspend my laptop, and back it up nightly for good measure, but will try to isolate the problem further by selectively returning the other settings to their previous defaults, and report back on the outcome in a few days.
  8. l3xh2k

    l3xh2k Bit poster

    Disabling the clock synchronization seems to have done the trick for me as well. I left everything else alone (ie, defaults).

    For those trying to reproduce this, it was pretty reliable for me when I had a terminal open and synaptics open. After 10 minutes or so, keystrokes were not always getting through to the terminal. Eventually, the machine hangs.

    My starting point was the 8.04 downloadable Ubuntu appliance; updated and then installed Parallels Tools.
  9. bliblong

    bliblong Bit poster

    Further to my previous post I've done further testing by returning the other settings to their previous defaults, and it has been stable for the last 5 days with the clock synchronization disabled. Suspending (sleeping) my laptop with the vm running causes the time to go out of synch, but I simply toggle the synchronization (on and then back off) when I resume my suspended session, and it resynchronizes the time in the vm without any problems.

    An annoyance, certainly, but it seems to be a viable workaround until there's a fix.
  10. Roy Harrell

    Roy Harrell Bit poster

    I've experienced a similar behavior with my installation of FC7 in Parallels 4 on my 4GB 15" Macbook pro. Following the advise from this thread, I disable clock synchronization and have had only one lockup since. This occurred within seconds after I disabled the Network Time Protocol from within the Set Date and Time Fedora applet (not sure what relationship this has with the clock sync configuration option within Parallels). Not sure if this is relevant or a coincident.

Share This Page