Unable to allocate memory for Monitor PE!! continues

Discussion in 'Installation and Configuration of Parallels Desktop' started by iGreg, Jul 29, 2007.

  1. iGreg

    iGreg Bit poster

    I found an archived thread with my exact problem and it is archived and I can't post to it.

    I tried to launch my XP virtual machine and got error message that "memory could not be allocated to Monitor PE".

    It was working fine for weeks, then suddenly this issue pops up.

    Only way to get the virtual machine to load was to reboot my intel iMac.

    The thread was inconclusive, why was it archived?

  2. Purplish

    Purplish Forum Maven

    February to May may not seem like a long time ago, but version 1970 does seem like a very long time ago. Is that what you were asking?
  3. wgdixon

    wgdixon Member

    That was probably *my* thread that was archived. No idea what these jokers are thinking. Anyway, for a while with version 3 I would start up Parallels and my VM shortly after booting and leave it running in Coherence mode. That *seemed* to work OK except for the constant CPU overhead being used (can you hear the giant sucking sound?). Well, at least it worked, and once in a while I could even access files on my Mac's file system!

    Well, as it happens I recently suspended my VM and rebooted MacOS for some reason, then didn't fire up Parallels for "a while". Of course, the problem has now returned and I cannot resume the VM. Chances are it will work if I reboot MacOS, which I refuse to do since it is disrputive and it just shouldn't be broke this way anyhow. What do I do in the interim? Well, Fusion seems to be working quite nicely, thank you, even as beta :). I have been in contact with Parallels support off and on about this for months with no resolution, the latest being to "try version 3". Oh well.......
  4. robert.staflin

    robert.staflin Bit poster

    I just ran into this problem myself. I had to Suspend my Windows XP machine for a reboot, and on startup I got this exact error.

    I'm running build 4560 (the latest that I know of). I've also hade the other problem mentioned, with Parallels taking all free processor cycles while trying to restore from a suspended state, never getting there.

    Just now, when trying to get the machine to start, my Mac crashed brutally. After the reboot the VM also started up without a hitch.
  5. scottm01

    scottm01 Bit poster


    I'm seeing this a lot lately; if I don't get this one I get another "unable to allocate" error. I have 4 gigs, and generally 3.5 of that is free when I start parallels.

    I use VMWare at home and will likely just pony up for a copy of fusion at work as well as I've had no luck even finding an official bug report or explanation from Parallels.
  6. guydavies

    guydavies Member

    Hmm, I've just seen this for the first time. I found this thread (and a few others) by searching. However, I tried to fix this by allocating more memory to the VM. Unfortunately, that just caused a crash of the box. :-( I'm running the most recent version of Parallels desktop.

    panic(cpu 1 caller 0x001A4A55): Unresolved kernel trap (CPU 1, Type 27=Unknown), registers:
    CR0: 0x8001003b, CR2: 0x64b37050, CR3: 0x00f64000, CR4: 0x000006e0
    EAX: 0x00000001, EBX: 0x6d626572, ECX: 0x00000000, EDX: 0x00000000
    CR2: 0x64b37050, EBP: 0x366ab970, ESI: 0x6d616769, EDI: 0x63216e75
    EFL: 0x00000246, EIP: 0x64b35c12, CS: 0x00000008, DS: 0x00000010

    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x366ab6e8 : 0x128d08 (0x3cc0a4 0x366ab70c 0x131de5 0x0)
    0x366ab728 : 0x1a4a55 (0x3d24b8 0x1 0x1b 0x3cb56c)
    0x366ab838 : 0x19aeb4 (0x366ab850 0x0 0x1676f3c 0x0)
    0x366ab970 : 0x64b352d0 (0x4c2cc000 0x5f5be84 0x7f89404 0x366abeb8)
    0x366abaa8 : 0x4c78241f (0x366abeb8 0x0 0x0 0x0)
    0x366abb18 : 0x4c7826d9 (0x5f5be84 0x366abeb8 0x200000 0x1992a3)
    0x366abbd8 : 0x4c782ef4 (0x5f5be84 0x366abeb8 0x18 0x0)
    0x366abd38 : 0x4c77e940 (0x5f5be84 0xc0185401 0x366abeb8 0x19e23a)
    0x366abd68 : 0x1f1668 (0xb000000 0xc0185401 0x366abeb8 0x81)
    0x366abda8 : 0x1e84a2 (0x366abdd0 0x297 0x366abe08 0x5dcc3e8)
    0x366abe08 : 0x1e02a3 (0x74776b4 0xc0185401 0x366abeb8 0x81)
    0x366abe58 : 0x332ac8 (0x5da6dc0 0xc0185401 0x366abeb8 0x5dcc3e8)
    0x366abe88 : 0x350e24 (0x5da6dc0 0xc0185401 0x366abeb8 0x5dcc3e8)
    0x366abf58 : 0x37ad83 (0x5dcc3e8 0x61e75f8 0x61e763c 0x0)
    0x366abfc8 : 0x19b28e (0x6263f40 0x0 0x10 0x6263f40) No mapping exists for frame pointer
    Backtrace terminated-invalid frame pointer 0xbfffdf78
    Kernel loadable modules in backtrace (with dependencies):

    Kernel version:
    Darwin Kernel Version 8.10.1: Wed May 23 16:33:00 PDT 2007; root:xnu-792.22.5~1/RELEASE_I386

    Model: MacBookPro2,1, BootROM MBP21.00A5.B01, 2 processors, Intel Core 2 Duo, 2.33 GHz, 3 GB
    Graphics: ATI Radeon X1600, ATY,RadeonX1600, PCIe, 256 MB
    Memory Module: BANK 0/DIMM0, 2 GB, DDR2 SDRAM, 667 MHz
    Memory Module: BANK 1/DIMM1, 1 GB, DDR2 SDRAM, 667 MHz
    AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x87),
    Bluetooth: Version 1.9.0f8, 2 service, 1 devices, 1 incoming serial ports
    Network Service: Built-in Ethernet, Ethernet, en0
    Network Service: Parallels Host-Guest, Ethernet, en2
    Serial ATA Device: Hitachi HTS541616J9SA00, 149.05 GB
    Parallel ATA Device: MATSHITADVD-R UJ-85J
    USB Device: Built-in iSight, Micron, Up to 480 Mb/sec, 500 mA
    USB Device: Bluetooth USB Host Controller, Apple, Inc., Up to 12 Mb/sec, 500 mA
    USB Device: Hub in Apple Pro Keyboard, Mitsumi Electric, Up to 12 Mb/sec, 500 mA
    USB Device: USB Receiver, Logitech, Up to 1.5 Mb/sec, 100 mA
    USB Device: Apple Pro Keyboard, Mitsumi Electric, Up to 12 Mb/sec, 250 mA
    USB Device: IR Receiver, Apple Computer, Inc., Up to 12 Mb/sec, 500 mA
    USB Device: Apple Internal Keyboard / Trackpad, Apple Computer, Up to 12 Mb/sec, 500 mA
  7. mcooper

    mcooper Bit poster

    I think it might be X11

    My system was working fine, then I installed X11 and OpenOffice 2.1 and tried it out. I then closed OpenOffice to return to NeoOffice, tried to open a Japanese Word document in OpenOffice and realized it was a complete mess (OO has problems with some Japanese Word formatting), and then tried to open the document in MSWord in my Windows VM with Parallels. I got the "Unable to allocate..." error. I rebooted and then was able to use the VM, but I suspect that this was caused by either the X11 install or using X11 before trying to use Parallels.

    Parallels support, please work on this.
  8. cedmond

    cedmond Bit poster

    After running into this issue myself I ran the daily, weekly & monthly scripts in /etc/ and haven't had an issue since. These scripts are supposed to run on a schedule but due to the times that they are set to run by default and the fact that your machine may be asleep or off when they are supposed to run, they don't execute as they should.

    For reference: http://www.thexlab.com/faqs/maintscripts.html

    In Terminal (it will ask for your admin password):
    sudo sh /etc/daily
    sudo sh /etc/weekly
    sudo sh /etc/monthly

    I don't use Parallels all that much so this may be unrelated or may not be a permanent fix. I just thought I would throw it out there to see if it helps.
  9. RDL

    RDL Bit poster

    Unable to allocate memory for monitor PE!

    "Unable to allocate memory for monitor PE!"

    Nothing new. Fully charged MacBook was put to sleep at the office. One & half hours later it was very warm and would not wake up. Hit the start button, read some mail, then started Parallels and got the above message when I pressed the Green Arrow Head. I had allocated about 850 MB to memory then increased that to one GB. It still does not work.

    Next day:
    Further to that XP is corrupted and only works in Safe Mode. I've tried to roll back the settings for several days but that is not helping. It appears that this will take a complete reinstall.

    Last edited: Oct 23, 2007

Share This Page