Unable to allocate memory for monitor PE!

Discussion in 'Installation and Configuration' started by vaderstryder, Oct 28, 2007.

  1. vaderstryder

    vaderstryder

    Messages:
    1
    Has anyone else had this error message since installing Leopard? If so, have you found a solution?

    Any help is appreciated.
     
  2. Chris Wheeler

    Chris Wheeler

    Messages:
    1
    Same error, Fresh install of Leopard, fresh install of 5160

    Instead of upgrade, I tried a fresh install of Leopard & build 5160.
    Tried to open backup of WinXP pro by File-Open- drive with PVS file.
    Got: Unable to allocate memory for monitor PE!

    MacBook Pro 2.33Ghz Core 2 Duo/2GB RAM

    I realize that Leopard is a few days old, I just wanted to add my symptoms to the pile.

    Chris
     
  3. airmunch

    airmunch

    Messages:
    9
    Yep same problem here. Out of curiosity - are you trying to start the VM in another 'Space' - more importantly do you have Spaces enabled?

    When I have Spaces enabled I tend to get this error and/or Kernal Panics. I am also using Parallels 3.0 b5160.

    Disabling Spaces seems to fix this for me... you can then re-enable Spaces after Parallels has started.
     
    Last edited: Oct 28, 2007
  4. Alicia

    Alicia Parallels Team

    Messages:
    693
    Hello,

    Parallels allocates Virtual Machine's RAM as one integral file. Consequently when your Macs RAM is too defragmentated (when too many applications are launched) then there could be not enough space in one sector for this file. And it causes this error when you are trying to start your virtual machine. But when you try to start it again - it may cause kernel panic or grey screen of death.
    So the solution of your problem is following:
    - Reboot your Mac, do not launch any applications except Parallels - try to load Windows then.
    - You will need to decrease amount of virtual RAM for your VM if the problem still occurs.

    Best regards,
    Alicia.
     
  5. StefanM

    StefanM

    Messages:
    10
    I have this problem too.

    I need to reboot my Mac and then first start Parallels before any other application.
    This is bad!!!

    Any ideas how to solve this?
    My Virtual Machine has 1024 MB of RAM
     
  6. Marc Vos

    Marc Vos Bit Poster

    Messages:
    29
    I had it after installing Leopard. I reinstalled build 5162 and now it runs ok. Only thing I have is that the F11 and F12 key are the same as the PrtScn and de ScrLk keys.
     
  7. StefanM

    StefanM

    Messages:
    10
    So did you directly installed 5162?

    I installed 5160 and did an update 5162...
     
  8. chriswaar

    chriswaar

    Messages:
    4
    i'm having this error as well. I recently installed a fresh copy of leopard and have 2gb of memory.
     
  9. Marc Vos

    Marc Vos Bit Poster

    Messages:
    29
    I already ran 5160 under 10.4.10. So it's an upgrade, yes. But I upgraded before installing Leopard and again afterwards.
     
  10. uvahoos

    uvahoos

    Messages:
    1
    I am having the same issue. I rebuilt my MacBook Pro from scratch with Leopard and installed Parallels build 5540 as was recommended. I built a new VM for XP and it worked fine. Then I installed Boot Camp and Vista. Everything still working fine. Went back to Leopard and started to create a new VM for Vista Boot Camp. Went through setup and attempted to start the VM when I got that message about being unable to allocate memory.

    Now neither my XP or Vista VMs will run. Always get that error. even after reboot and nothing else running. I have the XP VM set for 512MB and the Vista one for 2048MB. I have 4GB of RAM.

    Please help as this i smy primary work machine and I really do need Parallels to work again or I am going to have to drop some cash on Fusion.

    PS - I originally upgraded to Leopard and was running the current production build of Parallels and essentially the same thing happened. Eventually my Boot Camp install of Vista completely stopped booting.
     
  11. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Dear all,

    We are sorry for the inconvenience caused. We are working hard to fix the issue but for the moment we can't offer you a solution alternative to the one given by Alicia.

    There's just one note: it's possible to start a virtual machine automatically on Mac OS X startup.

    Best regards,
    Xenos
     
  12. Ryan Taylor

    Ryan Taylor

    Messages:
    3
    I think this is the golden ticket. I was getting the memory message followed by kernel panics and being forced to restart my machine almost every single time I tried to run Parallels. I tried the above suggestion to disable Spaces, launch Parallels, then re-enable Spaces and it has worked great for me. I am running build 5540.
     
  13. jsgoecke

    jsgoecke

    Messages:
    1
    I have build 5160 and am having the same issue, but even with disabling Spaces no joy. Should I simply assume that Parallels is not Leopard compatible? My VMWare Fusion is running just fine...but Parallels seems highly unstable as it was running but would crash frequently.

    And rebooting my machine and running Parallels first sounds like a bug, not a solution.
     
    Last edited: Nov 1, 2007
  14. Xenos

    Xenos Parallels Team

    Messages:
    1,596
    Dear jsgoecke, a new free build with PD-Leopard issues fixed is coming soon. There is a number of bugs that we could not prevent because of some last-minute changes in Leopard's official release. We are sorry for the inconvenience caused.

    Best regards,
    Xenos
     
  15. Juan

    Juan

    Messages:
    2
    The problem that I have been noticing is with 'Spaces'. when I start up Parallels in one space and then drag the start up window to a different 'Space' and then start the parallel, for some reason my macbook does not like that and I run into memory issues. What I do now is start the parallel in one 'space', once it has been totally started, I move it to another 'space'. When I'm done, I move the window back to the 'space' I started it in, and then close it down there. If I close it down in another 'space' where it was not started in, well..I run into memory problems, hope it helps.

    ps. get this fixed!!

    Regards
    Juan
     
  16. maurizionaro

    maurizionaro

    Messages:
    2
    I had the same problem today after having installed EYETV HYBRID on my macpro. I had to disinstall it in order to have Parallel to work again
     
  17. bamsaleg

    bamsaleg

    Messages:
    27
    I tried just that. Restarting hoping to be able to use Parallels again.

    Nope. Still the same kernel panic :(
     
  18. bamsaleg

    bamsaleg

    Messages:
    27
    Just a question before I try this long way...

    Did someone tried to go back to 10.4.X? Did this help recover the VM?

    EDIT: It' working... this is the workaround !

    Just to help the community, I reformatted an external hard drive and give this idea a trial.

    After reinstalling Tiger, I was able to install this beta and start my VM. No apparent damages, no warning.
    I updated the Parallels tools. Rebooted the VM in 10.4, verified that it worked and did a complete VM shut down.

    I rebooted in 10.5 and voila... Parallels is back.

    So the temporary work around is to have a 10.4 external hard disk or partition around.

    This "adventure" gave e an opportunity to try Fusion again.
    - I am still much more comfortable with Parallels !
    - But I love the way vmware offers you to retrieve your serial number online.
    In such situation restoring a full mail backup to find back my original Parallels 3 product keys was not funny.


    I hope this experience could help other
     
    Last edited: Nov 11, 2007
  19. Martin

    Martin

    Messages:
    38
    Leopard running since the first day, the problem suddenly occured this morning on my MBP. Restart didn't help, but de-attaching the Time Machine drive did the trick. At least for now the solution works. Waiting for the Leopard fix; HTH Martin
     
  20. maurizionaro

    maurizionaro

    Messages:
    2
    I solved the problem with eyetv reinstalling it while Parallels was working. the first time I had installed it just after the boot and that cancelled completely the monitor settings on parallels.
     

Share This Page