Unable to allocate memory for monitor PE!

Discussion in 'Installation and Configuration' started by vaderstryder, Oct 28, 2007.

  1. dioshy


    Same problem here

    I have a Macbook Pro (last generation) with 4gigs of RAM and 200gigs hard disk.
    I recently upgraded to Leopard and Parallels was working PERFECT, until today, were I got the alread known error message - after been using it with Leopard for about 2 weeks.
    I have disabled Spaces and since then Parallels is in an infinite loop trying to launch itself every time I try to run it.
    I'm running Parallels 5160 on Leopard (10.5.1) and Windows Vista Ultimate.
    I think that we must wait until an update is realeased.
  2. Xenos

    Xenos Parallels Team

    Hello dioshy,

    Could you please try these steps:

    a) reboot the MAC
    b) increase manually the size of Memory in Parallels Desktop/Preferences
    c) enable virtual memory preallocation
    d) decrease the size of RAM memory allocated to the virtual machine
    e) reinstall Parallels Desktop in the following manner.

    You will also probably have to decrease the total RAM for your Macbook.

    Best regards,
  3. dioshy


    Hi Xenos, and everyone.

    As soon as I rebooted my MAC, just after posting my message, I tried to launch Parallels and it worked perfectly. I now have Spaces disabled and can run Parallels whenever I want to.

    Just an interesting comment and question, how could I be asked to DECREASE the total RAM of my Macbook? Incredible!
  4. cozza


    I experienced this exact same problem today. I've been using Leopard since it was released and have not had this problem until today. Following two hard reboots of my MBP I turned off spaces and Parallels is now working fine. I've not experienced issues with spaces and other applications, so it points more to Parallels than spaces. I would like to keep using spaces but will put up with switching spaces off when I need to run Parallels.

    MBP details: 2.4Ghz, 4Gb RAM. Leopard was installed as an upgrade. Parallels is build 5160.
  5. Eru Ithildur

    Eru Ithildur

    Good for troubleshooting as in the past there have been issues with large amounts of RAM.
  6. paralleldan


    I just upgraded my memory to 4GB in my book pro, and 3GB in my desktop. Parallels now fails in both (Leopard), either with a blue screen or with the above message.

    Ironic - I upgraded my memory so as to better handle parallels, and it causes the app to crash.
  7. stef56


    Congratultions!! you have managed to create a software package that has been the most irritating install and upgrade process i have ever encountered in my 20 years as a software engineer....unable to allocate memory for monitor PE this problem is stopping me from using your software ..i will switch to a different package and begin advising my clients to do the same...I am VERY frustrated and disappointed...you need a SOFTWARE ARCHITECT..not a bunch of amateur programmers with a good idea.
  8. Rachel Faith

    Rachel Faith

    The Restart, change the memory, restart again and reset the memory does work... but for the luv !!

    This just happens SOMETIMES... other times I can run it fine. And I have spaces on and off and that makes no difference. Something else is wrong with this... when I get my new mac this fall... I think I am going to VM... I am about done with this app.
  9. John@Parallels


    I believe we need to investigate this even with developers, could you please create ticket in support and let me know ID, I will suggest some investigation steps?

Share This Page