Unable to allocate VM blah blah blah

Discussion in 'Parallels Desktop for Mac' started by athos, Jan 11, 2007.

  1. athos

    athos

    Messages:
    31
    This is still happening, even with the most recent RC (which scares me).

    MacPro, 6 GB of Ram, and it's bitching about not having enough memory.

    I'm tired of this error, can I have an explanation of WHY it happens?
     
  2. athos

    athos

    Messages:
    31
    What would it take to get support to comment on why this happens? This has happened for a while now.
     
  3. jsteinhu

    jsteinhu

    Messages:
    5

    You could try providing some actual information and/or waiting longer then 5 hours.
     
  4. STim

    STim Super Moderator

    Messages:
    942
    jstienhu is right, some more info is needed to start thinking of the reason.

    1. How long ago did this start? What was the first build where you experienced this?
    2. What were you last time doing with the VM before it happened?
    3. Are you the only Mac account that uses this VM?
    4. Does it happens all the time and with any of your VMs? Are you able to start successfully some time? If so, what are you doing for that to happen?

    The error basically means that either the VM cannot create/modify .mem file due to improper permissions or file system error, or Mac memory is too fragmented for VM to be able to allocate enough for initialization.

    Best regards,
    Tim
     
  5. athos

    athos

    Messages:
    31
    Good god, does EVERYONE have to be a smartass. I guarantee you would not talk to me like that standing in front of me.

    I have mentioned this error in multiple threads. It's quite simple. I install parallels. I go open a VM. It says I don't have enough space for virtual memory. I'm then stuck. Other people see it too (a friend of mine did the exact thing on the exact machine and got the exact errort).

    I have a MacPro with 6.5 GB of RAM and a billion hard drives. I have plenty of memory and disk space, so I have no idea what it means to not have enough for parallels.

    I could keep copy and pasting this from the other threads.
     
  6. athos

    athos

    Messages:
    31
    Thanks for the response.

    1. Started about 2 betas ago. I'd have to look through the old threads to see when I first mentioned it. I'm not alone, btw -- do a search on the error message.
    2. I have no idea -- probably doing outlook.
    3. I am the only account on this machine.
    4. It happens with any of the VMs until I reboot. Then I get to use it for a while. Then sometimes it will complain again. After every new refresh it gives the error again. BTW, if you need me to reboot after install, you should say so in the installer.

    I would find it hard to believe that out of 6.5 gigs of RAM, Parallels can't find enough to run in.

    Rick
     
  7. Alexey

    Alexey Parallels Developers

    Messages:
    14
    Could you say exact error message that you gave?

    Could you post me what "sudo dmesg" (or whole file /var/log/system.log) tell after the error occurence?

    How much free space on your HDD (where VM configuration is located) during error occurence?
     
  8. athos

    athos

    Messages:
    31
    Unable to allocate virtual machine memory!

    This error may occur mostly if there is no enough free disk space avaialbe on the physical disk to allocate virtual memory paging file. Try to clean up the physical disk (remove unecessary files). If it doesn't help, try to re-install Parallels Desktop.


    my disk has 88GB free, so I think we can all agree that's plenty.

    Absolutely nothing of substance in the system.log
     
  9. plunk25

    plunk25

    Messages:
    2
    Same error

    I got the same error after I accidently quit parallels. I rebooted my Macbook pro (2GB RAM, 16GB free space on hdd) and still got the same error.

    After beating my head for 10 minutes I lowered the amount of allocated RAM for my VM from 1024MB (1BG) to 512MB. Booted like a champ.

    I hope this helps.

    thatgirl
     

Share This Page