Unable to close applications in windows virtual machine

Discussion in 'Windows Virtual Machine' started by EmmanuelA3, Nov 27, 2023.

  1. EmmanuelA3

    EmmanuelA3 Bit poster

    Messages:
    2
    Over the past few days I've been unable to close any application I open in parallels. When I open a browser, I can't open new or close old tabs, it just hangs.

    I've reset parallels times and reinstalled and updated the tools twice but it's still not working. I'm on parallels for Intel Macs, and I've recently updated to the newest Mac OS.
     
  2. RichardD36

    RichardD36

    Messages:
    1
    I also have this exact issue. Performance is also very slow. Odd trackpad behavior.

    Details
    MacOS: MacOS Sonoma
    Apple Hardware: MacBook Pro 2019 - 15in INTEL I7
    Windows 10

    Steps I've tried:
    1. Ensure MacOS and Windows 10 are updated
    2. Reinstall Parallel Tools and Parallel Toolbox
    3. Reboot vm and MacBook
    4. Set optimization resource limit to "no limit"
    5. Set parallels hypervisor to "Apple"

    This seems to be related to MacOS Sonoma IMHO.

    I cannot close tabs, windows, etc. When trying to close a tab in chrome/windows explorer, it gets VERY slow but if I click off it becomes responsive. When IDLE and having a few tabs open, 78% of CPU is used (Windows Antimalware Executable is high usage). I can bring up task Manager and end tasks. When clicking and moving the mouse (using MacBook trackpad) it will randomly right-click or drag).

    Might be an issue with Windows and mouse pass through?

    But also issues with performance that wasn't an issue before.

    I have a 12in MacBook from 2017 (i7 model) that runs parallels 19 just fine with another Windows 10 vm. This MacBook runs MacOS Ventura 13.6.1.
     
  3. EmmanuelA3

    EmmanuelA3 Bit poster

    Messages:
    2
    I agree it's related to the new MacOS. I have the exact same Mac and I've recently updated to macOS Sonoma. I can also close apps using the task manager! Uhhh this is so frustrating! I've been in contact with support but they're taking ages to reply.
     
  4. EricS41

    EricS41

    Messages:
    1
    Same issue on Sanoma 14.3.1. Sometimes the X in the top right works, most of the time it doesn't.

    Right clicking the taskbar (when I'm finally able) has been the most effective way for me to close apps. I really hope this gets fixed.
     
  5. Pramesh Boodadoo

    Pramesh Boodadoo Staff Member

    Messages:
    552
    Hello,
    As a possible solution, kindly follow the below steps:
    1. Select Virtual Machine, open the Virtual Machine's Configuration ( https://kb.parallels.com/117287 ).
    2. Click on the "Hardware" Tab and select "Mouse and Keyboard".
    3. For the options "Mouse" select "Optimize for games" from its drop-down options.
    4. Turn on your virtual machine and verify if the closing issue has been resolved.
    If the issue still persists, for us to further investigate this issue, kindly reproduce the issue and collect a technical report (right-click Parallels icon in Dock > Help > Send technical data > check "Attach screenshots..." > press Send Report) and provide us with the report's 9-digit ID in reply to this post.
    Thank you.
     

Share This Page