Unable to Compress / Compact virtual hard disk

Discussion in 'Installation and Configuration of Parallels Desktop' started by fiopa, Jun 27, 2007.

  1. mstevinson

    mstevinson Bit poster

    Disk Compression Mayhem

    After spending 36 hours waiting for the “merge†to complete (read CelticTech’s post and my previous posts), the process hung up. Rather than attempting to start the process over, I trashed the VM and restored a back-up copy.

    Somehow, either due to the Parallels Image Tool or something with the hang, 3-4GB of hard drive space is no longer available. It’s “full†and I can’t figure out where the files are that could be causing this.

    So, this morning, I thought I would take a shot at upgrading Parallels to version 4.0, migrating the VM from the back-up and see if I could get the Compressor to work.

    Alas, it does not. When I run the Parallels Compressor I receive the following message:

    “The virtual hard disk cannot be compressed. Make sure the virtual machine does not have snapshots, the virtual hard disk is not a plain disk, nor a Boot Camp partition, and that you are not working in safe mode.â€

    I have not tried CelticTech’s process for compressing the disk. Although, I’ve tried every conceivable combination to get this to run and have spend hours reading forums and troubleshooting guides, I’ve hit a wall.

    How does one get the disk compressor to work in Parallels 4.0.3810? I have limited hard disk space and am running out of patience.
  2. DaTa

    DaTa Hunter

    Hello, mstevinson,

    If the issue still remains, please, create a support ticket in our Help Desk system, so our engineers are able to contact and help you directly, as this problem seems to be too complicated to discuss it here:


    Please, let us know the ticket number.
  3. Jay Chow

    Jay Chow Bit poster

    CelticTech's post on Oct 6, 2007, 07:58 AM works for me, except that he seemed to forget deleting the newly created snapshot after step 15. So, after step 15:

    16. Next boot the VM:
    It is normal for this to take a little longer than usual.

    16.1 Virtual Machine > Manage Snapshots.Select the snapshot and click Delete. When all snapshots have been deleted, click Close.

    17. Finally Run Disc Compressor:

  4. helikyler

    helikyler Bit poster

    I tried this process. I am running Parallels version 5.0.9310. Previously, I had no snapshots and Undo Disks was disabled.
    1. I created a snapshot in the process of following CelticTech's procedure.
    2. When I attempted to compress the Virtual Machine, the current size and 'after compress' size were identical.
    3. I allowed the compression process to continue anyway, rebooted the VM and everything, still the same size though.
    3. I went to Manage Snapshots and deleted the one I just created.
    4. I then tried to compress again but the same equivalent disk size was still the same.

    How do I get rid of unnecessary free space inside my virtual machine!?!?

    Thanks in advance for your help.

  5. Kai HolgerM

    Kai HolgerM Bit poster

    3 years and the problem is not resolved

    Incredible. I am afraid that they will tell me the solution: UPGRADE TO V6.0.
  6. PlectoR

    PlectoR Junior Member

    No way. I upgraded to Parallels 6, and started experiencing this problem.
    My VM expanded to 116GB, while the actual data are less than 50GB, and trying to compress it, after some minutes, produces the usual error: "the hard disk cannot be compressed because is has snapshots or it is corrupted..." but none of these situations is the case.
    Please help!!!
  7. dMac786

    dMac786 Member

    This is a great solution, but I found pci_clonemaxx to be slow and failure prone. I suggest Partition Wizard Home Edition, which is free and can be downloaded from download.com.
  8. ExeloM

    ExeloM Banned

    I just don't understand why it won't work on compression. I deleted all snapshots in mine.[​IMG]
  9. petermil

    petermil Bit poster

    Using Parallels Transporter


    I have Build 6.0.12106 (Revision 692267; September 7, 2011), I'm not sure whether that's earlier or later than 5160, but when I checked for updates it said I was already up to date (I have Snow Leopard and am not planning to upgrade to Lion in the foreseeable future). I had exactly the same problem. My virtual machine size bloated up to 43Gb and wouldn't compress despite deleting all snapshots and disabling whatever you have to disable.

    I found one more solution which is to use Parallels Transporter.

    Open your current virtual machine and start Parallels Transporter.

    Then create a new machine without a disc or file, using the same OS as your other one (mine is Windows XP). Configure it with a hard disc of appropriate size (as small as possible). I set mine to 20Gb. I might try again with a smaller one if it looks as though it will accommodate all my applications and associated clutter, because of course I store documents and data on the Mac drive.

    Then choose File .. Import, check 'Parallels Transporter is open on the source PC" and away you go.

    The only problem I found was it didn't import my desktop icons correctly.


  10. hahsjar

    hahsjar Bit poster

    Parallels Team -

    I'm using Parallels v7 (circa 2012) and this problem seems to still exist. However the solution above doesn't seem to work anymore since the Parallels Images Tool is not incuded in the most recent version.

    I've been digging for over a week for a solution with no luck.

    Since this is the first relevant discussion that results from a search in this forum, can someone post a link to the best Current solution to this problem?

    I will also attempt to start a new thread with more detail about my problem specifics, but want to avoid adding yet another loose thread until absolutely necessary.

  11. petermil

    petermil Bit poster

    image tool?

    What do mean by Image Tool? I was talking about Parallels Transporter which is a Windows app that automatically installed when I set up my virtual machine.
  12. gllvwl

    gllvwl Bit poster

    The suggestion quoted below saved the day for me--hard to believe this problem has persisted since 2007! (In my case, unable to compress the virtual hard drive which was ballooning in size; was getting the error message saying I need to delete snapshots, although there were no snapshots.)

    HOWEVER, Clone Maxx is appallingly slow. I aborted that process after it gave me an estimate of >3000 hours to clone a 10GB disk. I instead used Partition Wizard Home Edition, suggested later on in this thread, which is a great find--free, easy to use, took about 20 minutes to copy the drive.

  13. ZachariasB

    ZachariasB Bit poster

    Problem still exists. I have a 52GB virtual disk, although Windows is only using about 20GB. It keeps growing.

    There are NO SNAPSHOTS.

    The undo disk feature is DISABLED.

    Parallels still fails to compress the disk using either the General > Reclaim... or the Hard Disk > Compress... option.

Share This Page