Unable to connect to Hard Disk 1

Discussion in 'Installation and Configuration' started by plazmyd, Nov 11, 2008.

  1. Chris Rogers

    Chris Rogers Bit Poster

    Messages:
    1
    Possible Solution for Boot Campers

    Ran into this issue on a friends 1.83MBP.

    Everyting was working fine yesterday, go to launch Parallels today... can't connect to HD. Try the toggling of the configuration. No dice.

    Rebooting into Boot Camp... works fine.

    Only changes from yesterday to today... few windows updates, printer installation, joining to an AD domain.

    ... and Parallels Tools

    Rebooted to Boot Camp. Uninstalled Parallels tools. Rebooted to Mac, Opened Parallels... login screen.

    Try it let me know

    -Chris-
     
  2. edwardd20

    edwardd20 Bit Poster

    Messages:
    30
    All,

    I ended up on this thread because I too was having the same problem/message and it seemed like it just showed up for no reason. Turns out I had upgraded to a beta version of MacFuse. I reverted back to the base version and all went back to normal. Great products, both of them. Just don't get ahead too far. http://macntfs-3g.blogspot.com/

    Ed
     
  3. budz

    budz

    Messages:
    1
    Why why why

    Why are there so many people with the same issue without a proper answer or update by parallels? I purchased this update from P3 and have been having issues almost straight away, same issues as you guys... Waste of money, I'd rather have my $$$ back. I've tried changing IDE location, read/write and noda...

    Grrrrrr
     
  4. LouisC

    LouisC

    Messages:
    1
    I found two possible workarounds for the "Unable to connect to Hard Disk 1" problem:

    1. Dismount BootCamp partition with Disk Tools. Then Parallels will be able to find it.
    2. Use the .hdd drive definition file found in "/Users/<USER>/Documents/Parallels/My Boot Camp.pvm/Hitachi HTS############.hdd" as the file to be used in the "Image file" option, instead of the BootCamp partition, in the Hard Disk 1 section of configuration. They are both the same, and Parallels will detect it as a Plain Disk.
     
  5. hapachris

    hapachris

    Messages:
    1
    I found this thread because I was having exactly the same problem.
    I read edwardd20 post and thought that in my cause, the problem might also have something to do with NTFS, because
    I installed NTFS-3G yesterday. Disabling NTFS-3G works as a work-around for this problem.

    But still no word from Parallels ...
     
  6. Jon Bruck

    Jon Bruck

    Messages:
    3
    Add me to this list too....

    Not a Boot Camp partition. I'm getting the error within 3 or 4 minutes after booting XP:

    Unable to access Hard Disk 1
    An error occurred when accessing the hard disk. Error ID: Input/output error.

    ...then, XP is unresponsive.

    Still no response (for those who have been waiting for months)?

    Report ID 420354
     
  7. PedroG

    PedroG

    Messages:
    1
    Excelent Michael

    Excelent Michael and Thank you guys for solving this problem...
     
  8. dontdo_that

    dontdo_that

    Messages:
    15
    Didn't see this posted above so I thought I'd mention it.


    Here is a potential fix for users experiencing issues with Parallels 4.0, using a Virtual Machine to virtualize a Windows installation on a bootcamp partition receiving the "Cannot connect to Hard Disk 1" error AND ARE USING MacFUSE+ NTFS-3G.

    You don't need to completely DISABLE NTFS-3G, simply go to NTFS-3G settings:
    System Preferences --> (Other) select NTFS-3G --> Click the lock bottom left and enter your administrator password to make changes --> Under "Mounted NTFS-3G volumes:" select the volume that is your boot camp parttion. Mine was still called "Untitled" --> Check the box next to "Disable NTFS-3G for this volume". Relock, and you're good to go.

    This will effectively enable NTFS-3G to work ONLY for NTFS drives that you need it for, while not interfering with your bootcamp partition by providing Parallels exclusivity in accessing it. In my case scenario, I am able to write to my NTFS external hard disk still, and my now bootcamp VM is unaffected by NTFS-3G, whereas I was getting an error at start-up that NTFS-3G could not connect to my bootcamp volume.

    Good luck...hope this helps!
     
  9. RodneyW

    RodneyW

    Messages:
    12
    I originally reported my problem to Parallels Support on August 2 (ticket #753056). I had not found the forum at that time, and the only solution to the problem I had found was to delete the VM associated with Boot Camp and recreate it every time I rebooted my Mac. The response from Parallels support was:

    This sounds a bit fishy to me; I would think that it would be in the best interest of both Apple and Parallels to resolve this issue quickly.

    I must add, however, that I had a similar problem with VMware Fusion before I switched to Parallels. In that case, however, when I started VMware after a reboot I'd see two "Boot Camp" VMs, and one would boot and the other wouldn't. VMware was automatically finding my Boot Camp partition and creating a VM from it, but the previous one wouldn't work because it wasn't pointing to the partition anymore. Maybe there really is a "failure to communicate" between Apple and the VM product vendors...
     
  10. CliveD

    CliveD

    Messages:
    1
    After 26 years I have switched to Apple and I am very pleased with the results, however there are still some applications I must run either natively or in virtualisation. I have a June 2009 MacBook Pro with a Bootcamp Partition running Parallels 4. The partition is running Windows 7, this is the MSDN release and is therefore the full release version (RTM)
    I use the word running advisedly as I am having terrible problems with the "Unable to connect to Hard Disk 1"error. I have raised this as a ticket with Parallels Support (775587).
    I think I have narrowed the problem down to issues with MacFuse. With MacFuse running I get the error message, if on the other hand I remove MacFuse I get Parallels connectivity. These seems bizarre; all the more so when MacFuse is now part of the Parallels 4 application.
    I have followed this thread and have tried out all of the suggestions, hence pinning down the problem to issues with MacFuse, I hope! I have even removed the partition and rebuilt it from scratch but to no avail. This problem is persistent and can be repeated.
    Has anyone got any other suggestions I could try, any help will be greatly appreciated.
     
  11. Ynot

    Ynot Parallels Developers

    Messages:
    387
    Can you create problem report after the message about "Unable to connect" appears and post its number here? To create report do the following: click Help in PD menu -> Report a problem. The Parallels will show you report number, post it here, please.
     
  12. Munkey

    Munkey

    Messages:
    1
    Same issue

    I am unable to connect to my hard drive following an upgrade and instillation of parallels tools. I am not running a boot camp partition but a mounted virtual machine.

    It opens in safe mode without the error but not in normal mode? This would suggest to me that it might be a networking issue but I am not technical enough to pin it down.

    I have submitted an error report 681843, please help.
     
  13. Andrew Rye

    Andrew Rye

    Messages:
    2
    I too was having this problem after adding a new VM with a new install of Windows 7 in bootcamp. I tried every trick in this thread, and only one worked...

    I went to Disk Utility and "unmounted" the Bootcamp partition. I then launched Parallels and it worked.
     
  14. Ynot

    Ynot Parallels Developers

    Messages:
    387
    Munkey
    I saw an input/output error in the log file, that seems that your HDD has some errors. In your mac system log there is an entry:
    Oct 26 07:30:36 Mac-daddy kernel[0]: disk0s2: 0xe0030005 (UNDEFINED).

    I searched in google and found some articles about this issue:
    http://mcculls.blogspot.com/2007/06/dreaded-disk0s2-0xe0030005-undefined.html
    http://macosx.com/forums/mac-os-x-system-mac-software/277126-disk0s2-oxe0030005-undefined.html
    http://answers.yahoo.com/question/index?qid=20091010195356AAvmUBe
     
  15. Adrian Boeing

    Adrian Boeing

    Messages:
    2
    I just upgraded from Leopard to Snow Leopard with a clean install. I installed Parallels and have gotten the dreaded "Unable to connect Hard Disk 1.
    A file or device required for the operation of Hard Disk 1 does not exist or is used by another process, or you have no permission to access it. The virtual machine will continue running, but the device will be disconnected."

    I have tried creating a new VM, CHMOD and changing IDE slots have not done the job for me.
    None of the steps described in http://kb.parallels.com/en/5734 worked.

    What is the official solution to this? It seems like there is no answer to this problem?

    If there is an official solution, perhaps a sticky on this thread might help others in future. This thread is getting so long it is hard to find all the suggested solutions, many of which work for some people and not for others.. (none work for me)
     
  16. Adrian Boeing

    Adrian Boeing

    Messages:
    2
    This worked for me too!! Thanks! (I also had to create a new bootcamp VM after un-mounting, but no big deal)
     
  17. Finer

    Finer

    Messages:
    1
    Having the same issue after upgrading to PD4. VM will freeze and become unresponsive after a short period of time so I have to restart each time. Also, I was able to see the C drive in my 'Places' in Finder last night when I installed but now it no longer appears when I start up the VM (it did every time in PD3). I've sent a report, I.D. 691735.

    Please help!
     
  18. JNieves

    JNieves Bit Poster

    Messages:
    10
    Let's add to the confusion...

    I have ben having the "Unable to connect to Hard Disk 1" problem for a long time and had been working around it by changing "Hard Disk 1" to a file then back to a Boot Camp partition in Parallels 4 (see post#20 and #58 in this thread). I upgraded to Parallels 5 hoping the bug had been fixed (silly me, I know) only to find that it is still there, but worse; now I can't just switch to an image file and click through the warnings, it makes me choose (I don't have one) and when I click Cancel I get an error "Unable to configure the Boot Camp partition, make sure you have read/write privileges on the drive"...
    I had recently uninstalled NTFS-3g from my system and was able to get my old workaround to be successful again by reinstalling NTFS-3g... once I jump through the hoops and get Parallels 5 to boot it works fine.
    So, at least in my case, NTFS-3g does not seem to be the problem (and by extension, neither is MacFuse).
    I've read in another thread that OS X assigns drive ID's based on the order in that the drives start up, therefore "confusing" Parallels regarding which drive is the Boot Camp drive in multi-drive systems; nevertheless the Boot Camp partition is detected quite easily when creating a new VM which begs the question: why can't Parallels detect the Boot Camp partition the same way on VM startup as it does on initial creation of the VM?
     
  19. RodneyW

    RodneyW

    Messages:
    12
    I've found a workaround for Parallels 5 that works for me. As always, YMMV.

    With the VM stopped (after I get the error), I go to Configure -> Hardware -> Hard Disk 1. I see a variation of:

    Source: ST3500630AS P

    If I open the drop-down list, I also see under "Boot Camp Disks":

    Source: ST3500630AS P
    Source: ST3500630AS P (disl 0)

    Or, it might show up as:

    Source: ST3500630AS P (disl 0)
    Source: ST3500630AS P (disl 1)

    One of these is selected, and the other isn't. If I select the one that isn't selected, then all is well until the next reboot. HTH.

    It does appear that Parallels is detecting the Boot Camp partition, but it can't figure out that the drive name changed, so it shows a non-existent partition in addition to the correct one. If it is any consolation, VMware Fusion has the same problem, or it did at the time I switched to Parallels a few months ago.
     
  20. dwestlake

    dwestlake

    Messages:
    1
    I've tried searching for a solution to getting my VM running in this discussion board but (not being all that technically oriented) have not found anything that works. Please, someone, help me understand how my VM can work fine one day then the next day I am totally locked out of it with this "Unable to connect to Hard Disk 1" error? I've been locked out of my accounting software and have lost 3 days of work! I even tried upgrading to version 5...still no luck.

    I NEED to get back into my VM ASAP!

    In case anyone from Parallels cares to respond to this, my ticket number is 816306.
     

Share This Page