Unable to connect to Parallels Service (upgrade from 12 to 13)

Discussion in 'Installation and Configuration' started by KevinB4, Aug 22, 2017.

  1. KevinB4

    KevinB4 Bit Poster

    Upgraded from 12 to 13. No errors during installation. Started Parallels and get, not one, but TWO message pop-ups that state:

    Unable to connect to Parallels Serivce
    Make sure that the prl_disp_service process is active and it is not blocked by Firewall. For details, please refer to http://www.parallels.com/products/desktop/supportinfo/pdfm13_en_US_249

    NO firewall service running.
    Followed the stop/start launchctl as per the referenced link in the error dialog.
    Still doesn't work.
    Removed the installation (dragged to trash, emptied trash) and rebooted.
    Tried installation again.
    Same exact response.
    Rebooted again.
    Sent problem report.
  2. weza

    weza Bit Poster

    same here....
  3. KevinB4

    KevinB4 Bit Poster

    @weza don't know if this will help you, note I'm running 10.12.6 ... I tried just dragging the application to the trash, but after talking with Parallels this needs to be done to git rid of it fully...
    Note...I also added the following to my situation, as being SU'd when performing the relative ~/Library/ references are to the root user, not my default user. So before rebooting and reinstalling, I performed the rm -rfd ~/Library/... commands as my normal user account:
    When I rebooted and reinstalled I was prompting for Licensing agreements, etc. that I was not prompted for before.
  4. MichaelA11

    MichaelA11 Bit Poster

    Having the same problem. Going back to v12 works fine. But 13 has this error.

    Edit: I followed KevinB4's recommendation (do sudo su first) and I fixed my problem. Only caveat is that control center will forget all your VMs. So you have to re-add them to Control Center (as a move, not a copy).
    Last edited: Aug 25, 2017

Share This Page