Unable to Dump Memory of Parallels VM Using prlctl

Discussion in 'General Questions' started by Dresec, Jul 6, 2023.

  1. Dresec

    Dresec Bit poster


    I'm trying to create a memory dump of a running Parallels virtual machine on my Mac M1 using the prlctl command. I'm using the following command:

    sudo prlctl internal {UUID} dbgdump --path ~/Desktop//dumps/
    I replace {UUID} with the actual UUID of my virtual machine. When I run this command, I get the following error:
    Failed to get VM config: The virtual machine could not be found. The virtual machine is not registered in the virtual machine directory on your Mac.

    I've confirmed that the UUID is correct by running prlctl list -a, which shows my virtual machine as running. The virtual machine is stored in a non-default location (/Users/user/Parallels/), but I've tried specifying the path to the .pvs file directly in the prlctl command, like so:

    sudo prlctl internal /Users/user/Parallels/macOS\ 13.macvm/config.pvs dbgdump --path ~/Desktop/dumps
    However, I get the same error. I've also tried registering the virtual machine in Parallels by opening the .pvs file through the File > Open menu, but this hasn't resolved the issue.

    I'm not sure what else to try at this point. Any help would be greatly appreciated.

Share This Page