Unable to find network devices with Siemens Tia portal

Discussion in 'Windows Virtual Machine' started by Pjotrv, Aug 17, 2021.

  1. Pjotrv

    Pjotrv Bit poster

    Hi all,
    Since Mac OS Big Sur we experience some issues with connecting to new Siemens PLC devices over ethernet.
    Siemens uses an ISO protocol once a netwerk device has no internet connection, but for some reason this is blocked somewhere between Mac OS and Parallels.
    When I connect my USB network adapter directly to Parallels there seems no issue.
    When it is connected through my Mac and share network adapter there are no devices found.

    There is no problem once we have the same setup with Mac OS Catalina.
    Currently using Parallels 17, but we also had these issues on Parallels 16.

    Can anyone help me?
    Thank you,
    MichaelJ40 likes this.
  2. MixailK

    MixailK Bit poster

    I have the same problem! Anyone tell me a solution?
  3. StephenV4

    StephenV4 Bit poster

    Hi Pjotr,
    I hope that all is well, I am experiencing the same issues with TIA Portal and RSLinx inside my VM when using WIFI. I can ping the devices with no issues but the PLC programming software will not connect over Wifi (OK via LAN).
    Would it please be possible to let me know what Wifi adapter you used to overcome this problem? I have just purchased and installed a Wifi adapter and I cannot get it to see any SSIDs on the wireless network, so maybe it is not compatible.

    Many Thanks,

  4. GampaA@P

    GampaA@P Pro

  5. MichaelJ40

    MichaelJ40 Bit poster

    I have the same problem. The solution that GampaA@Parallels posted did not work for me.
    TobiasB4 likes this.
  6. TobiasB4

    TobiasB4 Bit poster

    Same here ....
  7. DanielE28

    DanielE28 Bit poster

    Same Problem here. I've tried Win10 too but not working. I hope parallels can fix this so I can use my new M1 machine productive.

    Maybe a USB-Network card directly connected to the vm will help but haven't tried that.

    WinCC Unified Simulation also does nit work because of de missing IIS in Win11 ARM.
  8. MixailK

    MixailK Bit poster

    This issue is not a Parallels Desktop bug. This is a Mac OS Big Sur and Monterey problem. Because in VMWare Fusion, the search for a controller via Profinet also does not work.
    I checked with Wireshark, and found out that Mac OS mangles the PLC response when searching through the Accessible Device. Mac OS Big Sur gets the correct answer from the PLC, and Parallels Desktop gets a garbled answer from the PLC.
    I had to go back to Mac OS Catalina. I installed Parallels Desktop 17 and the problem went away. The TIA Portal works great.
  9. MixailK

    MixailK Bit poster

    Yes, I tested this method under Mac OS Big Sur. He works. But I don't really like it, since the settings of network adapters are constantly getting lost.
  10. DanielE28

    DanielE28 Bit poster

    Okay, for me it is not working.
    I can not find any devices? Which network card do you use? What are your settings?

    Does Mac OS Big Sur evan block those connections?
  11. AlexandreH

    AlexandreH Bit poster

    Hi. I've tried for a while to find a solution and i finally got connection between my MacBook Pro 14´(M1 pro) in windows 11 with parallels and my Siemens Logo!.
    1. Connect your Logo! via ethernet adapter (I´m using a UGREEN ethernet to usb c adapter)
    2. Change the Network configuration in parallels to Bridged Network
    3. Restart Parallels
    4. Change ipv4 configurantion inside windows 11 (in parallels) to manual and inserte the above:
    ip adress: (any number available excetp the one being use by the Logo!)
    subnet mask:
    5. Turn off ipv6 in windows configurations.
    6. Head to Siemnes Logo! Confort and select: transfer >> pc to Logo! >> ethernet

    It worked for me i dont realy know how
    tempImageV5zG7v.png tempImageNqjniT.png
  12. YangZ5

    YangZ5 Bit poster

    Are you currently running Tia Portal V17? I am using MacBook Pro M2 14', I managed to install the Tia Portal V17 without any problem, but when I open/create a project and click 'project view' Tia portal just crashes for some reason. Have you had same issues by any chance?

Share This Page