unable to install SQL Server 2019 (Express or Standard)

Discussion in 'Parallels Desktop for Mac Feature Suggestions' started by SaikatD1, Jan 11, 2022.

  1. SaikatD1

    SaikatD1 Bit Poster

    Messages:
    2
    MacBook Pro 16" / 1TB SSD / Apple M1 Max Chip / 64GB RAM / 2021 Model
    - Total Number of Cores = 10 (8 performance and 2 efficiency)
    - System Firmware Version = 7429.61.2
    - OS Loader Version = 7429.61.2
    - macOS Monterey 12.1 (updated as of 10 January 2022)
    - Parallels Ver 17
    - Windows 11 Pro (downloaded the ARM based not x86, which is the right version for my Macbook Pro M1)

    Help Required...........
     
  2. AndrewC38

    AndrewC38 Bit Poster

    Messages:
    5
    You can't do it, and Parellels will not help. They don't care because it's a Microsoft issue, not a Parallels issue. I don't agree, but whatever. I have tried everything I have read on these forums. I tried returning my 1TB MBP M1 Pro and getting a 512GB one instead. Nope, didn't work. I've tried installing Windows 10, half a dozen times. Even that doesn't work unless you use a specific build, which does work. But even getting Windows 10 to install, I still could not install SQL Server 2019. I tried it without the TPM chip, I tried it with the TPM chip. There are a few lucky people that seem to have gotten SQL Server 2019 to install, but I'm not sure I believe it. Even if they were able to get to eventually install, I doubt it will be stable. There are tons of developers that want to use Parallels on their macs to do development, which can't happen, for the most part because SQL Server won't install. Save yourself some time and frustration and just forget about it until Parallels does something about it.They made Visual Studio run better, so I suppose there is some hope.
     

Share This Page