Unable to log in Remotely

Discussion in 'Parallels Remote Application Server' started by airfrog, Feb 7, 2011.

  1. airfrog

    airfrog Guest

    I have a 2X ApplicationServer set up to use SSL for Secure Client Gateway. I have a laptop with the 2x Client installed which can connect and access published applications and desktops fine when on the network.

    I have set our broadband router to forward anything on port 443 to the ApplicationServer. When I am outside of our network I can connect to the ApplicationServer and it shows me the list of published applications. However, when I click on one of the published applications, I get the error:

    [516] - The Client could not access the remote application.
    The machine might be too busy to accept new connections or network problems are preventing your connection.
    Please try connecting again later.

    If I change the connection mode to Direct SSL Mode, I can still see the published applications, but get the following error when I click on any of them:

    [260] - The specified remote computer could not be found.
    Verify that you have typed the correct computer name or IP address, and then try connecting again.

    The 2X logs do not suggest there has been any sort of error. When I open the client and it connects initially there is an entry in the log saying "Failed to get MAC address", but the entry after that says "Logon user 'user@domain' successfully". When I click on a published app to try and open it the log says "Client connection from address "xxx.xxx.xxx.xxx":port is tunneled to localhost (". When I log on to from within the network (where everything works fine) I get all of the same messages (minus the MAC address one). There are no extra "successful authentication" messages.

    The Application Log on the laptop shows two 1001 Event IDs (Windows Error Reporting):

    Fault bucket , type 0
    Event Name: PCA2
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: TSClient.exe
    P2: 8.1.941.0
    P3: TSClient Application
    P4: 2X ApplicationServer
    P5: 2X Software Ltd.
    P6: 200
    P7: -1

    I did a fresh installation of the 2X client on a separate Windows 7 laptop (that had not previous had the client installed) and encountered the exact same issues when connecting remotely: the client opens and displays the list of published apps, clicking on a published app produces the 516 error message. the 2X server logs show that the client connected successfully, the Windows Application Log on the laptop shows the TSCLIENT.EXE has reported an error.

    I don't think it's a client configuration issue, because the same client can connect OK when inside the network. I don't think it's an authentication issue, because I can log in and see the list of published applications (plus I tried putting in an incorrect password and got a "logon failure" error). I don't think it's a problem with the port forwarding on the router as I can log in and see the apps, I just can't open them. It appears the client connects, logs in and then TSCLIENT.EXE crashes.

    Does anyone have any suggestions as to what the issue might be?
  2. davidsaliba

    davidsaliba Guest

    Your client is version 8.1.941.0 from your notes what version is you server ?

    Are there any crash dumps ?

    Check the folder:
    %APPDATA%\2XDumps\ (eg C:\Documents and Settings\user\Application Data\2XDumps)for any crash dumps (files *.dmp)

    On windows 7 you might need to enable dumps attachment might help with that.

    If you get a crash kindly open a ticket with support include your findings, eventlog and crash dump.
    Include an explanation of the environment and also the type of NAT or firewalls you have (~since the issue occurs out of your network there might be something breaking the protocols in the process)

    Hope this helps.
  3. racgarcia

    racgarcia Guest

    We are seeing the exact same issue...did you ever find a solution to the problem??
  4. kimballwj

    kimballwj Guest

    I had the same problem (error 260 connection failure, despite getting to the published items folders OK) when using the latest (v10.5.1323) 64 bit client on Windows 8 (64 bit). Rolling back to the same 32 bit client (vv10.5.1323) fixed it for me. BTW, the 64 bit client has previously been fine for me on Windows 7 (64 bit).

Share This Page