Unable to play games on Parallels 15 with new MacBook Pro 16"

Discussion in 'Windows Guest OS Discussion' started by ThomasR26, Mar 21, 2020.

  1. ThomasR26

    ThomasR26 Bit Poster

    Messages:
    3
    I am using the latest version of Parallels 15 and I would like to game on Windows 10 using my Bootcamp image via Parallels. Lately, however, games refuse to start.

    When I try to play Forza Horizon 4, I get an error message saying that my Graphics card doesn't support DX12 although when running dxdiag within Parallels there are no problems detected and it says "DirextX Version: DirectX 12".

    When starting Age of Empires II: Definitive Edition, I get an error message stating that the game recommends at least 2GB of dedicated VRAM and that my computer doesn't meet that requirement. Again, when checking dxdiag, 8GB is listed as VRAM as I set the graphics memory for Parallels to "Auto (Recommended)" and have allocated 16GB of regular virtual memory (my Mac has a total of 32 RAM).

    I already tried installing Parallels Toolbox for Windows and I tried reinstalling the toolbox for Mac, both to no avail...

    I am very disappointed because I bought Parallels 15 exactly to be able to casually play a game without rebooting. Could someone please suggest how I get the Parallels graphics card/driver properly recognized by Windows in the vm?
     

    Attached Files:

  2. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    8,670
    Hi, when you say Parallels Toolbox, did you mean Parallels Tools?
    If not, please try to reinstall Parallels Tools
    Please also reproduce the issue and collect the tech report right after that and post the report's ID here.
     
  3. ThomasR26

    ThomasR26 Bit Poster

    Messages:
    3
    Hi, thank you for replying.

    I indeed mean Parallels Tools, I mixed up the names. I did what you suggested and reinstalled Parallels Tools (I tried both from Mac and inside Windows) but to no avail. I still cannot play games through Parallels.

    I then sent technical details to Parallels. The report ID is 335946563.

    Thank you in advance for your assistance.
     
  4. CasB

    CasB Bit Poster

    Messages:
    1
    Has a solution for this problem already been found? I think I am suffering from the same problem
     
  5. ThomasR26

    ThomasR26 Bit Poster

    Messages:
    3
    the Parallels support team replied to my support ticket stating that Parallels 15 does not support DirectX 12. However, my issues are not only related to games that require DirectX 12, such as Forza Horizon 4.
    I also cannot play Shadow of War, Ori and the Blind Forest, Sea of Thieves, and Age of Empires II: Definitive Edition, all of which only require DirectX 11, which is supposed to be supported by the latest version of Parallels.
    So far, no solution has been offered....
     
    Last edited by a moderator: Apr 1, 2020
  6. GertS1

    GertS1 Bit Poster

    Messages:
    1
    Age of Empires III Definitive Edition freezes on startup under PD 16: "Wrong DirectX installation"
    With PD 15 it works on my iMac (2017).
     

Share This Page