Unable to Record Audio using Record Screen

Discussion in 'Parallels Toolbox for Mac' started by Shiwan, Feb 12, 2019.

  1. Shiwan

    Shiwan Bit Poster

    Messages:
    6
    Hi

    I am using Parallel Toolbox for Mac. I am unable to record audit from Computer using Record Screen.
    I checked my laptop audio system and it is working fine. I could hear the audio when I am not recording the screen.
    When I trigger Record Screen, the audio automatically mutes.
    I also checked my Privacy settings and Parallel ToolBox had been checked to access audio.
    I am using macOS Mojave V110.14 if this info helps.

    I had sent a technical report - ID 298461829.

    Anyone, who can help? I need to record my lectures before they expire. :(
    Thank you in advance!
     
  2. KebhaK@Parallels

    KebhaK@Parallels Parallels Support

    Messages:
    122
    Please uninstall and reinstall Parallels Toolbox then check the screen recording issue.
     
  3. sergk

    sergk Parallels Developers

    Messages:
    195
    Hi Shiwan,

    You are planning to record your lectures that are being played in browser, I suppose? Do you need to record other sound except for lectures, from microphone e.g.?

    If you need only sound from lectures then you can change 'Record audio from' setting in Record Screen preferences (open Toolbox --> hover Record Screen with mouse --> press on 'Preferences' cogwheel near the tool icon). You have 'Same As System' audio source as I see from your technical report. It should be the microphone that is currently connected to your Mac.

    I suggest you to try other option named 'Computer'. This option allows you to record exactly the same audio that computer produces, without microphone-like distortions.

    Try it to record some audio from 'iTunes', for example, to make sure that it works for you correctly. Also it is good idea to check that recording of long period of time is correct too because your lectures could be quite long.
     
  4. Shiwan

    Shiwan Bit Poster

    Messages:
    6
    Hi

    I had tried to uninstall and install - still does not work.

    Sorry I might had changed to "Same as System" audio source when I tried to troubleshoot. I was using the "Computer" option and that is what I usually use. The recording works find without using the Toolbox. The moment I trigger Record Screen with "Computer" selected as option for audit. It gets muted.
     
  5. sergk

    sergk Parallels Developers

    Messages:
    195
    Are you using bluetooth headphones with microphone while facing the problem?
     
  6. Shiwan

    Shiwan Bit Poster

    Messages:
    6
    I am not. I am just using the audio from the laptop speakers.
     
  7. sergk

    sergk Parallels Developers

    Messages:
    195
    So you stopped hearing the sound from laptop speakers after starting the screen recording?

    What about other recording tools like Record Area/Window and Record Audio. Do you have same problems with them?

    Another option I can suggest - use microphone as an audio source for Record Screen tool then start watching the lecture with sound from speakers. In this case the sound will be little distorted but at least you can receive the result.
     
  8. Shiwan

    Shiwan Bit Poster

    Messages:
    6
    Yes, if I don't trigger Record Screen. The audio works fine. The moment I trigger Recrod Screen, the audio gets muted.

    I tried. Same for Record window.

    I know I can use Microphone as the audio input for recording, but I'm trying not to record any background noise too, thus I was using audio input as a Computer.
     
  9. sergk

    sergk Parallels Developers

    Messages:
    195
    btw,
    have you checked sound that was actually recorded by Screen Record tool? may be audio was recorded despite the playing via speaker is muted?
     
  10. Shiwan

    Shiwan Bit Poster

    Messages:
    6
    I did check - I recorded part of it anyway and then play the recorded video to check.
     
  11. sergk

    sergk Parallels Developers

    Messages:
    195
    And there is no sound in recorded video at all?
     
  12. Shiwan

    Shiwan Bit Poster

    Messages:
    6
    Yes. I can't find any solution now. I had been looking at my settings, but can't find anything amiss.
     
  13. BertW

    BertW Bit Poster

    Messages:
    4
    Hello,

    I'm having exact the same issue.
    Is there already a solution?

    Thanks
    Bert
     

Share This Page