Unable to start Parallels services after upgrading to 16.1.0.

Discussion in 'Installation and Configuration' started by PedroG5, Oct 22, 2020.

  1. PedroG5

    PedroG5 Bit Poster

    Messages:
    2
    V16.0.0 did not work, you fixed it in 16.0.1. Now, upgraded to 16.1.0 and it says Unable to start Parallels services.

    I already followed the command line suggestion, but no luck.

    Tried downgrading to 16.0.1 and 15, but those do not start after the 16.1.0 installation.
     
  2. MichaelF27

    MichaelF27 Bit Poster

    Messages:
    2
    Best Answer
    I have found a solution for this! It's based on this thread: https://github.com/pqrs-org/Karabiner-Elements/issues/2373#issuecomment-676121212
    There is a flag that's set incorrectly on a directory that Parallels tries to load its kernel extension into, so it fails. Condensing the explanation from above:
    • /private/var/db/KernelExtensionManagement should have permissions 0755 with the "restricted" flag set [visible via "ls -Ol"], and the com.apple.rootless attribute set to KernelExtensionManagement (you can check the value of the attribute with xattr -l)
    • /private/var/db/KernelExtensionManagement/Staging should be 0755 with the "restricted" flag set.
    When compared to another Mac running 10.14.6, I found that the "restricted" flag was not set against KernelExtensionManagement, which appears to have affected how SIP treats the directory.

    If that's the case for you, you should be able to repair it using chflags (e.g chflags restricted /Volumes/Macintosh\ HD/private/var/db/KernelExtensionManagement) from the terminal in recovery mode.

    Steps:

    1. Restart in Recovery Mode (hold down Cmd-R until you see the Apple Logo)
    2. If you have FileVault enabled on your hard drive, run Disk Utility, choose the main hard drive (which will be dimmed), choose "Mount", and enter your password to mount and unencrypt the hard drive. If not, just go to the next step.
    3. Quit Disk Utility, and run Terminal from the Tools menu
    4. run "chflags restricted /Volumes/Macintosh\ HD/private/var/db/KernelExtensionManagement" (with "Macintosh\ HD" being replaced by the name of your hard drive. If it has spaces in in, putting quotes around the whole pathname should work:
      • chflags restricted "/Volumes/My Long Hard Drive Name/private/var/db/KernelExtensionManagement"
    5. Restart the Mac. All should be good.
     
    PedroG5, IvayloP and Maria@Parallels like this.
  3. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    6,969
    Hello, could you please reproduce the issue with 16.1.0. and collect the tech report right after that.
    Looking forward to your reply and the report's ID
     
  4. Gregory2

    Gregory2 Bit Poster

    Messages:
    1
    It happened with me too. For the first time ever, I got a send-us-a-report-and-this-is-not-a-support-request thing.. The report number is. 352730748
    Maria, your link directions do not apply. "Unable to start Parallels services" means we don't ever get to the virtual machine window.

    This is getting old. :mad:
    In the several months I've had Parallels, I have at least monthly gone through your rigamarole spending hours redoing the OS each time to get it back (because nothing else in your sequence did it).:(
     
  5. MichaelF27

    MichaelF27 Bit Poster

    Messages:
    2
    Best Answer
    I have found a solution for this! It's based on this thread: https://github.com/pqrs-org/Karabiner-Elements/issues/2373#issuecomment-676121212
    There is a flag that's set incorrectly on a directory that Parallels tries to load its kernel extension into, so it fails. Condensing the explanation from above:
    • /private/var/db/KernelExtensionManagement should have permissions 0755 with the "restricted" flag set [visible via "ls -Ol"], and the com.apple.rootless attribute set to KernelExtensionManagement (you can check the value of the attribute with xattr -l)
    • /private/var/db/KernelExtensionManagement/Staging should be 0755 with the "restricted" flag set.
    When compared to another Mac running 10.14.6, I found that the "restricted" flag was not set against KernelExtensionManagement, which appears to have affected how SIP treats the directory.

    If that's the case for you, you should be able to repair it using chflags (e.g chflags restricted /Volumes/Macintosh\ HD/private/var/db/KernelExtensionManagement) from the terminal in recovery mode.

    Steps:

    1. Restart in Recovery Mode (hold down Cmd-R until you see the Apple Logo)
    2. If you have FileVault enabled on your hard drive, run Disk Utility, choose the main hard drive (which will be dimmed), choose "Mount", and enter your password to mount and unencrypt the hard drive. If not, just go to the next step.
    3. Quit Disk Utility, and run Terminal from the Tools menu
    4. run "chflags restricted /Volumes/Macintosh\ HD/private/var/db/KernelExtensionManagement" (with "Macintosh\ HD" being replaced by the name of your hard drive. If it has spaces in in, putting quotes around the whole pathname should work:
      • chflags restricted "/Volumes/My Long Hard Drive Name/private/var/db/KernelExtensionManagement"
    5. Restart the Mac. All should be good.
     
    PedroG5, IvayloP and Maria@Parallels like this.
  6. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    6,969
    Hello guys,
    did you check this KB article?
    Please let us know how does it work for you
     
  7. MichaelF27

    MichaelF27 Bit Poster

    Messages:
    2
    Yes, I did. When I updated to 16.0, none of it worked for me except reinstalling the OS. But yesterday when going from 16.0 to 16.1, none of that article worked, including an OS reinstall. However, the procedure I just posted above did work - I think it is worth trying before an OS reinstall for most people.
     
  8. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    6,969
    Hello, did you try the workaround from @MichaelF27 ?
    Also we would like to inform you that we've escalated this case to the Parallels Engineering Team for the further investigation.
    Once we get any updates we will contact you.
     
  9. ChrisJ13

    ChrisJ13 Bit Poster

    Messages:
    5
    I upgraded to 16.1.0 and now get the "unable to start service" message. This happened to me on a previous update. I am beyond furious, this is such an incredible waste of my time. I don't pay you a subscription so that you can bork my machine and screw up my work schedule every time you announce an upgrade. I have a well specified iMac, late 2014, running Mojave. I tried the chkflags workaround and it made no difference. Now I have to go through the whole rigmarole of uninstalling and reinstalling Parallels, then when that doesn't work reinstalling macOS - I mean who puts out upgrades that mean you have to reinstall your operating system??????? And all I had to do to get some work done today was ignore the update nag - never again

     
  10. ZacharyM

    ZacharyM Bit Poster

    Messages:
    2
    Well since i updated to Version 16.1.0 (48950), my mac now grey screens and then restarts continuously.
     
  11. ChrisJ13

    ChrisJ13 Bit Poster

    Messages:
    5
    As per last time, the only thing that worked was reinstalling macOS. I won't bother with any of the other suggested steps next time I upgrade Parallels, I'll just do it last thing at night and go straight to the nuclear solution.

     
  12. DanielB40

    DanielB40

    Messages:
    1
    I ran into this issue yesterday, same result with being unable to fix it even after downgrading. Followed the workaround marked as best answer, and that fixed it! I'd recommend Parallels Support should update the KB to add that particular workaround bit in here as this seems to be a common issue at least with Mojave.
     
    Maria@Parallels likes this.
  13. Maria@Parallels

    Maria@Parallels Parallels Team

    Messages:
    6,969
    Thanks a lot for sharing your feedback with us.
    We're working on the KB improvement.
     
  14. PedroG5

    PedroG5 Bit Poster

    Messages:
    2
    Hello.
    Same issue happened today when I upgraded to 16.1.1-49141. The official KB article does not help. But, solution posted by MichaelF27 worked!

    Suggestion for Parallels: add this to the KB article: chflags restricted /Volumes/HDD name/private/var/db/KernelExtensionManagement

    Last time I was forced to reinstall the host OS to use Parallels (never tried the "chflags..."). now it is working without OS reinstallation.
     

Share This Page