Unofficial fix for Linux Guest OS Parallels Tools with Xorg 1.4 version

Discussion in 'Linux Guest OS Discussion' started by Egurt, May 13, 2008.

  1. Egurt

    Egurt Parallels Team

    Messages:
    24
    Hi All,
    We created unofficial Parallels Workstation 2.2 builds with special fix for Linux Guest OS Parallels Tools.
    If you get Installation for xorg 1.4 not found error message during Tools installation inside the Guest OS, please download special test build.
    The links are:
    http://download.parallels.com/stuff/Parallels-2.2.2232-lin.tgz
    http://download.parallels.com/stuff/Parallels-2.2.2232-lin.i386.rpm
    http://download.parallels.com/stuff/Parallels-2.2.2232-lin.deb
    http://download.parallels.com/stuff/Parallels-Wst-2.2.2232-Win.exe

    Please note, that PW 2.2 2232 is not released. This build has major implementation, but the build may also contain unknown bugs. We will release new OFFICIAL version of PW 2.2 only after full investigation.
     
  2. rm53

    rm53

    Messages:
    31
    that sounds nice, but we are in the Mac forum here (Parallels Desktop for Mac), a quite different product for a different platform...
     
  3. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    150
    True, we're on a different platform, but I'm wondering if perhaps what Egurt is suggesting is that we install ONLY the Parallel Tools (which, of course would be Linux tools) from this build into the Linux virtual machines we've already created. Is that right Egurt, and are there any special installation instructions?
     
  4. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    150
    It Works

    I just decided to be brave and try this on my own. Yes indeed, by using the tools from Workstation 2.2, the tools installation problem is solved for the Desktop version. Just navigate to the Tools folder within the Data folder of this Workstation 2.2 build and mount it. Then install as you would with the version of Tools that was included in the Desktop version.

    So far it's working flawlessly for me. Thanks very much!
     
  5. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    150
    First problem found

    I'm not sure if this is a problem with Parallels Tools or Ubuntu 8, but I cannot get Ubuntu 8 to recognize the screen resolution I assigned to the virtual machine (1440x900). Any ideas here?
     
  6. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    150
    First problem fix

    Figured out how to fix the resolution error. This works ONLY if you've installed the Parallels Workstation Tools as described in above posts.

    In terminal:

    cd /etc/X11

    Then sudo nano xorg.conf.

    Under the section #"Parallels Screen" scroll down to SubSection and then "Display." Then under "Modes," delete the entry for 800x600 BUT BE SURE NOT TO DELETE THE QUOTATION MARKS AROUND THIS ENTRY - (for some reason you cannot replace them as they appear in this file.) Replace 800x600 with whatever resolution you prefer (in my case, 1440x900.) Then save the xorg.conf file and reboot the virtual machine. After you reboot, you should be able to select the resolution you wish and then be able to use Full Screen mode.
     
  7. melody

    melody

    Messages:
    2
    Unfortunately, installing these tools does not work with me under Fedora Core 7 (Sulphur). I get the following error when attempting to start X:

    (EE) module ABI major version (2) doesn't match the server's version (4)
    (EE) Failed to load module "prlvideo" (module requirement mismatch, 0)
    (EE) No drivers available

    If anyone has a solution, I'd love to hear it.

    Mel
     
  8. intulor

    intulor

    Messages:
    2
    Jim, I have successfully(I think) installed Parallels Tools after reading your instructions. I'm running the latest Ubuntu distribution, and this is my first install of linux in a virtual machine. When I run Windows via Parallels, I get a Parallels Tools initialization message when booting up each time, and I notice I have a new program group for it as well in the start menu. I was expecting to see something similar with Ubuntu (an initialization message and new programs installed), but I have not. Are there any steps you may have overlooked because you thought they were simple or intuitive? If not, and I have done everything correctly, then I guess I'll just have to wait till something more official shows up that supports the latest Ubuntu distro.
     
  9. Egurt

    Egurt Parallels Team

    Messages:
    24
    This is only "test" unofficial build. Please use it only for new Linux Guest OSes with Xorg 1.4
    We will provide you with Parallels Desktop for Mac build with this fix soon.
     
  10. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    150
    I am by no means a Linux maven, but my experience is that in the Linux builds, the Tools don't load in the same way as in Windows. You won't see the tools loading as you do when booting Windows. Once they're in, they're in, and there isn't a menu to select any of the tools. Any options are configured in the xorg.conf file. You can confirm this by looking at the xorg.conf file..if the tools are loaded, the file will make references to Parallels drivers.

    It sounds to me as if you've got them loaded.
     
  11. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    150
    Is there a trick with these tools to get the Apple Mighty Mouse options to work? Editing the xorg.conf file does not seem to make a difference (at least when using options found online for previous versions of Ubuntu)
     
  12. eban

    eban

    Messages:
    2
    I'm made an assumption here and downloaded the parallels-2.2.2232-lin.tgz. I've un-archived it. And this is where it gets tricky for me: I've found the "Tools" directory... should I mount the directory or one of the ISO's in it? I'm just not sure what I should be mounting or running. It would be wonderful if one of you could help me out.

    Cheers,

    eban

    PS: Burned the VMTOOLS-Linux.iso, mounted it, ran the parallels-tools.run... wa-la it works... W00T! Edited the xorg.conf file... it's all good
     
    Last edited: May 16, 2008
  13. jgadbaw

    jgadbaw Bit Poster

    Messages:
    9
    mouse click

    eban -- Good work. One qlitch remains with the mouse on my setup. All the mouse controls - click, select,scroll etc - from within say a terminal or gedit program. But the mouse click/select won't work on menus or network selecting. Any ideas?

    Jim
     
  14. jgadbaw

    jgadbaw Bit Poster

    Messages:
    9
    eban - in my xorg.conf file I got it to work by editing-
    Section "InputDevice"
     
  15. jgadbaw

    jgadbaw Bit Poster

    Messages:
    9
    Sorry -
    eban I got it working by editing the xorg.conf file.
    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    EndSection

    Now the mouse left button selection button works. Still working on the right mouse button. Getting closer.
     
  16. eban

    eban

    Messages:
    2
    Excellent, but I'm using a MacBook with a touch-pad. I'll try your edits. However, I'm dubious as to whether they will work for me....

    -eban
     
  17. cwestpha

    cwestpha

    Messages:
    4
    Works well. Doesnt like dynamic scaling and the mouse is a bit odd with a mightymouse. Need to tweek the screen resolution, the xorg.conf, and settle for a few odities. For example when you shut down the guest the VM doesnt detect the fact the system is halted, forcing you to stop or reset the VM manualy.
    Though I do have to admit I am finding the right click on the mighty mouse being the same as copy/paste in windows and terminals quite appealing.

    EDIT: Ok it HATES changing the display. Switching resolutions causes the VM to lose track of where the mouse is.
    For clariification of what has been said before I made a few changes in xorg.conf and set the resolution to "1680x1050" so now that works better.
    This is helpful when doing to remove 800x600 thing under xorg.conf (like Jim said). So instead of the line reading:
    Modes ""
    it should read:
    Modes "[your max resolution]"

    If you set it like the first example it just makes a huge window without any reason to the size. If you normally have the ubuntu VM set to full screen use the screen's max resolution and Xorg will never spit out a resolution bigger then you can handle. If you use it in a window boot to your windows VM. Set the parallels window to what ever size you like and look under display properties. It will give you the exact screen resolution the virtual machine window is using (if you have parallels tools installed under windows). Use that in place of [your max resolution].
    If you do the above then Xorg will make your login splash screen and all other screens no larger then that. Its now just a simple matter of logging into your account and using the drop down dialog under screen resolutions (its under user settings) from 800x600 with the higest option being your max resolution. Every option is now something your monitor can theoretically support!
     
    Last edited: May 17, 2008
  18. jimcoyle

    jimcoyle Kilo Poster

    Messages:
    150
    Were any of you able to get mouse scrolling going? Still not happening here no matter what I try. Thanks.
     
  19. rattus32

    rattus32

    Messages:
    7
    Display reset loop

    Hmm - I downloaded and installed the "unofficial fix", edited the xorg.conf file to set resolution to 1440x900, and verified that we now support fullscreen on the MBP, the mouse pointer is now "unstuck", etc. I'm running Kubuntu 8.04, xorg 1.4.

    However, when I log in, the normal KDE4.0 splash appears, then the screen distorts to a stretched "striped" grayscale for a bit, and then returns to the nornamal color fullscreen login prompt. Same response every time.

    Weird. Any ideas?

    Thanks,

    Mike
     
  20. John@Parallels

    John@Parallels

    Messages:
    6,450
    Were you able to login to KDE4, when no Parallels Tools was installed?
     

Share This Page