Update Failed?

Discussion in 'Windows Guest OS Discussion' started by MrLynn, May 12, 2009.

  1. MrLynn

    MrLynn Bit Poster

    Messages:
    45
    Received an update message in the background. I clicked 'Later', but the danged thing kept appearing, so I quit out of Parallels and ran the installer. It was fine up to the restart message, saying the software was "successfully installed." But then when I clicked Restart, I got a message saying that it was "Not installed correctly."

    So I had to quit out of the installer. I then restarted my MBP (10.5.6), and ran my XP VM under Parallels. It told me that Parallels Tools needed to be updated, but when I tried to do this, I got a message saying "Unable to download update."

    The XP VM seems to run all right, but the "Parallels Tools are outdated." message persists at the bottom of the screen. I still can't download the update. If I check for updates under Help, it tells me I have the latest version (About says 'Build 4.0.3844'--I think the original update was for a later version, but can't remember).

    So what do I do about this?

    /Mr Lynn
     
  2. Yeolegood

    Yeolegood

    Messages:
    36
    Hello,

    In case Parallels Tools fail to install properly, please try to reinstall Parallels Tools as described in this knowledge base article:

    http://kb.parallels.com/en/4945
     
  3. MrLynn

    MrLynn Bit Poster

    Messages:
    45
    I don't understand the KB article. First it tells me to uninstall Parallels Tools, then to uninstall Parallels itself? As I responded in the feedback box,

    When I see click on the Parallels Tools icon BELOW the System Tray (not IN it), it says 'Update Parallels Tools." When I try to do this, I get an error: "Unable to download the installation package."

    The article then tells me to remove 'P'. Is this article telling me to remove Parallels ('P'?) from my Mac? Is this necessary? What a PITA!

    Can I re-run the update? If so, where is it? Don't see the downloaded file anywhere.

    I'm confused!

    /Mr Lynn
     
  4. MrLynn

    MrLynn Bit Poster

    Messages:
    45
    Two days have passed. No reply.

    Can you explain?


    /Mr Lynn
     
  5. JoeP

    JoeP

    Messages:
    2
    Please Provide Better Directions

    The KB sited regarding this problem is terse, ambiguous, and incomplete. Since the last Parallels automatic "upgrade" I have also been experiencing the "unable to download installation package" by the "Parallels tools installation agent". It seems pretty obvious that this is a bug in the latest "upgrade".
    Please provide accurate, complete, concise step-by-step directions for resolution of this problem.
    Thanks,
    joe
     
  6. MrLynn

    MrLynn Bit Poster

    Messages:
    45
    No response? Why?

    It's been almost a month.

    Please tell us how to resolve the continuing problem of being unable to download and install Parallels Tools.


    /Mr Lynn
     
  7. JoeP

    JoeP

    Messages:
    2
    Here is what I was instructed to do by Parallels support... and it worked for me:
    The only problem with the instructions is that the file you want is actually prl-tools-win.iso.
    So, you open up the .iso disk image on your mac, inside you'll find the setup file. copy that over to your Parallels Virtual Machine windows desktop and run it inside windows.
    Hope this helps (more than the silly KB article).
    joe
     
  8. MrLynn

    MrLynn Bit Poster

    Messages:
    45
    Many thanks, JoeP!!

    I just got back to this (been too busy to think about it, so just clicked through the Parallels Tools warning every time I started the VM). It's a simple fix.

    Now why in the world couldn't the Parallels people have written (and posted here) this simple procedure?

    You wonder how well they understand their own product. . .

    /Mr Lynn
     
  9. MrLynn

    MrLynn Bit Poster

    Messages:
    45
    Well it happened again!

    Opening the VM, got a message that an update was available (build 3846). So, closing my eyes as I prepared to jump off that cliff again, I said OK. The Installer proceeded apace, and at the end said "Successful," and told me to restart. I pressed the Restart button, and read: "Install Failed. Parallels Desktop 4 for Mac was not correctly installed." Clicking the Show Error button got nothing, so I clicked Quit.

    That enabled the Restart, and the Parallels VM booted up all right. But of course, then it tells me that Parallels Tools was not installed correctly. Same problem as before!

    Fortunately, Mail is still able to find Joe P's post above, so I follow his instructions, and we're back in business.

    But (excuse me for shouting), WHAT IS IT WITH THIS COMPANY? CAN'T THEY BUILD A COMPETENT INSTALLER?

    Grrrr. . . . Time for Fusion yet?

    /Mr Lynn
     
    Last edited: Sep 2, 2009
  10. MrLynn

    MrLynn Bit Poster

    Messages:
    45
    Yet AGAIN!

    Today, Build 3848. Exact same problem!

    You would think after all this time they would build a fix into the installer.

    Would someone from Parallels care to comment?


    /Mr Lynn
     
  11. Juan ManuelR

    Juan ManuelR

    Messages:
    7
    Perfect thanks much better solution as the rest commented here
     
  12. renato_nyc

    renato_nyc

    Messages:
    3
    simpler method

    Guys,

    I had the same problem and it keeps re-appearing every once in a while. A simpler solution that fixes the problem for me is to directly open the tools iso (Macintosh HD-> Library -> Parallels-> Tools-> prl-win-tools.iso) via "Devices -> CD/DVD1 -> Connect Image ...". This starts the parallels tools updater automatically. So you don't need to extract setup.exe from the iso first and copy it to your windows desktop.

    I agree with the rest of the comments here: This problem has been around since I can remember. How difficult is to fix this installer? Why can't it simply disconnect the current CD image, load the tools iso and after the update restore the old setting?

    And, yes, the lack of a proper response by Parallels in this forum and the poor KB article are a shame too.

    Renato
     
  13. Stuart McLeod

    Stuart McLeod

    Messages:
    1
    Renato

    Your solution worked for me thanks. Is this some sort of permissions problem??

    Stu
     
  14. renato_nyc

    renato_nyc

    Messages:
    3
    Good to hear it worked for you. I don't think it's a permission issue. I think it's just an installer problem.
     

Share This Page