Upgraded to Ubuntu 13.10 - mouse not working, launcher & toolbar missing

Discussion in 'Linux Guest OS Discussion' started by FazlurR, Oct 18, 2013.

  1. FazlurR

    FazlurR

    Messages:
    10
    Hi all, I need help with my Ubuntu setup within Parallels for Mac.

    My knowledge is very minimal on parallels and Ubuntu, so forgive me if I am asking something too basic.

    I previously installed Ubuntu 13.04 on my Mac (OSX 10.8.5) via Parallels 9. It worked well.

    Last night I upgraded to Ubuntu 13.10. And now Ubuntu stopped working. I managed to get to the login screen and login... but there after everything ceases to work. see screen shot.

    Parallels Picture.png

    • I get a "Could not apply the stored configuration for monitors" error message.
    • The mouse doesn't move (although I can see the arrow), the launcher and toolbar are missing.
    • Clicking the command button doesn't bring up the unity dash and I cannot access Terminal.
    • I tried to reinstall Parallels Tools, but nothing happens. I cannot uninstall it either.

    I searched the forums and other sites. they seem to tell me to remove ~/.config/monitors.xml

    But I have no way of doing so since I cannot access terminal in Ubuntu 13.10 VM.

    Hope to find some answers.
     
  2. Hovo_84

    Hovo_84

    Messages:
    2
    I have the same problem, please heeeeeelp.
     
  3. Hovo_84

    Hovo_84

    Messages:
    2
    I have deleted ~/.config/monitors.xml file but the problem not solved (((
     
  4. FazlurR

    FazlurR

    Messages:
    10
    anybody else having this problem?

    I have not been able to solve it. I really don't want to re-install everything all over again.
     
  5. FazlurR

    FazlurR

    Messages:
    10
    ok, since I am still no where near to getting Ubuntu 13.10 to work on Parallels - is there any way I can retrieve the files I had saved on the VM? note: I have not enabled sharing across the VM.
     
  6. Thomas Hartwig

    Thomas Hartwig Bit Poster

    Messages:
    24
    Hello,

    I have a working 13.10, so don't give up. Ubuntu dropped 2D support in their window manager for unity. So you probably will get problems after upgrading. I see two solutions:
    1. Try a different Window manager and check if this works. For instance you can install wmaker and try to use this because it does not use any 3D. You should be able to chose the window manager right in the login screen when you enter your password. (If you have autologin you should check my tips below to get out of the session).
    2. Try to reset your settings for compiz, probably by removing .compiz in your home directory.

    Tip, for all not knowing this: you should try to get to a text console by pressing CTRL-ALT-F2. Then you can control you Xorg. For instance you get back to the login screen with the command: "sudo killall Xorg" This will kill your current login session. An other command is: "sudo killall lightdm" or "sudo killall gdm". This will kill your login manager.

    Hope this helps as first steps
    Thomas
     
  7. Thomas Hartwig

    Thomas Hartwig Bit Poster

    Messages:
    24
    Just a short addition:

    xfce is all really worth a try as an alternative window manager, it produces much less cpu load compared to compiz
     
  8. FazlurR

    FazlurR

    Messages:
    10
    Hi Thomas

    thanks for the additional tips and the help here.

    I was just trying to choose the different window manager from the login screen... but since I don't have control of the mouse, I cannot seem to do anything different. will keep trying again...

    Parallels Picture 1.png


    fazz
     
    Last edited: Oct 20, 2013
  9. Thomas Hartwig

    Thomas Hartwig Bit Poster

    Messages:
    24
    Are you sure you did install the latest Parallels Tools?
    I use Parallels 9.0.23136. Mount the CDROM for yourself in the text console with following command: "sudo mount /dev/sr0 /mnt". Then go to /mnt and do "sudo ./install".
     
  10. FazlurR

    FazlurR

    Messages:
    10
    I use Parallels 9.0.23136 (revision 932290) too. I didn't install ubuntu using a CDROM, but through a downloaded iso file, so I am not sure how to follow your suggested command sequence.

    My problem is not having access to the mouse and to the keyboard controls in the ubuntu VM. this prevents me from running any linux commands.
     
  11. Thomas Hartwig

    Thomas Hartwig Bit Poster

    Messages:
    24
    Boot into text by appending "text" to the boot parameters in Grub and check the Parallels help what Parallel Tools are and how to provide them to the machine.
     
  12. LorenF

    LorenF

    Messages:
    10
    You can get to "CTRL-ALT-F2" without the mouse by command-tab then click on the window bar (not in the window) then select the devices menu then keyboard then "CTRL-ALT-F2" from the menu.
     
  13. FazlurR

    FazlurR

    Messages:
    10
    Thanks LorenF! this is helpful. I am now able to get to the text mode. But from here I need to be handheld, as I am very unfamiliar with ubuntu / linux commands and s

    I tried the above command to mount the CDROM for Parallels in text mode. However, this was not successful as I got "mount: no medium found on /dev/sr0"...

    I also did the following: clicked the Parallels menu "Virtual Machine --> Update Parallels Tools" and then did the sudo mount command... but no luck. I still get the "mount: no medium found on /dev/sr0" error.
     
  14. ZBoater

    ZBoater

    Messages:
    36
    Try clicking on the little CD rom icon on the bottom edge of the Parallels screen. You can manually map the CD drive to the pr-tools.iso image. Try the commands after you've done that.
     
  15. Daniel Bauwens

    Daniel Bauwens

    Messages:
    2
    I myself don't use parallels(I just have ubuntu on a PC) but I think I might know some things to help you.

    First, type either Ctr+Alt+F1 or Ctrl+Alt+F2.
    Then type (without the quotation marks) "unity" and then press Ctrl+c
    Then type (without the quotation marks) "export DISPLAY=:0" and then type "gnome-terminal" and press Ctrl+Alt+F7

    You should now have a Terminal in your normal screen.
    Then, type in your Terminal "dconf reset -f /org/compiz/" then "setsid unity" and finally "unity --reset-icons" (again with no quotation marks).

    After that's done, you restart it with "sudo reboot".

    Although I'm not sure how parallels works, ubuntu is ubuntu, so this should help at least a bit.

    Hope this helps.

    Daniel
     
  16. FazlurR

    FazlurR

    Messages:
    10
    thanks everybody. I have managed to recover my Ubuntu 13.10 VM (somewhat). Thanks to _Thomas_, LorenF, ZBoater and others...

    here is what I did:

    Description of the problem is per my first post above. Essentially, I was unable to interact (cannot use mouse or keyboard) with Ubuntu 13.10 after login. What I also found was that the Parallels Tools was out of date and needed to be upgraded. But because I had no access to the mouse or keyboard I was unable to install it within the UI.

    To overcome the problem with the interaction, I had to release the mouse from the VM and at the Parallels Desktop menu, selected "Devices -> Keyboard -> Control+Alt+F2

    This brought me to the ubuntu text screen. which operates like Terminal. the next task was to install / upgrade Parallels Tools. To do this I did the following:
    1- at the Parallels Desktop menu, select "Devices -> CD/DVD 1 -> Connect Image" ... a finder window appears...

    2- you now need to look for the Parallels Tools *.iso image file (which would act like a CD ROM). Use the finder window that appears (as above) to locate the image file in the following file / directory locations: "Application -> Parallels Desktop (right to show package contents if sub files don't appear) -> Contents -> Resources -> Tools -> prl-tools-lin.iso (which is the parallels tools iso file for linux VMs) ... this action will mount the Parallels Tools

    3- go back to the Ubuntu text screen interface within Parallels Desktop and do the following:
    sudo mount /dev/sr0 /media/cdrom
    ... this does some mounting which I do not fully understand since I had mounted it earlier.. :?

    4- change directory to /media/cdrom as follows:
    cd /media/cdrom

    5- install parallels tools from the /media/cdrom directory as follows:
    sudo ./install

    6- go through the Parallels Tools installation steps - as easy as just clicking next until the installation is complete and then reboot when requested.

    7- this then allows me to now access Ubuntu 13.10 VM via Parallels Desktop 9. After login, I get to the Ubuntu desktop which was almost as it was in 13.04 before the upgrade.

    the only thing i still get is the "Could not apply the stored configuration for monitors" error message. I used Terminal and did "rm ~/.config/monitors.xml" which was ok, but caused the screen resolution to be too high (and the icons, font became too tiny)... so I went to settings to adjust the display settings back to a normal size and then reboot. and I still get the same error message "Could not apply the stored configuration for monitors".

    this error message is not a major problem, but very annoying and makes me wonder whether I have an optimal installation of Ubuntu 13.10...

    any ideas now?
     
  17. Daniel Bauwens

    Daniel Bauwens

    Messages:
    2
    EDIT:

    Alright, could you remove .config/monitors.xml again, then reboot, log back in, then do a quick "sudo apt-get update" in a terminal and reboot again?

    If the resolution stays bad, try "xrandr --addmode VGA1 1366x768" (change the sizes to your specific screen size).

    Hope that helps.
     
    Last edited: Oct 23, 2013
  18. FazlurR

    FazlurR

    Messages:
    10
    Thanks Daniel. I tried the first part of your suggestion, but I still got the "Could not apply the stored configuration for monitors" error message. Actually, the resolution is ok, as per the settings I had set in the displays settings. the only thing is the error window which keeps on appearing everytime i login. i can dismiss it, and everything is ok but it appears again the next time i login.

    I have not tried your second suggestion as I would not want to screw things up as I am not too confident of the right screen size...
     
  19. Nanook

    Nanook Bit Poster

    Messages:
    13
    I have the very same problem as FazlurR: 13.04 worked fine, upgraded to 13.10 and git the same monitor errors and the mouse is no longer working. So I followed his step-by-step guide (with some minor changes since the /dev/sr0 was mount to a different mount-point) and started the PTools reinstall. This resulted in some errors in the /var/log/parallels-tools-install.log. If memory serves me right (looong time ago) these are some c file compilation errors which then make it unable to MAKE the new binaries.Looks like it is complaining about some pointers and data types which I find pretty strange. As I said, everything worked fine until I upgraded…

    Parallels Desktop 8 on 2013 iMac with FusionDrive.

    Any help appreciated.

    Thanks,
    Nanook

    Here is the /var/log/parallels-tools-install.log excerpt:


    Parallels Tools 8.0.18608.898384 Installer started.
    2013-10-25T19:04:04+0200: execCmd: ./installer/pm.sh check_guest_tools 2>&1 [0]

    Fr 25. Okt 19:04:04 CEST 2013
    Start installation or upgrade of Guest Tools
    new version of parallels tools
    Installed Guest Tools were not found
    Perform installation into the /usr/lib/parallels-tools directory
    cat: /usr/lib/parallels-tools/kmods/../version: No such file or directory
    Start installation of prl_eth kernel module
    make: Entering directory `/usr/lib/parallels-tools/kmods'
    cd prl_eth/pvmnet && make
    make[1]: Entering directory `/usr/lib/parallels-tools/kmods/prl_eth/pvmnet'
    make -C /lib/modules/3.11.0-12-generic/build M=/usr/lib/parallels-tools/kmods/prl_eth/pvmnet
    make[2]: Entering directory `/usr/src/linux-headers-3.11.0-12-generic'
    LD /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/built-in.o
    CC [M] /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/pvmnet.o
    LD [M] /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/prl_eth.o
    Building modules, stage 2.
    MODPOST 1 modules
    CC /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/prl_eth.mod.o
    LD [M] /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/prl_eth.ko
    make[2]: Leaving directory `/usr/src/linux-headers-3.11.0-12-generic'
    make[1]: Leaving directory `/usr/lib/parallels-tools/kmods/prl_eth/pvmnet'
    cd prl_tg/Toolgate/Guest/Linux/prl_tg && make
    make[1]: Entering directory `/usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg'
    make -C /lib/modules/3.11.0-12-generic/build SUBDIRS=/usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg SRCROOT=/usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg modules
    make[2]: Entering directory `/usr/src/linux-headers-3.11.0-12-generic'
    CC [M] /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg.o
    /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg.c: In function ‘prl_tg_write’:
    /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg.c:796:9: error: implicit declaration of function ‘PDE’ [-Werror=implicit-function-declaration]
    struct tg_dev *dev = PDE(ino)->data;
    ^
    /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg.c:796:31: error: invalid type argument of ‘->’ (have ‘int’)
    struct tg_dev *dev = PDE(ino)->data;
    ^
    /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg.c: In function ‘prl_tg_init_one’:
    /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg.c:1303:2: error: implicit declaration of function ‘create_proc_entry’ [-Werror=implicit-function-declaration]
    p = create_proc_entry(proc_file, S_IWUGO, NULL);
    ^
    /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg.c:1303:4: warning: assignment makes pointer from integer without a cast [enabled by default]
    p = create_proc_entry(proc_file, S_IWUGO, NULL);
    ^
    /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg.c:1305:4: error: dereferencing pointer to incomplete type
    p->proc_fops = board_info[dev->board].fops;
    ^
    /usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg.c:1306:4: error: dereferencing pointer to incomplete type
    p->data = dev;
    ^
    cc1: some warnings being treated as errors
    make[3]: *** [/usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg/prltg.o] Error 1
    make[2]: *** [_module_/usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg] Error 2
    make[2]: Leaving directory `/usr/src/linux-headers-3.11.0-12-generic'
    make[1]: *** [prl_tg] Error 2
    make[1]: Leaving directory `/usr/lib/parallels-tools/kmods/prl_tg/Toolgate/Guest/Linux/prl_tg'
    make: *** [installme] Error 2
    make: Leaving directory `/usr/lib/parallels-tools/kmods'
    Error: could not build kernel modules
    Error: failed to install kernel modules
    2013-10-25T19:04:06+0200: execCmd: ./install --install [143]
    2013-10-25T19:04:06+0200: Error: An error occurred when installing Parallels Tools. Please go to /var/log/parallels-tools-install.log for more information.
    2013-10-25T19:04:08+0200: Exiting with code 1
     
    Last edited: Oct 25, 2013
  20. Thomas Hartwig

    Thomas Hartwig Bit Poster

    Messages:
    24
    Ubuntu 13.10 comes with kernel 3.10 and above which has some fundamental changes for instance in the proc system. As far as I see from your install log Parallels 8 might lack support for these versions. I really don't know if this will be supported in 8 ever. In general I really recommend to invest in the update to version 9. From all my experience it is running very good especially on Mavericks.
     

Share This Page