USB connection to radio fails

Discussion in 'Parallels Transporter' started by gino1307, Jul 26, 2007.

  1. gino1307

    gino1307 Bit poster

    I have two iCOM broadband radios that can be controlled by or exchange data with a Windows machine via a USB port. Each has its own individual Windows drivers for USB. One works with the Parallels VM and the other doesn't.

    iMac, OS X 10.4.10
    Parallels Desktop 3.0, build 4560
    Windows XP Pro, SP2

    The radio that fails is an iCOM IC-R1500 (which works fine on a non-VM setup). When I try to use the program, it puts up a message box saying "COM Port Error" and later a second one, "Communication failed. Cannot Access receiver". Otherwise it seems to run, but of course doesn't do anything useful.

    If anyone wants to look at the radio software - which includes the USB driver - it can be found here:

    This requires navigation to the software since the link always goes to the support root:
    Click Firmware Updates, agree to the license, click the Text "Communications Receiver", and finally click "IC-R1500 / IC-PCR1500 / IC-R2500 / IC-PCR2500" at the top of the right hand pane.

    This is a Zip file. If extracted, there is a subdirectory "Driver\WinVista". To install the Windows XP drivers run CP210xVCPInstaller.exe in that folder. There is no XP folder :)

    BTW, the driver does provide an uninstaller in Add/Remove programs :)

    If anyone has solved this, feel free to tell me how. I've looked around on both the iCOM and Parallels sites to no avail. There are some hints in the Parallels forums about USB to serial converters, but they don't seem to relate to what I have - unless that's what the radio has, hiding behind its USB port. That might be - the software, when it works, claims to be connecting to COMx, usually COM3.

    The other people talk about installing USB -> serial drivers in the host machine. If that's needed then I am probably out of luck, since there's nothing on the iCOM site, although the radio that works seems to talk about COM ports too... Oh yeah - I did try a Mac driver downloaded from SiLabs, the apparent provider of the Windows driver, but with no success.
  2. gatesl

    gatesl Bit poster

    I have reproduced the bug

    No workarounds yet, but I agree, this radio fails to work with Parallels.

    It seems to be related to the choice by Icom to use the Silicon Labs USB chip in the radio. It is unfortunate since TrunkPCR seems to work just fine. It has a very different featureset though...

  3. gino1307

    gino1307 Bit poster


    Well, I had an old unused Windows XP Home CD, so I made a BootCamp partition (all of 10 GB) which works OK. I think, though, I'll just use it with my somewhat elderly (well, 3 years, IIRC) laptop. Advantage: portable.

    The other iCom, an R20, works in Parallels - I guess it doesn't use the SiLabs chip :)

    Thanks, Lee, for letting me know,
  4. jbsolutios

    jbsolutios Junior Member

    I confirm that I have the same problem on the latest version of Parallels.

    Has anyone tried the new Vista drivers?

Share This Page