USB Dev / Suse 9.3

Discussion in 'Parallels Workstation for Windows and Linux' started by Kai.Teuber, May 9, 2006.

  1. Kai.Teuber

    Kai.Teuber

    Messages:
    1
    Hi,

    I'm running Parallels on a Suse 9.3 and Windows Xp Pro. as a guest system. I need a USB Fritz card within the Windows. When I start Parallels as root Win Xp finds the USB Device. With normal user rights the USB device isn't working.
    I've read the help about this problem, but I don't get what I have to do. Can someone please tell me how I can make the needed changes to the USB Devices ?

    Regards,
    Kai Teuber
     
    Last edited: May 10, 2006
  2. Nadine McSim

    Nadine McSim

    Messages:
    17
    To fix the issue please do the following:
    1. Create a group and include into it users who have to have access to USB devices.
    2. In the /etc/fstab file edit the string that mounts the usbfs. Devgid parameter should contain the identifier of the group created in the previous step.
    usbfs /proc/bus/usb usbfs devgid=<USB gid>,devmode=0664 0 0
    3. Open your /etc/init.d/boot.localfs, locate section with a comment "Mount local filesystems in '/etc/fstab/'", add line
    modprobe usbcore
    before the line `mount -av -t nonfs,noproc,nodevpts,nosmbfs -O no_netdev`.
    4. Restart your Linux primary OS.
     
  3. xsenon

    xsenon

    Messages:
    1
    Hi Nadine! :)

    I am using Ubuntu and tried to follow your guide.

    But i faced a problem. On my system there is no "/etc/init.d/boot.localfs". What can i do now??

    xsenon :)
     
  4. Negative

    Negative

    Messages:
    8
    xsenon, adding modprobe command in /etc/init.d/boot.localfs is not necessary
    you may add this command in any startup scripts according to your distro or even run 'modprobe usbcore' manually
     

Share This Page