USB device pass through

Discussion in 'Installation and Configuration' started by DanielF14, Jan 9, 2022.

  1. DanielF14

    DanielF14 Bit Poster

    Messages:
    2
    Hallo togehter,

    I have a MacBook Pro with M1 chip and I have Windows 11 ARM with Parallels on it. I have to program the radio receivers for the fire department, which is done via a USB to serial converter. The USB device is recognized by the MacBook and then also passed through to the Windows 11 machine. In the Windows 11 machine the device is also displayed but as unknown. A searcher with Windows updates does not bring up a driver. Directly on the manufacturer's site is a driver offered for Windows 7 - 11 but this does not work(https://ftdichip.com/drivers/vcp-drivers/) . The device is displayed in the device manager as FT232R USB UART.

    How can I get the device to work?

    Thanks to all who can help.
     
  2. DanielB63

    DanielB63 Bit Poster

    Messages:
    1
    I am also having the same issue. Has anyone worked out how to get these working?
     
  3. GampaA@Parallels

    GampaA@Parallels Staff Member

    Messages:
    439
    Hi, please try connecting the Virtual machine directly and check.
     
  4. DanielF14

    DanielF14 Bit Poster

    Messages:
    2
    So for me it is now working:

    Disable Secure Boot in Windows 11 ARM

    In Windows, hold down the SHIFT key while selecting Restart.
    Go to troubleshooting advanced options: UEFI Firmware Settings.

    Then in the BIOS turn off the secure boot option.
    Then in a cmd with admin rights type the following
    bcdedit.exe /set nointegritychecks on

    Then switch it on again:
    bcdedit.exe /set nointegritychecks off

    After this:
    You have to disable driver signature verification.
    https://www.howtogeek.com/167723/ho...8.1-so-that-you-can-install-unsigned-drivers/

    for me it was only the GIU way working not the cmd way.

    4. insert the adapter FT232R USB UART

    5. after detecting it with exclamation sign: update driver, have disc -> point to the downloaded extracted driver in ARM64\Release folder
    CDM v2.12.32.B3 for ARM64.zip
    There are 2 items of the drivers that needs to be installed, first the bridge, and after the serial to usb driver, both updated with inf from package from FTDI.

    6. After updating the bridge, launch regedit

    7. Go to

    Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\VID_0403&PID_6001\a410f66c\Device Parameters

    where VID_0403&PID_6001 you will find from Device HW ID from device properties

    8. Create a new string value named PortName

    9. Give it a value COM4 or any free value

    10. Take out the adapter and insert it again

    11. A new USBtoSerial device will appear with Excalamtion sign

    12. Reinstall its driver from the same package

    13. There you go, the FTDI based adapter is functioning perfectly under Windows 11 ARM64
     

    Attached Files:

  5. 4suites

    4suites

    Messages:
    1
    I got stuck at step 5. It says " Windows could not find drivers for your device" . Any suggestions?
    All the previous steps went perfect.
     
  6. Asish@Parallels

    Asish@Parallels Staff Member

    Messages:
    162
    Hello Guys, We have released the new build of the Parallels Desktop v17.1.3. Kindly upgrade to the latest build and check.
     
  7. RayM4

    RayM4 Bit Poster

    Messages:
    2
    I have the same issue as the start of this thread, with updated Parallels.
    My device is a Prolific brand 2303RA of a late variety and Mac is happy Mac Hardware USB, "USB-Serial Controller D" is what is identified and this is found by windows but reports error 28 device driver not found. No attempt to change this has worked.
    As for above steps 1-13 by DanielF14, you have got to be kidding me, above my pay grade, surely the route cause can be fixed by the main programmers for everyone without special workarounds?
     
  8. RayM4

    RayM4 Bit Poster

    Messages:
    2
    The basic problem is with the virtual drivers and it's up to Prolific to update drivers or get an FTDI chipset cable as they have the necessary virtual drivers.
     
  9. RobertW45

    RobertW45

    Messages:
    2
    You **MUST** extract the drivers to the C:\ in order to get them to be seen by device manager with the instructions above if you are using a Mac and trying to extract the drivers to the shared "Downloads" directory - they won't be seen. Once I got that to work, the rest was addressed above. Great directions.
     
  10. RobertW45

    RobertW45

    Messages:
    2
    See above.
     
  11. NeilT4

    NeilT4 Bit Poster

    Messages:
    2

    I've installed Parallels 18 trial and also trying to get a Serial-USB cable to work, had a GUC232A adaptor and just bought a DTECH DT-5119 FTDI and hoping to get it to work using the instructions above. Unfortunately, I've also become stuck at poiint 5. Message of "Windows could not find drivers for your device". I pointed to the driver zip you provided, but no success? Any ideas or suggestions would be really appreciated. Thanks in advance.
     
  12. RandyB7

    RandyB7

    Messages:
    1
    @DanielF14 are you trying to program something like Motorola XTS5000 (or similar) radios? I'm having the same problem - have you found a working solution ?
     

Share This Page