USB Devices Not Working in RC2

Discussion in 'Windows Guest OS Discussion' started by rmwilliams4, May 31, 2006.

  1. e7sharp9

    e7sharp9

    Messages:
    29
    Device: UM-1 USB MIDI interface
    MFR: Edirol
    OS: Windows XP SP2
    Symptom: XP reports problem installing Driver - "This device cannot start (Code 10)"
    Affects: Cannot use to connect to midi devices
    Changes : Problem has been consistent since first version supporting USB[/QUOTE]
     
  2. socket

    socket

    Messages:
    1
    Web Cam Not Working

    Device: QuickCam Communicate STX
    MFR: Logitech
    OS: Windows XP SP2
    Symptom: XP installs driver, but the end complains that the device cannot start (code 10)
    Affects: Can't use Yahoo Messenger or MSN under windows to video chat.
    Changes : Problem has been consistent since first version supporting USB
     
  3. dkelley

    dkelley

    Messages:
    5
    this might be naive from the point of view of the parallels developers, but it seems to me that much could be fixed, and at the very least many of these usb problems could be debugged more accurately if one major part of the equation was removed --- the conflict with osx trying to take control of the usb device and not allowing parallels to use the device as a result. If there could be a way to "turn off" usb access on the mac side for a particular usb device, and this could be controlled on a device-by-device basis within a popout control panel in the parallels main screen (config screen, not within the guest os), and if the list was saved automatically whenever a change was made (like if I told the list to give parallels control of my ipod then the next time I start parallels it takes control of my ipod if it's connected or when it's next connected), that would be really nice.

    This would solve many of the conflicts we're all experiencing right now, and I personally have managed to work around some of those conflicts on a device by device basis by disabling the usb device on the osx side when needed but this isn't consistent or easy at all (it's a pain in the butt actually). But it would allow more devices to work, it would allow us to say exactly which devices run under parallels or osx (since it can't run under both at the same time obviously), and it would give us the ability to send more useful bug reports to parallels about which devices honeslty don't work.

    As an example of how I'd do it, make a scrollable list of usb devices that are currently connected to your mac with a checkbox beside each saying "use in parallels". if it's unchecked it's useable in osx, if checked it'll be disabled in osx and useable in parallels' guest os. Due to the nature of usb devices being plug and play, this list will have to save itself with updates every time a new usb device is seen when parallels is running, and then when you next run parallels even if your ipod or whatever isn't connected it will still be in the list if it was used in the past with parallels and that way you if you have a device that you always (or almost always) use with parallels then it will remember that setting in the future when you plug it in again.

    This preference setting would only take control of osx while parallels is running, when parallels isn't running the particular guest os in question then osx will try to use all attached usb devices as usual.

    Of course this is just a suggestion of how parallels could do it, that's how I would do it if I was coding this, but it's a quick thought - no real research put into it, and I don't know if it's possible at all.

    Wouldn't it be nice though? :)

    Cheers,
    DKelley
     
    Last edited: Jun 1, 2006
  4. rbarbera

    rbarbera

    Messages:
    2
    well, I think that this is how the RC2 works now ;). If I right click over the USB icon in the lower bar of the window, I see a list of USB devices atached to the iMac and I can check and uncheck them. When I change the status, the guest OS inside the VM "see" the new attached device
     
  5. j_jstra

    j_jstra

    Messages:
    1
    iSight in-build MacBook Pro Intel

    Device: iSight in-build

    OS: Windows XP SP1
    Symptom: XP doesn't recognise the camera.
    Affects: Cannot use camera in skype

    I agree with previous posts. The problem isn't new, but no response from the staff.
     
  6. blshaw45

    blshaw45 Bit Poster

    Messages:
    33
    Garmin Quest, RAZR

    As posted by others, Garmin's Quest still does not work (with RC2), nor does my Motorola RAZR cell phone ("in use by another application").
     
  7. djmorris

    djmorris

    Messages:
    4
    I don't think they gonna solve this problem. Apple has to provide the drivers for letting the isight work under xp.
     
  8. cwoloszynski

    cwoloszynski

    Messages:
    3

    We have un-installed the Mac KeySpan USB-Serial adaptor and it still does not work under Parallels. Can we add this device to the list of USB devices that should be supported. The error mode for it is that characters are lost when the remote device sends lots of data. We are testing this under Windows XP and under Suse 9.3 Linux.

    We need this working to justify migrating our developer machine base to Parallels, since we need serial access to the embedded devices we develop for.

    Edit: This error was under RC1. We have not tried RC2 but since Parallels has not indicated if it was an issue, I don't intent to test it again until we get some indication that it has been addressed.
     
  9. cwoloszynski

    cwoloszynski

    Messages:
    3
    SanDisk ImageMate CF

    This USB-compact-flash device works fine under Mac OSX, but does not work under Suse 9.3 Linux or Windows XP when using RC1.

    Under Linux, either linux hangs or it says that it is not a valid block device. Under Windows, the entire (iMac) machine crashed.
     
  10. powell

    powell

    Messages:
    12
    Greetings, I do not have the Keyspan drivers installed on the OSX side, but I do have them installed in the VM WinXP. When I am in the VM, I plug in my Keyspan USA-19QW. XP chimes and says new hardware, then it fails and says the driver cannot talk to the device. This is in RC2.

    Using BootCamp and WinXP, the device works great, but I really hope to use a VM instead.
     
  11. William McHargue

    William McHargue

    Messages:
    4
    dkelley sumarized just what I would suggest. The procedure suggested by rbarbera seems to only work if the host OS has no hooks already into the device—it won't "detach" a device already attached to the host OS. We need a way to identify devices and completely remove them from the host's access.

    (Note to The Parallels Team: "I'm love'n it!")

    Bill.
     
  12. Menace

    Menace Bit Poster

    Messages:
    52
    Device: SCR335 Smart Card Reader
    MFR: SCM Microsystems
    OS: Windows XP Home SP2
    Symptom: USB device doesn`t get recognized although drivers are installed properly
    Affects: I still cannot use it in RC2 = I don`t buy Parallels until we have real USB support
     
  13. rimage

    rimage

    Messages:
    3
    USB 2 Port?

    I wonder if this is the answer to some of the problems. I apologize up front if this has been discussed I couldn't find it on the forum.
    If you look on page 101 of the current user guide it mentions. "The current version of Parallels Desktop emulates the 2-port USB controller 1.1. This means that up to two USB peripherals can be connected to a Virtual Machine simultaneously." Does this mean that if I have a mouse and the keyboard I've used my two ports? Also, what does, "Isochronous devices are not supported in the current version." mean?
    Thanks,
    Chris
     
  14. bishpatrik

    bishpatrik

    Messages:
    1
    Freecom DVB-T USB Stick

    RC2 now seems to work with all the devices I need to do my work, so the only device left that I have that I may want to plug in is my Freecom DVB-T USB Stick, that unfortunately doesn't seem to have Mac drivers.

    I'm running Windows 2000 SP4 as Client, Intel Dual Core Mac-Mini as Host.

    I'm guessing its too complicated a device to work, but it would be really useful, as I plug my Mac into the TV when I have to stay at Bed and Breakfasts when I work away from home, so that I have a DVD player, but it would be nice to use it as a digital TV as well.

    An extra minor issue is that when I restart the client system, I get the USB device is in use message, even though the only thing that was using it was the Windows client itself. This issue is solved, by unplugging and replugging in the device again after reboot, so I am not too bothered by this.
     
  15. Ozy

    Ozy Bit Poster

    Messages:
    25
    Device: Garmin Earthmate GPS LT-20
    MFR: Garmin
    OS: Windows XP SP2
    Symptom: Cannot map to guest OS. Parallels says device is in use by OSX

    Please dont make me run boot camp so i can run Delorme Street Atlas and Microsoft Streets and Trips while on business trips. I want to stay in OS-X!

    Thank you.
     
  16. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,507
    Could you use iSight in BootCamp? Does it have drivers for XP?
     
  17. anville

    anville

    Messages:
    17
    Andrew, you almost sound like you're baiting him, since you are fully aware that the XP driver for the USB iSight doesn't exist!

    However, if it DID exisit, would you expect it to work under Parallels? :)
     
  18. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    Messages:
    1,507
    We have other problems with iSight - we don't know how to say OS X not to use it - it is essential for using it in VM. I hope we can solve this eventually.

    But we can't make XP drivers for iSight for sure - it can be real stopper.

    PS: I don't fully aware it doesn't exist really. But if someone going to use it in XP - may be he somehow got the drivers...
     
    Last edited: Jun 2, 2006
  19. anville

    anville

    Messages:
    17
    Sorry, Andrew, I misread your post :eek: But I what really do want to know is if you think that using any USB webcams (with the correct XP drivers) will be possible with this release? Or will not be until 3.0? Thanks! :)
     
  20. API

    API

    Messages:
    1
    Rainbow SuperPro and Gibbs CAM

    I use the Rainbow SuperPro Dongle with Gibbs CAM. It did not work in RC1. It has worked for 2 days in RC2.
     

Share This Page