USB Devices Not Working in RC2

Discussion in 'Windows Virtual Machine' started by rmwilliams4, May 31, 2006.

  1. Andrew @ Parallels

    Andrew @ Parallels Parallels Team

    Cameras are usually isochronous USB devices. We have limited support for isochronous devices in this version - so some of them may work, some not. We are working on full isochronous devices support.
  2. imjeffp

    imjeffp Bit poster

    Device: Celestron NexImage (Philips ToUCam) and Meade LPI
    OS: Win XP SP2
    Description: Unable to install driver, "Device cannot start (code 10)"
    Works with BootCamp.
  3. rumplestiltskin

    rumplestiltskin Bit poster

    Device: OfficeJet G55
    MFR: HP
    OS: Windows 2000 (SP4)
    Symptom: Shows up in list of devices at bottom of window but the driver doesn't show in the "Add Printer" list (even though the HP G55 Installer runs successfully). Also: USB Port in "Add Printer" wizard doesn't show up about half the time.
    Affects: No printing possible.
    Changes : First time installing using RC2; never tried printing with earlier v's.
  4. Menace

    Menace Bit poster

    What about the other USB devices like my SCR335 Smart Card Reader
    from SCM Microsystems? When will they finally work?
  5. rcomeau

    rcomeau Member

    Are you sure you have the correct driver loaded? Unlike the Mac version (which works for all their devices), they seem to have separate version for each device.

    Does the device show up when using the KeySpan serial assistant? The problem I have when I have the Mac driver loaded is (I assume) that the Mac driver competes with the Windows driver in Parallels and Parallels looses. If I have the serial assistant running in Windows, the device shows up for a second, then disapears (and I get the "device in use by the host" blah blah error). If I remove the OS X driver, the serial device stays up in Windows. I have not tested it by connecting a real device yet because the cables I use in the offic e just left with our gear for a trade show. I'll test it with my Serial enabled Garmin GPS tonight.

    I'll see if I can get away with the comand-line kextload & kextunload to enable/disable the Mac drivers so I don't have to deal with the Keyspan installer all the time.

    In any case, I hope Parallels continues to improve USB support, or even better, supports real serial ports rather than just sockets and files. That would do away with the USB support requirements all together and probably would not be all that difficult to do (but how many of us need this is the problem I guess).


  6. miketichon

    miketichon Junior Member

  7. shredrca

    shredrca Bit poster

    Zonet ZUC2800L Card reader and USB 2.0 hub

    Zonet ZUC2800L Card reader and USB 2.0 hub

    Parallels Desktop for Mac rc2 with WinXP-SP2 recognizes the hub and the card reader but only sees it as USB 1.1. Otherwise it works like a charm.
  8. powell

    powell Junior Member



    I just confirmed that I am using the correct XP driver (I have actually tried to use the HS driver to see if I could get it to work to no avail). I am using the same driver (for the USA-19QW) that I use in BootCamp (where it works flawlessly). I don't have the MacOSX driver installed. When running RC2, I plug in the Keyspan, and Windows announces new hardware has been found. I look at the KeySpan Assistant and it says that it cannot find a serial device. Windows alerts me after a short period that the driver cannot talk to the device.

    Alas. I am looking forward to getting it to work in Parallels though!
  9. daveef

    daveef Member

    If anyone has any USB cam working with this would be glad to hear about it, Would even go out and buy the cam. But have not seen one post saying that has occured. So the words some may work and some may not could be a little misleading. Still have hope though:):)
  10. dlatkins

    dlatkins Junior Member

    USB-attached HP Officejet 7110 still not working

    Hi, all.

    I've updated to RC2 (including the Parallels Tools Center), and I still can't print to my Officejet 7110. I downloaded the latest driver software from HP's website, printed out the instructions, and followed them to the letter. That included first uninstalling all previous Officejet driver software (and rebooting), unplugging the USB cable and turning off the Officejet, installing the software (and rebooting), plugging in the USB cable and turning on the Officejet to complete the Plug-and-Play portion of the install, and then completing that install. Everything seemed to go fine, but when all was said and done, the little status icon in the toolbar tray said that it couldn't communicate with the Officejet, and trying to print ended up with a job in the queue that also couldn't communicate with the Officejet.

    Any ideas?
  11. Menace

    Menace Bit poster

    Very slow USB connection

    If I want to transfer data back and forth from my external USB Hard Drive with RC2 it takes 20x longer than with Boot Camp (or 40 minutes instead of 2 minutes).

    The speed needs to be improved.

    Please, do improve USB support. It can`t be that hard.
  12. lgp

    lgp Bit poster

    I have an Epson Pixma MP950 attached to a 2.0G iMac with 2.0G memory. I have a Guest XP Pro SP2 running under Parallels. XP sees the printer and installs it, but printing a test page (or printing anything else) fails.
  13. merwin

    merwin Member

    Getting USB to work properly in virtualization software is harder than you might think :)
  14. jayncee

    jayncee Bit poster

    HP PSC 1510 driver and Samsung Mobile Phone driver cannot be installed.
    If these devices are unable to work properly in parrallels Windows XP,
    my pre-order will be useless.
    Please, fix those problems soon.
    Last edited: Jun 2, 2006
  15. wizzo

    wizzo Junior Member

    Are you programmer?

    How do you know it "can't be that hard".

    As stated before, getting USB to be shared between two different OSes at the same time is not trivial at all.
  16. hmss007

    hmss007 Bit poster

    The following device will not connect to the Windows XP. It is seen in the USB device list at the bottom but errors out when you try to connect to it.

    Device: Motorola V3
    MFR: Motorola/T-Mobile
    OS: Windows XP SP2
    Symptom: USB device you are trying to connect to the VM is in use by another process.. Wait 5-10 seconds, then try to connect the device again.
    Affects: Cannot sync device to my windows Outlook which is my work database.
  17. schmidp

    schmidp Member

    How about using the Printer Sharing from macos x?

    greets philipp
  18. Menace

    Menace Bit poster

    No, but I am a potential buyer of Parallels.
  19. Newsguy

    Newsguy Bit poster

    Motorola Q Problems

    Please add the new Motorola Q to the list of products that won't work in Parallels. Running RC2 XP SP2. It sees a driver, but won't do anything with it.
  20. luz

    luz Member

    Qtek 9100 Win Mobile 5, ActiveSync 3.8,4.0,4.1

    I tried the Qtek 9100 with three different ActiveSyncs (3.8, 4.0, 4.1) under WIn XP SP2.

    I have USB autoconnect off.

    It shows up in the list of USB device as "Generic RDIS", when I select it, Win XP recognizes it as a "Windows Mobile" device and installs a network adapter for it. However, then some error prevents that adapter to go active - it receives the yellow question mark icon in the hardware manager.

    This is 100% repeatable (I have to remove the network adapter in the hardware manager to make the system try installation again, of course).

Share This Page