USB Devices Not Working in RC2

Discussion in 'Windows Virtual Machine' started by rmwilliams4, May 31, 2006.

  1. sdfjkl

    sdfjkl Bit poster

    USB Report

    Here are some experiences with RC2 and a WinXP SP2 Guest and some USB devices:

    • HP Laserjet 1300: worked once, was recognized, drivers installed, printed a page - didn't since. Apparently MacOS doesn't properly release the device when connecting it to a VM guest.
    • HP iPaq hx4700 (USB Cradle): Works, however: Whenever the device is restarted or undocked/redocked, it is disconnected from the VM and needs to be manually reconnected - thats rather annoying - I suggest adding an option such as "always connect this device automatically". Also the HP Firmware upgrade doesn't work correctly with this - it starts, but looses connection a few percent into the upgrade.
  2. marana

    marana Bit poster

    VEC USB Footpedal not working

    When i try to activate it in the USB selector (bottom right) I get teh "USB device you are trying to connect to the virtual machine is being used by another process. Wait 5-10 seconds...."

    Running WinXP SP2 (with patches) on a iMac 20" w/ 2gb of ram.
    Parallels RC2
  3. cetuma

    cetuma Member

    HP Photosmart 8250

    Device: HP Photosmart 8250
    Host: MB Pro 2.16 / 2GB
    Guest: WinXP SP2
  4. freaky

    freaky Bit poster

    Microsoft ActiveSync 4.1

    Device: PDA (USB Devices)
    MFR: 02 Atom PDA
    OS: Windows XP SP2
    Symptom: Activesync 4.1 does not register Windows CE Devices connected to the MAC usb port.
    Windows makes sound when devices are connected and diconnected which is normal, but Activesync does not see the connection even though it knows that the usb port is available.
    Affects: Cannot sync PDA's with Microsoft Activesync 4.1 for phone books, addressbook email etc...

    I see this as a MAJOR REASON for people to BUY Parallels Desktop for Mac, because it is hard to sync PDA's and Smartphones on MAC OS X.

    It would be great if this is not overlooked in the final release.

    Has anyone had success using Activesync 4.1 ?
  5. sdfjkl

    sdfjkl Bit poster

    As mentioned above, HP iPaq hx4700 syncing works (ActiveSync 3.7.1, USB Cradle) here.
  6. hcdavis

    hcdavis Bit poster

    Nokia 9300 unable to connect via USB

    Oddly enough my phone shows up in the list of available USB devices but I get the standard wait 10 seconds message and it won't connect. I can print, but even with autoconnect on I have to manually select the printer device from the list. Proper USB support is critical for my use of Parallels Desktop for Mac OS.
  7. edwardlotz

    edwardlotz Bit poster

    Sony Ericsson Phone not able to connect

    I have a SonyEricsson phone Model K750i....when connected it starts Itune and mounts as a drive...and Parrellel for Mac..say something is blocking the USB....

    I close all Mac programs attached and eject the memory drive in the phone...but I can not get pass the blocking USB message...anyone knows how to do this so I can connect my phone. I need to upgrade firmware and can only do that with a Windows xp machine....
  8. mattmon

    mattmon Bit poster

    I have an ioGear GUC-232A USB/Serial adapter that works great in both RC2 and OS X.

    I just have to make sure to unload the kext before use in windows:

    sudo kextunload /path/to/kext/bundle

    I also have a Cingular 8125 that I have made work all of once - then it would never work again. This is after I enabled serial mode on the WM5 device...
  9. Spike

    Spike Junior Member

    My Keyspan USB-to-serial USA-19QW doesn't work with RC2. Same failure mode as the report above. I will point out that this adapter doesn't work with VirtualPC 7 on my PowerBook either. I have to keep a copy of VPC 6 around just for doing serial port stuff.

    On a brighter note, my Kvaser USBCanII USB-to-CAN adapter works like a champ with both XP and Fedora Core 5. Right now this is more important to me than a serial port, and I think I can convince the boss that a PowerBook -> MacBook Pro upgrade is justified now that I know this device will work.
  10. fredcast

    fredcast Member

    Garmin Edge 305 GPS Device

    Device: Garmin Edge 305

    MFR: Garmin

    OS: Windows XP SP2

    Symptom: XP recognized the unit and installed the Garmin drivers (drivers v. 2.1). The unit is recognized by the device manager. When I try to connect to the unit using Garmin's MapSource (6.11.1) or with Garmin's Training Center (3.1.4), the software doesn't see it. I have tried connecting the unit to different USB ports on my MacBook Pro (Parallels Workstation RC2), but the same symptoms occur.

    Affects: Cannot use the device with XP under Parallels Workstation. The device works fine with this exact same setup on real PC hardware.

    Thanks for such a great program. I am hopeful that you will get this issue sorted out very soon.


    The FredCast Cycling Podcast
  11. dmgwork

    dmgwork Member

    Xerox Documate 252 High Speed Duplex Scanner

    When attempting to scan, I get the blue screen of death in windows xp pro sp2

    Device: Xerox Documate 252 High Speed Duplex Scanner
    MFR: Xerox / Visioneer
    OS: Windows XP SP2
    Symptom: blue screen of death when scanning from Paperport ( or Adobe PDF), computer recognizes scanner
    Changes : Problem has been consistent since first version supporting USB
  12. fredcast

    fredcast Member

    Just an update on my progress with using Garmin and Parallels together . . .

    I am able to use MapSource to create maps for my Garmin iQue 3600 (which are then synced via Palm software). I am able to send and receive to and from a Garmin GPSMap 76. I am not able to do anything with my Garmin Edge 305.

    For a complete rundown of what I have done to get this working, see the following thread:


    The FredCast Cycling Podcast
  13. erdgeist

    erdgeist Bit poster

    The Cardreaders CardMan 2020 and ReinerSCT CyberJack eCom also not work. I need one of them to work for my online banking. Thats one of the only reasons i would by and use parallels.
  14. s.cresswell

    s.cresswell Junior Member


    ADInstruments PowerLab, using ADInstruments Chart.
    Blue screen crash when Chart is aquiring a USB2 PowerLab.
    USB1 PowerLabs seem ok so far
    Last edited: Jun 11, 2006
  15. netsyd

    netsyd Bit poster

    AS 3.7.1 may work fine on yours, but please note that the way AS 4.1 handles connectivity is different ... especially when you get into firewalls and things of that nature. You can have 3.7/8/9 installed and working fine with your device and then install AS 4.x and not have it work at all.

  16. patches

    patches Junior Member

    Gemplus PC433 USB smart card reader

    When it is plugged in with an XP VM already running, I get the 10 sec error. If it is plugged in when attempting to start a VM, Windows does not start, like there is a blocking thread or something.
  17. Fithian

    Fithian Bit poster

    I have a Canon Pixma iP90 that works fine with RC2 and Win2000 using USB. I installed the Canon windows driver and it just showed up. I haven't yet been able to find how to print to this printer using bluetooth.
  18. ArmyDuck

    ArmyDuck Bit poster

    Hello, I'm having a difficult USB issue too. Has anyone tried using a CAC reader with Parallels and had success in having the CAC reader install and work with ActivCard Gold. I hate to say it here, but on my old iBook using VPC 7.0, it worked like a charm and I was able to do everything I needed to with my card reader. I really need this functionality...just curious. I'm using a MacBook Pro 2.0 1.5GB RAM, running Parallels RC2. Thanks guys.
  19. msolsona

    msolsona Junior Member

    Activesync 4.1 with WM05 report

    I had a chance to test 3 devices in the US:

    Verizon XV6700:
    - RNDIS mode: did not work, recognized by OS, not by Activesync
    - Serial mode: working ok. It must be used with AutoConnect off, or connection does not last more than 3min.

    Verizon Treo 700w:
    - RNDIS mode: did not work, recognized by OS, not by Activesync
    - Serial mode: working ok. It must be used with AutoConnect off, or connection does not last more than 3min.

    Imate K-Jam:
    - RNDIS mode: did not work.
    - Serial mode: did not work.

  20. yannis

    yannis Bit poster

    Problems with the USB driver in parallels RC2 with the following devices:

    Blackberry: 8707v

    Garmin: iQue M5

Share This Page