USB Devices Not Working in RC2

Discussion in 'Windows Virtual Machine' started by rmwilliams4, May 31, 2006.

  1. urbanape

    urbanape Bit poster

    It would be useful to hear from anyone on strategies for determining just *how* the Host OS already has control over a particular USB device. I'm in the same boat (actually with the same phone) as EdwardLotz, and while I've disabled ImageCapture from automatically launching iPhoto when my K750i is connected, and I've unmounted the phone from the Finder as a removable media, I still get the 5-10 second message. I don't really have a good idea where to start tracking down what other processes might be using the phone.

    Any hints?
  2. bpeter

    bpeter Junior Member

    Well, I can only confirm that the previous errors about usb devices not able to start are still exists in today's GA release. :(

    Could anyone post some hints about what to do to walkaround this error? I cannot use my VPN connections because of this... :(((((
  3. Spike

    Spike Junior Member

    I spoke too soon. It worked fine in RC2, but no longer works since I installed GA.
  4. msuper69

    msuper69 Bit poster

    Until I can use a USB Floppy Drive, I won't consider paying for Parallels.

    IMO, it is very questionable to expect people to pay for this software w/o decent, reliable USB support.

    It was released for purchase too soon.
  5. dkp

    dkp Forum Maven

    We don't all need USB support in the Windows VM so it isn't a show stopper, and I'm quite happy to have it now rather than later. It is entirely possible that because none of the support software for USB devices were built anticipating they'd be shared in a virtual environment, there may be unresolvable issues. In my case I have a printer and an iPod. Both work perfectly well in OS X and I have no need or interest in them working in Windows. Windows can see the shared printer and has no business attaching to the iPod. So I'm a happy customer. If USB support is a critical service then this is probably the wrong product for you to use to run Windows on Mac hardware. That does not make it a bad product - just the wrong product.

  6. Larry__Rymal

    Larry__Rymal Member

    Certainly depends on one's need. In my case, I need Windows to supplement my Mac. My Mac does the heavy stuff. I just need Windows for just a couple of products and that is it. USB is a very minor issue for me.

    USB won't work with my Garmin, but using a USB to serial adapter, I am able to use the Garmin.

    Yet, Garmin doesn't YET make software for the Mac. Parallels Desktop opened up a new world for me. I now can do GIS stuff on my Mac instead of having to use a klunky Dell laptop that you can't see in sunlight. My Mac does a marvelous job with this combo. I'm happy.
  7. dschamis

    dschamis Bit poster

    I think that this is well known to people, but I didn't see USB headsets on the list, so I'll include it:

    Plantronics DSP-400 & Logitech 250
    Win XP Pro SP2
  8. dkp

    dkp Forum Maven

    I just checked my USB floppy drive - it's a SmartTech that I bought at the Apple store in Seattle. It works great in OS X and Win XP. It was a pretty inexpensive drive, too. I don't know why but my wife insisted on having a floppy drive. So there ya go - it's possible.

    I did have to use the Parallels Devices menu to activate it, and I had to unmount it in OS X before Windows would see it, but that is expected.

  9. patches

    patches Junior Member

    Unmount a device in OS X?

    I'm a mac newbie...How do you unmount a device in OS X?

    Thanks in advance
  10. joem

    joem Forum Maven

    Three ways:

    In the finder, click the up-arrow looking icon next to it in the left pane of the finder window

    Right click (or control-click if you only have one button) the device icon on the desktop and select eject.

    Drag the device icon on the desktop to the trash (real intuitive, right?) This deletes files, but unmounts devices -- my idea of bad UI design, but Apple mostly gets it right in other places.
  11. tmeadow

    tmeadow Bit poster

    I'm having two USB problems:

    a. Syncing my Treo 650 w ACT. The process seems to start alright, but because I've got a lot of contacts it does not complete.

    b. Using a CardScan 700 scanner. The CardScan application cannot see the scanner .
  12. dkp

    dkp Forum Maven

    Something to remember is that Parallels emulates USB 1.1. If the application for your device cannot use USB at that level it probably won't work (Chorus: Duh!). The Parallels folks are working on 2.0 for a future release (FFR). Based on what I've been reading about USB problems in this forum I'm wondering if perhaps this is a major contributor.

    USB 2.0 should be able to fall back to 1.1 but it's anyone's guess if the applications permit that. I don't have any to test, unfortunately, but every USB device I've tried works fine in Windows as well as OS X. And every time there is a need to command the unwanted OS to release the device so the other can use it.

    I use OS X to sync my Treo 600 so have no need to do that in Windows.

  13. TLCC

    TLCC Bit poster

    usb function is very important to me. I review and use many gsm imported phones and I have to use different software that run in windows. I purchased Parallels and it works great for my other needs. But I am having to give up 20 gigs of my hard disk to Bootcamp just to be able to use usb connectivity. It really sucks that I have the ultimate program to run windows in my main os but can not use usb connect.
  14. daddygadgetdude

    daddygadgetdude Bit poster

    Garmin Forerunner 305 USB Not Connecting

    USB device you are trying to connect to the virtual machine is being used by another process. Wait 5-10 seconds, then try to connect the device again. If this does not help, find the application that blocked up the device and disconnect it manually.

    Major Bummer Dudes
  15. dfeshbach

    dfeshbach Bit poster

    USB Devices not working in Production Version

    Hi, I have two devices that install the drivers fine (Logitech WebCam Fusion, and VTech Skype phone), however when trying to connect them after a reboot, windows say the device is not recognized/connected and thus these two USB devices are rendered unusable for the time being...

    This seems to be a common problem. Any word on when the USB challenges may be fixed?
  16. divi996tt

    divi996tt Junior Member

    I bought the Program,Tried all my USB's and none of them work:

    1- My Book- USB External HD
    2-Firelite- Compact External HD
    3- Sony Erickson - W600i
    4-Garmin 60CS
    5-Nikon S6
    6- Canon 20D Card Reader
    7- Korg Triton Extreme
    8- Uniden Bearcat Scanner
    Last edited: Jun 25, 2006
  17. Fithian

    Fithian Bit poster

    I was just able to print to my Canon Pixma iP90 printer that has the bluetooth module installed. I used Bonjour on Win2000 and set up printer sharing on the OSX side. The quality is not good, but it does print in color using the generic/microsoft printer settings. The postscript setting was limited to grayscale printing.

    This allows me to print wirelessly (using bluetooth) to my Canon, as well as connecting a USB cable for higher quality printing.

    Using Parallels build 1848 and Win 2000 Pro with 1GB ram
  18. Xabi

    Xabi Bit poster

    I want this to be cleared from the Paralells stuff and not from forum users. If this is the case, this product is bad advertised (I see "USB support") and I will ask for a refund.
  19. dkp

    dkp Forum Maven

    FWIW, I just bought another USB device. I now have:

    iPod Nano, USB floppy drive, Sony DSC-W100 Camera, Treo 600, HP ColorJet printer, 2g thumb drive, 1g thumb drive, USB to Serial adapter, HP flat bed scanner, Firewire webcam. All but the firewire webcam (It's a very old model) works in both OS X and Windows XP on both MBP and Mac Mini. I've yet to find a USB device that does not work. The flatbed scanner has no driver support from HP for OS X so it is useless there, but it is seen. It works fine in XP. I'm about to purchase a joystick and will provide info on how that goes. To be honest, it isn't important to me if any of these works in Windows as that is not where I use them, but I was curious to see if they could. The scanner is going to be replaced with one that is properly supported natively in OS X and will definitely not be a WinHP brand.

  20. rcomeau

    rcomeau Member

    Can you tell me which USB-Serial adaper you are using? I have tried the Keyspan USA-19HS and the USA-49WLC with no luck. The 19HS can be seen by the keyspan assistant software but not send data reliably and the 4 port model is not recognized by the keyspan software, let alone available for use by other software.



Share This Page