USB Devices Not Working in RC2

Discussion in 'Windows Virtual Machine' started by rmwilliams4, May 31, 2006.

  1. dschamis

    dschamis Bit poster

    Parallels staff,

    Any updates on timing on some of these things? I don't mean to be a pain here as I'm sure you are working hard on this, but we are all obviously very anxious for proper USB support (from my point of view, all I care about is a USB headset).


  2. dkp

    dkp Forum Maven

    It's the Keyspan 19HS. I use it to connect to the terminal ports of my Solaris servers and it's been fine for that.

  3. rcomeau

    rcomeau Member

    Hmmm, when I use the 19HS, I find that it is at best intermitent. I once got it to talk to my GPS using EasyGPS (I think) but my lab software to talk to a piece of lab equipment always gives me a timeout error. I'll give it another try.


  4. Xabi

    Xabi Bit poster

    I celebrate your good luck with USB devices under Parallels, but you are posting in a 7-page thread with people complaining about lack of USB support. So please don't come here saying that Parallels is the "wrong product" for USB support simply because you don't need this feature.
  5. Spike

    Spike Junior Member

    Just wanted to follow up here. I've been using a Mac so long I had forgotten about all of the mindless crap you gotta do to keep a Windohs machine running. I did the pointless uninstall-and-reinstall-hardware shuffle on my Kvaser USB-to-CAN adapter, and it magically started working again.
  6. Spike

    Spike Junior Member

    Three days later and it has magically stopped working again. The pointless shuffle has no effect now. What's worse, the Linux driver for this device is so bad that in order to make it do anything you gotta boot to Windohs first and do something with the device, then reboot to Linux without unplugging it.

    I like what I've seen of Parallels thus far, but until the USB support is stable it's basically useless for me.
  7. orthocross

    orthocross Bit poster

    I absolutely HAVE to have USB 2.0.
    My 250gb USB 2.0 drive only works at reduced speed (USB 1.1)

    When I turn it on in Windows, Windows connects it, but proclaims that I've installed a USB 2.0 device into a USB 1.1 plug on the back of my Apple 23" Wide-Screen display. From what my brother tells me, the USB 2.0 connections on the back of my 17" iMac are all supposed to be USB 2.0. I know the connections on the back of the Apple Pro Keyboard are both USB 1.1, so I have the USB 2.0 HD plugged into the back of my Apple Cinema Display.

    Any solutions from Parallels yet? I just purchased Parallels Desktop 2.1 (Mac).

    Donald L McDaniel
  8. joem

    joem Forum Maven

    Parallels emulates USB 1.1, but at much higher speeds if your physical device is USB 2.0 and plugged in to a USB 2.0 port. AFAIK, all USB ports on Intel Macs are USB 2.0. If you test your drive on your Mac in the VM and on a Windows hardware machine, you will probably see comparable speeds. The assumption that a report of USB 1.1 means only USB 1.1 speed is not accurate.
  9. wilbanja

    wilbanja Bit poster

    Garmin Forerunner 305

    Device: Garmin Forerunner 305
    MFR: Garmin
    OS: Windows XP SP2

    Symptom: Similar to other posts. XP recognized the unit and installed the Garmin drivers. The unit is recognized by the device manager. Garmin's software, Training Center (3.1.4), though doesn't recognize it. I have tried connecting the unit to different USB ports on my iMac (Parallels Workstation RC2), but the same symptoms occur.

    Affects: Cannot use the device with XP under Parallels Workstation. The device works fine on PC hardware.

    If this would work, I could drop my Windoze box in the recycle bin.

  10. chriskrogers

    chriskrogers Bit poster

    No Luck with CAC either...

    Yes, I am too having problems. The CAC is seen by Parallels but the drive does not seem to function properly. When I view the hardware in System, the CAC reader is there. I click on the CAC reader and the driver General tab indicates that the driver is not installed; however, when I click on the driver tab, it indicates that the driver is installed. I too need this functionality. I was able to get the CAC reader ti work in BootCamp. I like Parallels MUCH better. Someone - Parallels - PLEASE HELP!
  11. daveef

    daveef Member

    How I solved my usb cam problems with parallels :):)

    Ok first i love parallels cause i can use my mapping program on it and not have to reboot into bootcamp.

    Now I solved the camming issue by not using the cams in parallels. The new yahoo works great for camming in mac OS X and a program called aMSN runs MSN in mac but without sound i think but cams are great. And Jmeeting runs the isight cam also, Although the cam has a blue tint , but think that will get worked out sometime. But i am not that good looking anyway so blue is ok. lmao.

    So my big complaint of not having cams is over. And the windows now runs all the programs i need to run. so Parallels fills all my needs.

    I still have to run bootcamp to use my GPS on my mapping. But when driving i dont need Mac OS running anyway. so i am happy camper. Who know maybe someday the gps will run on Parallels then i can trash Bootcamp. Oh glorious day. lol

    BTW anyone using aMSN with router or airport will have to do little reading of the port mapping notes. haha and then try to figure out what it really says :):)
  12. conalho

    conalho Member

    Garmin Forerunner 205 -- does not work

    Device: Garmin Forerunner 205
    Manufacturer: Garmin
    Problem: Parallels says that the USB device is being used by another application and I should unplug and wait 5 to 10 seconds and try again.
  13. ram

    ram Bit poster

    Using Web Cam in Parallels

    Device: QuickCam Express
    MFR: Logitech
    OS: Windows XP SP2
    Symptom: XP installs driver, but the end complains that the device cannot start (code 10)
    Affects: Can't use Yahoo Messenger or MSN under windows to video chat.
  14. VM-o-saurus

    VM-o-saurus Bit poster

    Motorola Q Phone/OS X Host/Windows XP SP 2 Guest/Beta update 08/08/2006 not working

    Seeing that this is the only posting that comes up re: Motorola Q, Parallels, and Win XP, I'd like to add that the Motorola Q is still not working properly with the Microsoft ActiveSync 4.1.0 (Build 4841) software that are distributed with with the Q phone.

    To the earlier poster who suggested that developing this kind of software and working USB support "can't be that hard", consider taking an OS design and implementation course. This is not trivial stuff here. The Parallels, VMware, and Xen folks know what the hell they are doing. After you take this course, consider every type of OS that might be running virtually and its USB driver architecture. Then you will see firsthand how non-trivial it is.

    That said, I am a paying customer and am disappointed that I cannot get this working. I would suggest to the Parallels team that they prioritize the development of these sorts of devices, which are sorely lacking support on the OS X platform and (for the foreseeable future) likely require a virtual Windows session to be used effectively.
  15. bpeter

    bpeter Junior Member

    Well, my problem with the Omnikey SmartCard USB Reader has been solved with the latest beta.

    Hope you guys will find your cure too.

    Thanks, Parallel.
  16. serialio

    serialio Bit poster

    Blackberry not working via USB

    Device: BlackBerry 7130
    MFR: RIM
    OS: Windows XP SP2
    Symptom: USB device you are trying to connect to the VM is bein guse by another process.. Wait 5-10 seconds, then try to connect the device again. I get this error at best. Sometimes no recognition whatsoever.
    Affects: Cannot load apps to the device, necessary for software development.
  17. pderby

    pderby Member

    Device: ST-402 Camera (Astrophotography)
    MFR: Santa Barbara Instruments Group
    OS: Windows XP SP2

    Symptom: Camera uses two USB drivers that install just fine. One of the drivers uploads firmware into the camera, which seems to work fine. The other driver establishes a two way communications link to the camera. When the software (CCDops) is asked to establish the connection to the camera, the application freezes and the connection is not made.

    Affects: Cannot use the device with XP under Parallels Workstation. The device works fine on PC hardware.
  18. JohnFowles

    JohnFowles Bit poster

    My SonyEricsson M600i phone is not working with USB. Both SE software (PC Suite for Smartphones and SE Updater software) work well but no USB connection. The phone is grabbed by OS X with the usual message. I use the latest beta.
  19. serialio

    serialio Bit poster

    Blackberry Working!!

    I finally got the BlackBerry working under Parallels. Auto-connect set, rebooted MacOSX, with only keyboard and BB cable plugged into USB. Loaded the XP VM and then plugged in the BB. Auto-detected, installed fine. I had to download a previous version of BB Desktop manager, however, to get it to see the thing (4.0 software). For some reason 4.1 wont see me. GOOD LUCK.
  20. andre

    andre Bit poster

    USB support for Samsung Z510

    Device: Samsung Z510 mobile phone
    MFR: Samsung
    OS: Windows XP SP2
    Symptom: XP installs driver, but when device is connected it is not seen by the application
    Affects: Connectivity

Share This Page