USB dongle: Double use ?

Discussion in 'General Questions' started by JLX, Dec 27, 2007.

  1. Xenos

    Xenos Parallels Team


    We'd like to see the Device Manager when your USB Dongle is connected to the Virtual Machine.

    It is important to find out what devices are seen in Device Manager after the Hasp key has been connected to VM and what their status is.

    Best regards,
  2. JLX

    JLX Junior Member

    It's the same as the printscreen.
    The Hasp is connected but probably i(m
    doing something wrong or I misunderstand your question...

    Before starting Windows the USB Controller in VM Configuration Editor is enabled and connect it to Guest OS again.

    The properties of the USB's?
    Control Panel -> System -> Hardware -> Device Manager->UBS->properties


    It doesn't make any difference if I plugin the hasp before or after starting WinXP.
    The message is still comin'.

    Nothing happens if I plugin the hasp in : Control Panel -> System -> Hardware -> Device Manager->UBS.
    It stays the same as the printscreen. (but a get the message)
    If I plugin a USB memorystick, I see a change : some USB (massstorage) is been added. (no message).

    My apologies if i misunderstand your question.
    best regards

  3. hhelenhh

    hhelenhh Bit poster

  4. JLX

    JLX Junior Member

    helo hhelenhh,
    I looked at the solution you used and I've tried it.
    When I'm in the OSX terminal and I give in the line
    the terminal (OSX) asked for my rootpassword.
    I don't use any password here and when I enter (blanc password) I get the message
    - bash: command not found.
  5. hhelenhh

    hhelenhh Bit poster

    Hasp issue


    Since I use a password on my mac system, I am wondering if it would help for you to set up your admin user to have a PW. You would also have a more secure system. Other than that, I am not sure what that message means, since I rarely venture into unix space :) That's also why I put the extra info below, because novices like me don't know that there is no "fudging" in Unix...everything has to be typed exactly. (I think..:))

    (Another idea...create a new user, with a password and admin priveleges and do the stop process there...I think you can run Parallels from the new user and see whether you have released the HASP from the claws of Leopard ;))

    Be sure to copy only the
    sudo launchctl unload /Library/LaunchDaemons/com.aladdin.aksusbd.plist
    Text--and no extra spaces, etc. It has to be exactly the same as above.

    You are doing this from Leopard, correct? Remember to FIRST go to Alladin's website and download/install the Mac OS X driver

    This solved MY problem with the HASP Key being used by another app.

    AND THEN, I found that XP SP2 has an issue with the HASP drivers as well. Apparently SP2 installs/updates...basically installs the wrong driver, so my software doesn't see the HASP.

    So, I found a page that explains how to use the HASP commandLine Driver installer from within windows. I used hinstall -r to uninstall first, then hinstall -i to install and then -info to see which driver had been installed. put a space before the minus sign. This made XP "see" the new hardware (HASP) and install the driver.

    Unfortunately it did not solve my problem and my 3D Embroidery software still doesn't recognize that the HASP key is installed...sigh.

    This might solve the issues you are faced with though!

    I have done a lot of searching in Parallels, XP forums, Searches on HASP installation in XP, etc, so hopefully someone can benefit from those links!

    Please let me know if you find anything else!

Share This Page