USB in beta5

Discussion in 'Parallels Desktop for Mac' started by STim, Apr 26, 2006.

  1. maverick808


    Indeed. I really hope proper USB support is in the next beta as synching my PDA is the sole reason I need Windows in the first place.
  2. Dragon


    I have one main question, will support be limited to usb1 speed?

    One of the things I'd most like to be able to do with usb support is connect up a usb dvd writer, and be able to run nero cd/dvd speed on it to do a disc quality scan, as I've yet to find any mac software that can do such, and rebooting though bootcamp just for that would be a total waste!
  3. jimh


    The first time I plugged my flash drive in, ejected it, and waited for a short bit, it mounted in my Windows desktop no problems.

    However, after I ejected it from Windows the first time, then I started having problems such as:
    - if Windows was open and running, it was always capturing/mounting the device before OS X could do so (assuming the mechanism, but Windows always captured it)
    - OS X could not see the drive unless Windows was suspended or closed
    . then OS X could see it OK (sometimes I had to remove the drive, wait for a while and plug it back in - other times it showed up right away)
    - After I got it back so that OS X could see it again, I can't seem to get Windows to see it any more, whether I do the normal ejection while Windows is running or suspended.
    - If Windows is active, I can't seem to get OS X to see it regardless, even is Windows doesn't see it (the OS X device manager and the Parallels status bar USB managers both see it)

    I also noticed that, when I tried to switch the My Computer screen from the USB device back to the base My Computer screen (only tried one time so far), Windows froze for several minutes (5?), Windows cursor didn't move, OS X was fine. I was going back and forth trying things and suddenly Windows became active again. Not sure what triggered it.

    It looks like the basic USB functionality, at least for flash drives, is there. However, the sharing with OS X and the detect/mounting and un-mounting needs quite a bit more work. Very complex interactions so understandable.


    Windows XP Pro - latest downloaded updates
    MacBook Pro - latest downloaded updates (10.4.6)
    Flash Drive Info: DataTraveler 2.0:
    Version: 1.00
    Bus Power (mA): 500
    Speed: Up to 480 Mb/sec
    Manufacturer: Kingston
    Product ID: 0x0008
    Serial Number: 0EF155516171DB4A
    Vendor ID: 0x08ec
  4. gtsullivan


    First got started with Beta 4. Very impressed. Win XP SP2, CENTOS, GenToo guests all running simultaneosly for testing (machine is MBP 2.16 GHz w/2GB and 100GB/7200RPM drive).

    Moved to Beta 5 (installation on top of Beta 4). The focus of my first tests was exclusively for Windows XP as a guest. Installation went fine but had to go through several reboots of the WinXP Sp2 guest VM to get stable. Installed tools from Beta5 to gain access to new USB and Shared Folders for testing. (BTW, the new trial license key did not change the start/end date of the trial)

    I seperately tried two different USB drives -- Jumpdrive Trio with a Sony memory stick and a WD USB 40G Hard Disk . Insertion of the USB cable lead to OSX mounting the drive as expected. I ejected the drive and then attempted to have WinXP SP2 pick them up. In both cases (seperate test instances), the drives were seen and supposedly mounted. I was unable to actually access either one.

    Later I also tried attaching my BlackBerry 8700c just for giggles. It was shown in the USB device list but when I attempt to connect to it from inside the XP VM, I get the error message indicating it is already in use. I guess OSX has it tied up but I do not know how.

    Hope this is useful as a data point.

  5. e7sharp9


    Where was this claimed?
  6. rcomeau


    I just tried with a Keyspan adapter with no luck. I either get a "Device is in use..." error message, or it connects to the device (I can see it in the Keyspan assistant screen) but drops it after a few seconds. I know USB support is new so this is just info for the dev people who might not have tried this yet.

    My preferred choice would be to have Parallels support physical serial ports so Parallels maps COM1 to a serial port and have the Mac map that port to the adapter as I have been doing with VPC for years. I've described this in the wish list section. If anyone else would lito chime in on that, please post to

    I'll wait a while to see if a solution appears here before trying "SerialClient" (see


  7. joem


    Bug - USB, host crash

    To get a USB device recognized, it seems to have to be selected in the device menu after the guest OS is booted. A flash drive (SD card reader) appears in Windows explorer, but I can't see the data or dismount it in Win2k.

    A USB serial device (Ross-Tech Key-USB OBD II interface) is recognized by the Ross-Tech software in Windows-as-guest (sometimes -- if I follow the exact correct sequence -- plug it in, start Parallels, boot Windows, select it from the device menu) but won't communicate with the external device (car). It works on a straight Windows machine.

    While attempting to make it work, Windows froze (who knows?). Reset VM from the menu gave me a black screen and host reboot.

    We've probably gone 9 out of the 10 steps required to make this work, so if there are experiments Parallels needs done to further illuminate this, let me know.
  8. Ekke


    Everything is used by another process??

    I have all kinds of devices in the USB list:
    Build-in iSight
    When I try to connect, just for grinds, it says that the devce is occupied by another process.
    Fine since that's right. But why do those need to show up, if not usable at all?
    In addition whatever I try, with the exception of somethnig I can manually eject from OSX, gives the same message. Not good, since not true.
    I would like to have the software release a device from OSX, instead of saying: "go find the program that uses the device" why not let the computer do so? If the program detects that another process claims a device, then the process ID should be traceable and in turn can be stopped - or am I wrong here?
    The best would be just bridge USB through to the guest.

    Mostly USB devices is why we need Windows, for programs with dongles, or devices where no OSX support is available. Right now only those devices can work for which we have OSX support in order to release it.

    For me this is an urgent need and I hope U solve it before the release version comes.

    Other than that - great piece of SW. Incredible speed if I compare it to Virtual PC, where I could go get a coffe after each key stroke!
    I run Win2K without any serious problem.
  9. daveschroeder


    Parallels said:

    And remember, people, this is *beta* software. Dare I say also that most people don't need Parallels Workstation *just* to sync PDAs with Windows...
  10. maverick808


    It was originally on the page at but as you can see it's been updated because if you go to that page now all the details are empty.

    EDIT: Both the MacUpdate and the VersionTracker current pages claim "Introduced USB support. Connect your favorite USB devices directly to a virtual machine!" That claim is definitely premature.
  11. maverick808


    Ugh... Parallels also said...

    That's what's on the main page right now. It's the most obvious information about USB to find and it quite clearly implies that all USB devices are currently working. I'm not blaming Parallels for saying it or thinking less of them but it's clear that when people read that on Parallels own front page that they assume USB is working for most devices.

    Also, since we can now use boot camp nobody NEEDS Parallels at all. However, once it supports USB it will be far the most convenient way for me to develop PDA apps. Would you rather I didn't desire Parallels for this one specific need and they lost a customer? Everyone who wants Parallels probably only wants to use Windows for only one or two very specific things. If they needed Windows for more than just an odd thing here and there then they'd wouldn't have a Mac since they'd need access to Windows all the time.
  12. Tommo_UK


    Yes, read my post properly ;) "...every time I try to connect to it in the USB menu, even when I have unmounted the K750 from the OS X desktop. Anyone know how to do this?"
  13. maverick808


    I really think you can't just yet. If you use USB Prober in the OS X developer tools you can directly see the devices OS X has a lock on. It simply won't release any phones I've tried with it either (Motorola RAZR, PEBL and iMate SP5).

    I tried unloading the IOUSBFamily kext so that OS X couldn't drive any USB devices and although it stopped OS X from seeing USB devices it also resulted in no USB devices at all being listed in the Parallels menu.
  14. blshaw45

    blshaw45 Bit Poster

    Garmin GPS no go so far

    I agree with everyone that parallels is a fantastic product, even at this early stage, with respect to both features and quality. The Parallels development team is awesome, too, especially with respect to their SPEED (just like Microsoft!). How they can crank out new versions every few days, each with major enhancements and bug fixes, is beyond me. And the folks who contribute to this forum are invaluable; if it hadn't been for this thread, I'd probably never figured out that I had to 'add' a USB controller to get even a flash drive to work.

    I can now see both of my flash drives in XP and can move files on and off them as one would expect. I stiill can't use my Garmin Quest GPS, though. I get the same message as others have seen with various USB devices: "USB device you are trying to connect to the virtual machine is being used by another process. Wait 5-10 seconds, then try to connect the device again. If this does not help, find the application that blocked up the device and disconnect it manually." The message appears as soon as I plug the GPS in.

    If anyone has been successful with a Garmin unit, please share how you did it. Otherwise I'll assume that this is a bug issue that will be resolved in a future release.
  15. Moondougie


    I, for one, do NEED Parallels. When I'm at home and want to play games that aren't available is really the only time I use the Boot Camp route - and that's not even an everyday occurrence. But EVERY day, at work, I need to use a couple of applications that won't work on my Mac natively - so, actually I have a greater need for Parallels than I do for Boot Camp (though I like having both - especially when it comes to showing off for my Windows friends who have an "attitude," for lack of a better word about computer OSes.

    I can't seem to get this to work with my SanDisk Cruzer - and I do "eject" the Cruzer from OS X before I launch Parallels. Should I be selecting autoconnect? If I should, it doesn't show in Windows. If I shouldn't and need to select it from the USB submenu, the blue light on the Cruzer comes on, but it still doesn't show up in Windows…any tips, hints or clues?
  16. Drewmangroup


    I am trying to see if a USB printer would work. How would i release it from OSX to be used in XP?
  17. Drewmangroup


    Well I'll be darned! I added the USB. Started XP. Let it install the drivers. Shut down XP. Restarted Parallels. Let XP boot, then plugged in the printer AFTER booting. And it worked, just printed a test page. Now to try my all in one that only scan under windows. I'll report if it works.

    Oh and the printer was a Brother HL-1440.

    Rather than have a new post, i will edi tthis one. So I tried my Epson Cx-3810, it will only scan if you are useing windows. I got it for free as a bundle with my Macbook. So it finds it, installs drivers, but it can't really connect to it. Windows shows it as "Ready" but the Epson software can't get a connection. I can't print a test page either. Some kind of comunication needs to be passed. I am holding out for the full version until i can verify that i can use the scan function of the printer in the VM.
    Last edited: Apr 28, 2006
  18. scrytch


    USB ActivKey not working

    My work uses the ActivKey from and this post is just to say this currently doesn't work - with the Parallels software stating I need to eject it from whatever app/service is using before it can be used in the Guest OS. The problem is nothing on the Mac is using it.

    I'd really appreciate support for this - then I'll be able to VPN into work from within the Guest XP Install running on Mac.

  19. mrudd1


    Samsung SGH-p850 no luck

    Just to add my .000002 cents. I have added a USB device, tried it under autoconnect and no autoconnect. I get the same message as everyone else, USB being used by some other device etc. Did I read that some has determined that the MacOS is the connected device?
    I too will only use this software to connect my cell phone to sync. The synce software is Windows only. I don't really want to use BootCamp. PWS would be a much better solution.
  20. NosillaCast

    NosillaCast Bit Poster

    stuttering noise with USB drive attached

    Put in Lexar USB flash style memory card reader (looks like a flash drive anyway) - Windows identified it, came up on the list, when I clicked it, it didn't respond for about a minute, then it started a stuttering sound that I could not kill! couldn't control-alt-delete to end a process, couldn't access any of the functions in windows. Finally it just stopped making the noise and went back to normal.

    Also tried my Seagate 5GB pocket drive, which technically isn't a flash memory drive either, actually a spinning disk, but I got some interesting results. Windows said "found new hardware" and did a bunch of other little happy looking popup windows, then suggested I get a USB 2.0 controller because 1.1 was so much slower. saw the drive anyway, but when I double clicked I got an error saying the E drive was not accessible. It asked me if I wanted to end task, so I said yes.

Share This Page