USB Keyboard Problem 5160

Discussion in 'Installation and Configuration of Parallels Desktop' started by slynch, Sep 17, 2007.

  1. slynch

    slynch Bit poster

    Since upgrading to B5160, I am having all sorts of problems with my keyboard.
    I am running on a 17" MacBook Pro OS 10.4.10
    If I am connected to an external USB Keyboard, I have to enable the USB keyboard under Parallels and disable it on the Mac side before it becomes fully functional under Parallels. For example if I do not enable it under the USB devices menu, my TAB key will not function properly. If I am in a WP document and press the TAB key, the key focus jumps to the task bar and does not set a TAB in the document. Other times, I will hit a key on the keyboard and It performs a wierd Windows function like "Lock Computer" or Search. This is inconsistent but frequent. Very strange. It is as if I is reading a modifyier key along with the key that I press.
    I can live with this, reluctantly, when connected to an external keyboard because I can disable it on the mac side. The problem is when I am working away from my desk and only have the internal keyboard. There is no way that I can disable this on the Mac side as it makes the computer completely non functioning. I have to put up with very quirky keyboard functionality and the TAB key just does not work (and it is important to me).

    Help. This was not the case in the previous release. I am thinking I have to roll back.
  2. johnv

    johnv Parallels Team Parallels Team

    1. Please upgrade Parallels Tools too.
    2. Open Configuration Editor and specify "Ask me what to do" in the USB controller options list. Or "Connect to the Virtual Machine (Guest OS)"

    Best regards,
  3. slynch

    slynch Bit poster

    John. That is what I had already done. I had updated to the latest Tools and under connection Options it is "Connect to Guest OS"

    As I mentioned first. The only way to consistently have my extended mac keyboard work is to disable it from the Mac. This a real problem for me when working on the laptop alone as it only has one keyboard.
  4. Sven.Luetkemeier

    Sven.Luetkemeier Junior Member

    I have the same problem using build 5160 with Windows 2000 SP 4/Mac OS X 10.4.10 on a MacBook. Any help would be appreciated.
  5. tucktuck

    tucktuck Junior Member

    me too, any answers?

    Mac OS 10.4.10
    Parallels build 5160 3.0

    It's the tab key that really interferes with working.
  6. Archy

    Archy Bit poster


    Could you please answer the couple of questions:
    1. What external keyboard do you use? Is it Apple keyboard or keyboard from other manufacturer?
    2. When you connecting keyboard to Mac does keyboard detection wizard start up?
    (It asks you to press button on the right of left Shift and button on the left of right Shift)

    Thank you.
  7. tucktuck

    tucktuck Junior Member

    It sounds like only the first poster uses an external keyboard, the rest of us use the laptop keyboard. No keyboard detection wizard here.
  8. Sven.Luetkemeier

    Sven.Luetkemeier Junior Member

    TAB key problematic with external and internal keyboards

    I can reproduce at least part of the problem by doing the following steps. The problematic keyboard behaviour seems to be affected by the Remap Keys setting in Parallels preferences.

    I'm using Parallels 5160 with Windows 2000 SP 4 on a MacBook Core2Duo 2.0 Ghz.

    To reproduce the problem do the following:

    MacBook lid closed, external Apple Pro Keyboard

    1. Starting Parallels Desktop

    2. Keyboard Settings/Remap Keys: "Do Not Remap"

    3. Starting Windows 2000 (VM was stopped)

    4. Wait for Windows to boot.

    5. Starting Start/Programms/Accessories/WordPad.

    6. Typing "this is a <TAB> test".

    7. soon as tab is pressed, the focus shifts to the task bar.

    With the internal keyboard, the same behaviour occurs.

    When I change the Remap Keys setting to "Swap CMD/CTRL" the problem doesn't occur at this point, but at least when using the external keyboard, TAB and Num Lock behave strange as reported before. However I'm at this point not able to reproduce the problem, it only occurs intermittently.

    Hope this helps!
    Last edited: Oct 7, 2007
  9. MacProUser

    MacProUser Junior Member

    Same Problem with Ext Keyboard and KVM Switch

    I'm having the same "TAB" problem. This just showed up on 5160. I've tried the different suggestions here and it still fails, I currently have CMD/CTRL swapped, but it failed with no remap, so I put it back.

    I have System 10.4.9, I'm using a Keyovation Gold Touch keyboard on a Mac Pro. It goes through a KVM switch (AddLogix DVI 2G).

    Like I said, this worked fine before, since the very early pre-FCS builds. It is intermittent, sometimes it behaves, sometimes it doesn't, but it is really annoying. I'd be happy to test any potential fixes or whatever I can do to get you info to root cause.

    I only have one keyboard on my system.

    Last edited: Oct 7, 2007
  10. dr4kds

    dr4kds Bit poster

    Mac Book, 10.4.10, Parallels no boot camp partition, XP Pro, Build 5160.
    When I try to enter a password into an application (m key is first letter) the application minimizes. When I am in excel and try to tab to the next field, the focus changes to the taskbar. If I click multiple times in the correct field, I am able to enter the password and tab to the right. I have checked everything I know of. Any ideas?
  11. philip_vl

    philip_vl Bit poster

    Mac Book Pro, 10.4.10, Parallels no boot camp partition, XP Pro, Build 5160.

    I have the same problem, with the built in keyboard as well as with several (apple and non-apple) keyboards. When I reinstall build 4560 with its tools, the keyboard works as expected.

    I am sure this is not the normal scheme for an upgrade ! ;-)
  12. Sven.Luetkemeier

    Sven.Luetkemeier Junior Member

    I just played around with a Knoppix Live CD. The problem with the TAB key even occurs using Linux without having Parallel Tools installed...

    Maybe it's time downgrade to build 4560? <sigh> :-/
  13. Hugh Watkins

    Hugh Watkins Forum Maven

    I see none of these problems using USB or PS2 windows / MS keyboards or using an Apple USB keyboard
    On both Mac OS and Windows I have the International keyboard options enabled and chose which layout to use

    I prefer MS keyboards because of the Alt Gr key to get @
    I don't bother wwith remapping
    just remember which keys to use

    I use a basic MS optical mouse
    the drivers for the 5 button mouse are a bit messy

    Hugh W
  14. olian

    olian Bit poster

    I have the same tab key problem, running on a Mac Pro (desktop) using the accompanying bluetooth apple keyboard. Os X10.4.10, no bootcamp, Windows Vista.
    Same symptoms as others. I forget that tab opens the task bar, and then once I start typing letters, all sorts of stuff happens - it as though I had hit the windows key and then the letters start acting as shortcuts. For example, tab and then starting to type the word "restful" will bring up the windows "run" window just as if I'd typed Windows-R.

    Like the others, this just started happening in a recent upgrade, but I can't remember which one. Please fix - it is maddening to use Quicken in Windows and not be able to tab between fields.
  15. KrP

    KrP Member

    I upgraded to the 5160 build and reinstalled parallel tools a couple of weeks ago. today the screen started popping in and out of the start menu, task bars, closes windows, locked the computer...ect while typing text and commands into autocad and notepad. (Maddening!!)

    Has any one found a way around this? I have tried Full screen and coherence modes seems to go away for awhile under full screen. I tried a full shut down and restart. I tried unchecking virtual memory allocation. (don't know why -- just seemed like something to try.)
  16. jackrose5

    jackrose5 Bit poster

    same here

    I have this problem consistently with 5160 on CoreDuo MBP with external Apple Extended Keyboard. Tab key always brings up start menu.

    Also, occasionally, when trying to enter passwords in web forms, I get dialogs popping up allover launching the Voice Navigator system in XP. To make it stop I bring up NotePad or something and type out the characters in the password and then when I return to FireFox, it's fine until the next time ... and ideas here would be greatly appreciated.
  17. Sven.Luetkemeier

    Sven.Luetkemeier Junior Member

    new beta affected too

    unfortunately, the problem with the tab key isn't fixed in the latest beta release (build 5540)...
  18. alljosp

    alljosp Bit poster

    I have the same problem with my macbookpro, using the regular internal keyboard and build 5160. Nothing else is very unusual about my setup. Drives me crazy.
  19. tucktuck

    tucktuck Junior Member

    especially if you have an answer!
    Now using Leopard and the lastest Parallels build and still having the same tab key problem.
  20. sonjay

    sonjay Junior Member

    Did anyone ever find a solution for this? I'm having the same tab problem, Parallels on Tiger with standard Mac usb keyboard.

Share This Page