USB Printing problem solved! (Generic solution?)

Discussion in 'Parallels Desktop for Mac' started by macgebruiker, Jun 9, 2006.

  1. fabriceh

    fabriceh Bit poster

    Fix for printing to shared USB printer w/3036

    With build 1970 I've managed to print from Parallels to a USB Canon printer connected to a networked iMac using Bonjour and selecting the Generic/Postcript driver.

    When I moved to build 3036, this stopped working. Launching Bonjour to reconnect the printer resulted in Bonjour losing the connection to the printer after a few second,or not seeing the printer at all.

    I suspect this is a firewall/NAT issue created by Parallels. With the new beta builds, Parallels can establish its network connection through the Shared Network option, which makes your Parallels machine go through the same network IP as your underlying OSX session. I believe that the shared printer cannot figure the dual sessions through 1 IP thing and you lose connection in Parallels.

    I switched my network connection for Parallels to Bridged Mode (default adapter). Then I launched Bonjour and was able to connect to the shared Canon MP830 printer, and retain the connection.

    There are newer Parallels build, I have not tried them yet to see if this gets corrected.

  2. Bit poster

    PM780 Crash

    I have build 1970 Parallels and a Canon MP780. Everything is fine and connected XP Pro recognises the printer. When I request a document to be printed Windows crashes and restarts but leaves Parallels untouched. I dont have USB autoconnect turned on so I hav to manualy select the printer. Any Ideas.
  3. Purplish

    Purplish Forum Maven

    Try tje Bonjour for Windows solution which is documented elsewhere in this thread. You may have to uninstall the printer drivers from XP. I would reboot both OSX and the Printer after doing this.
  4. rleonetti

    rleonetti Bit poster

    Network Printer Success

    All of what is below I have tried in parts before without success (over the last 6 months) I took one last shot at it and was successful this time.
    1. I uninstalled the printer drivers from previous attempts
    2. In MAC OS I enabled "printer and fax sharing."
    3. In parallels Win XP:
    a. I used the original printer install disk to install the printer
    b. I used Bonjour and it found an installed the printer (generic/generic ps)
    It would sure have been nice to had some reply from Paralles to repeaded cries for help!!!!!
  5. Bit poster

    I still can't get anything to work. I tried rieonetti's steps. I still get the message "You do not have sufficient access to your computer to connect to the selected printer."

    Here's my setup:
    1. Parallels is running on my MacBook Pro.
    2. The printer is connected to an older iMac. It is shared, and the Macbook Pro prints on it just fine.
    3. The MacBook Pro connects to the network via an Airport.

    I can't connect the printer directly to the Macbook Pro, since this would leave the rest of the users on the network without printing any time I go on a trip, a situation which my wife would not find forgiveable.

    I'm beginning to think Parallels isn't worth the hassle.
  6. drval

    drval Pro

    Have you sent this to
  7. straight_up

    straight_up Bit poster

  8. bigbob

    bigbob Member

    unable to print with R2400 Epson

    I was unable to print using USB - Bonjour works with Generic Postscrip. As a photographer wanting to print using the Epson driver and profiles is unavailable. Is ther any way to use the Epson driver with Bonjour? bigbob
  9. cmclenn

    cmclenn Bit poster

    I have been trying to get my printer working for hours. I tried to get it working as a USB device and it worked last night and then stopped working and I could not get it to work again. Next I tried to set up a network and get the printer to work off there and everytime I tried to pprint my parallels shut down so I came to this site and tried to download Boujour. I downloaded it and went to generic and then when it was about to finish downloading it stated that I do not have suffficent access to my computer?? I have no idea what that means. I sent up printer and windows sharing in my system preferences (on the mac), I am pretty sure I set up a network onto my computer and had a printer set up but nothing would print when I sent documents to it. I have a HP Photosmart 3200 and I am getting frustrated as an program I could only use on a PC has a document that I need printed for an assignment!! It was working last night so I did not think I had a problem but then it would try and re-install everytime I opened parallels. Please help!! Crystal
  10. pmattf

    pmattf Bit poster

    USB Printer Problems with 3150

    I have an old HP 932c inkjet and an Epson R1800 photo printer both attached via USB to the Mac, and I am running Parallels 3150.

    The HP shows up properly in the USB Devices menu, and seems to work fine.

    However the Epson (which I really need access to so I can print with QImage) shows up as "USB 2.0 Printer (Hi-speed)". When I attach it, I can not print to it. If I run the Epson status monitor, it pauses a very long time, saying "Searching...", then eventually comes up with a message saying "Communications error" (if I turn off the printer, or do not attach it, a message comes up immediately when I run the status tool).

    Does anybody have any suggestions on what I should try? From reading this thread my impression is that if I set it up as a network printer I won't be able to use the Epson drivers and profiles? If that is true, there is no point.
  11. Hugh Watkins

    Hugh Watkins Forum Maven

    problem solved in one

    i had an older Belkin USB 2 hub which I connected to a mac USB port and the printer, scanner and camera card reader to the hub

    I downloaded and installed the latest Epson drivers and utilites for WinXp and it all worked first time - with lots of head cleaning

    Epson have no driver for this older printer for Mac OS 10.4.8 so I was a great work around

    they recommended a generic driver for the mac

    >> EPSON have not produced OSX Intel compatible drivers for your particular printer. There are alternative drivers available from the following web site:

    Please be aware that these drivers are not produced by EPSON and as such we are unable to support them technically or guarantee their function.<<

    My cry for help answered within 24 hours
    thank you Epson support for brilliant service for a 5 year old printer

    good luck

    Hugh W
    Last edited: Feb 4, 2007
  12. pmattf

    pmattf Bit poster

    There are Intel drivers for Mac OS X for the R1800 on the Epson site. I downloaded them, and it seems to print fine from the Mac side, it is only from Parallels that it does not work.
  13. baldeegle

    baldeegle Bit poster

    Hi, I am in exactly the same situation trying to print to the Epson R2400 from Qimage through parallels 3150. I did get the commmunications error as you did, but found that the connection would be re-established for a moment before disappearing again. This would continue to happen. I managed to achieve a perfect print from Qimage through parallels - when the printer re-established contact (and lost the connection again). It seems to be a bit hit and miss at the moment.
  14. pmattf

    pmattf Bit poster

    I have only actually tried to print once -- since then I have just been trying to get the Epson tools to recognize the printer. Once or twice it has gotten through after a long delay and shown the ink levels, so I think we do have the exact same issue.

    Since my old HP works, and it shows up in the Devices menu as an HP-930 printer, I think the key is in the fact that the Epson is showing up in devices as a generic USB 2.0 printer. But I have no idea where that is coming from.

    At this point, I am just going to hold on to the PC that I just migrated to Mac from, keep the Epson attached to it, and remote desktop in when I need to print. That seems more convenient than restarting into Boot Camp every time I need to print, which seems like the only other alternative at this point.

    I would encourage you (and anybody else with this issue) to send in a support request to Parallels, so they realize it is high priority.
  15. baldeegle

    baldeegle Bit poster

    After my last post I tried sending a number of print jobs to the epson R2400 via qimage. (6 in all). Each job printed perfectly, in full, every time. Sometimes it would locate the printer after a search and start printing (using the epson driver and displaying the ink levels and printing progress as usual). Ocassionally it would show a communication error, but by reactivating the job in the print queue the printer would again locate the printer and start printing. Once the print job got going there was no longer a problem with commmunication. I can live with this at the moment (after all this is a Beta version), I'm just pleased to see that it can work as I had previously tried with the 1970 build with no joy at all.

    I will report this issue to the parallels team.
  16. sader1055

    sader1055 Bit poster

    USB connection problem?

    I tried as most of you had said using bonjour, but when I ran the wizard, it told me that no printers were availible. Also, when I connect my printer to the xp in parallels, it is giving me a little popup box saying that the device is being used by another process and can't be accessed or is blocked or something along those lines. I wasn't using?


  17. sader1055

    sader1055 Bit poster

    Change from last post

    It finally recognized my printer not 5 min after my last post. However, now it's telling me that I "don't have sufficent access to my computer to use this printer." Does anyone know why it's telling me this?

  18. SDTBFT

    SDTBFT Bit poster

    bounjour download wont run

    how do I get the file to open and install the program?:mad: :confused: :mad: :confused:
  19. SDTBFT

    SDTBFT Bit poster


    How do I install and setup bonjour?

    I hae downloaded the mac and windows versin of it

    but when I slect to open either rom the download screen or on my desktop---ot wont install--noapplication associated or somethinsg??????:mad: :confused: :mad: :confused:
  20. ttclett

    ttclett Bit poster

    gentle people,

    after reading this thread, I downloaded bonjour from the Apple site, installed it on my VM and following your directions - generic encapsulated postscript - I have got the following printers to work with my MacBook on my wireless system:
    Brother MFC 210C inkjet multi
    Brother HL5140 laser
    Epson Stylus Photo R800

    I did have to go into the various Macs and turn on Sharing in the Print/Fax System Prefs.
    I did have to go into each printers Properties in WindowsXP and select page setup and media choices. All printers worked even with the host computers sleeping.

    Cheers, Terry

Share This Page